iCON QCon Pro G2 (+Extender) MIDI Remote Script

Hi all,

I recently started a port of my X-Touch script (X-Touch (+Extender) MIDI Remote Script (MCU mode)) for the iCON QCon Pro G2 / QCon EX G2, so this thread is for feedback and discussions related to it. The script and its documentation are available at my cubase-mcu-midiremote repository on GitHub.

Cheers!

6 Likes

Hello, I have had the following problem to control the input busses with icon… maybe you have the solution in your script?
Thank you!!

Hi @Jose_Cardell,
like Cubase’s own MCU implementation, my MIDI Remote script excludes input and output buses. If you’d like to include them, you can open the script file with a text editor, search for .excludeInputChannels() and remove it. I’m thinking about adding some config options to the top of the script file to simplify channel visibility configuration a bit. Until then, just removing .excludeInputChannels() should do the trick.
Cheers!

2 Likes

Thank you very much for your response, but where is this command file script located?? Sorry, I have never done it.

Hey, no probs – when you follow the setup instructions, you know where the script is located. Also, I didn’t mention this earlier: After editing the script file, you’ll have to restart Cubase so it will pick up your change.

1 Like

I think this would be a very good choice my friend!
I did something similar by moving options to another file, just for it to be a little easier for the end-user, since not everyone knows javascript and that’s not a bad thing at all when we’re making music :slight_smile:

1 Like

I’m going to work on it, but I don’t understand why they natively eliminate the input channels, they take away functionality from the table

Thn u so much!!

Ok, the “local” folder is empty, inside the “driver script” folder there is a “json” file and inside the “.api” folder there is a file called “midiremote_api_v1.js”, is that it? ?

I have modified that file by removing “exclude” but it doesn’t work either.

Hi, you’ll need to follow the setup instructions one-by-one first. The script you’ll edit in the end is the one you download during that process.

but I don’t need to download any file, it’s just modifying the one that already exists?

Nope, you’ll be downloading the MIDI Remote script for your QCon. Just follow the instructions to the very end. After that, you can modify the script, but you should go through the instructions first to set it up and make sure everything works without the modification.

Ok, I work it ;o)

Excuse me, is it strictly necessary to install the icon firmware? I didn’t do it… directly in the studio configuration in Cubase the machine recognized me

I don’t know – the script was developed for and only tested with firmware version 1.13. Regardless, updating the device firmware never hurts.

SOLVED!!
I have downloaded the script and modified it, but since I work with hardware instruments through MIDI, I also put the midi channels in the mixing console, what I don’t understand is why I put two channels for each midi channel, I deduce that I put one channel audio linked to that midi channel. The problem is that I had all the channels messed up on the mixer and I only wanted the input busses, so I modified the script by overriding the midi channels that I don’t need to control with the mixer, just to create the midi mapping…
Thnx u so much to all!!! <3

2 Likes

Hello again!!
I have seen another “small” problem, it is that the audio channels are mixed with the input busses, That is to say… instead of all the audio channels being together (ch1 to ch16) and the input buses together (bus1 to bus16), they appear on the mixing console ordered as follows: ch1 bus1 ch2 bus2 ch3 bus3… …
This makes it very difficult to mix.
Do you know any way to get them organized?

Hi,

It depends how did you implement it in the script.

Myself, I would implement it so, that if you press the Input button, it would control the Inputs. If it’s disabled, control the Channels.

In the script I only enabled the input buses and disabled the midi channels, I have not touched anything about the order that the channels appear in Icon.
Do you know how to get all the channels of the same type to appear together instead of mixed? because it is very annoying to have:
fader1 (icon) = audio1
fader2 (icon)= bus1
fader3 (icon)= audio2
fader4 (icon)= bus2


You know??
Previously, the same thing happened to me with the midi channels and that’s why I disabled them, but obviously I can’t disable the audio channels.

Hi,

How did you do this? Which line of the code you change? What was the original code, what is your new code?