imac yosemite 5k

I have a new 5k imac and comes preloaded with Yosemite… and I can’t downgrade to Mavericks

I bought the new imac as I read on here that the Nuendo would be compatible with Yosemite when the official version came out. And now it’s not going to be til Feb!!

Don’t know what to believe as this was out road computer… and I go on the road in Jan.

What’s the real schedule here? Anyone got a clue?

Would we be allowed to use Cubase 8 in the meanwhile?

http://www.steinberg.net/forums/viewtopic.php?f=194&t=71367