Import multiple MIDI files at once

I tried to import via the file nenu, drag and drop from Win Exploiter and also from the MediaBay to get more than one MIDI file into Cubase at once. I’ve also searched the forum. It’s not possible. I don’t think I’ve ever tried this before since … umm … I apparently don’t have the need, so it’s not much of a show stopper and I won’t jump ship.

But from the little collection of drum loops I just generated it would be such a great feature I need to request it. I started with a simple drum loop and edited the drums by moving the notes around and listen. First loop simple then it got better and better and finally it was not bad at all. Now I had this idea of getting all the permutations on a long line in reverse order which would mean from simple to complex. I stepped backwards with CTRL+Z and I used the in-line edtor (remember that one?) to watch the notes dance backwards and disappear as I moved towards the big bang of my project. Every now and then I saw a version I liked so I closed the in-line editor and dragged and dropped the MIDI part to a Win folder. Eventually I had 19 MIDI files.

Now I wanted to drag them into Cubase again and expected to get the same dialog as when I import multiple Audio files, including the option to import to one track or multiple tracks. Nope …

I searched the forum and found some people who had more than 19 files, would you believe it!!! The had bought collections of a few thousand files and wanted to audition them, but not by importing them one at a time.

You should be able to do this in Cubase, right?

[edit]

Oh, I forgot one other thing I was thinking of to get it right from the first try. Let the MIDI parts retain their names from the MIDI files they came from, if “Parts get Track Names” is turned off. “Parts get Track Names” is a brilliant feature, but not when importing multiple MIDI files. Thanks …

Incredible that Steinberg still hasn’t fixed this. You can import multiple midi files in most other DAWs including Reaper.

Cubase cannot import multiple midi files and Cubase 12 has not fixed this.

I have clients who expect me to work in Cubase and Cubase is very good at manipulating midi so here is a work around which takes about 30 seconds and saves a lot of frustration if you have Reaper.

Drag and drop all your midi files into Reaper and choose ‘seperate tracks’.

Then export from Reaper using these settings:

Consolidate Item: Choose ‘Whole Project’
Consolidate Midi Item: Choose ‘All’
Then choose ‘Multitrack Midi File (Type 1 Midi File)’

Reaper will then export the Midi as one file and when you import into Cubase you will find all your files on seperate tracks, which is presumably what you needed.

In Cubase Edit/Preferences under midi file/ import, replace Halion in the drop down menu with ‘Midi Tracks’.

It’s worth buying Reaper just for this work around if you’re working in Cubase and often need to import multiple midi files.

Cubase is so good in most respects it really should have fixed this years ago.