In Editor when moving a note it extends the note

When I am trying to move a note in Editor with the key cursor it automatically starts to extend the note instead of moving it… This makes me crazy please help me out…

Which editor (drum, Key, Score, List, sample maybe…) ? And what is the ‘key cursor’ ? I have searched for it through the whole 1391 pages of the Cubase Pro Operation Manual, to no avail…

Hi thanks for replying.
I mean the key editor (midi editor). In the menu of the editor where you have the tools to cut, delete, paste etc there is an arrow on the left to move a key.

When I start moving a key it starts to extend the note instead of moving it.

Hope this helps to understand.

EDIT - Forget what I wrote previously, as the time stretch applies essentially on the associated controllers of a given note, sorry.

Simply be sure that you are ‘drag and dropping’ from the center of the note involved, otherwise the note might be extended (when the mouse cursor appears as a double opposite arrow).

Hi Thanks,
it still cuts the note in pieces every time I drag the note… I just want to move the note I dont want the note to be cut.

I don’t get how a note could be cut when simply attempting to move it… :thinking:

So, could you post two screenshots of the Key Editor, one before the move attempt and another after it, showing the result of the motion ?

Hi sorry hereby:



You can see that two notes have been cut as I try to move it with the arrow


I was thinking, you have the Split tool selected instead of the Object Selection tool. But at your screenshot, I don’t see any tool selected in fact. So what tool do you use, please?

I use the arrow tool to move a note (to make it shorter for example). Instead of making the note shorter it starts cuting as you can see:


Are you sure, there are no double-notes bellow the one you are moving?

Use MIDI > Functions Delete Doubles.

Hi no. I have made a short video of what happens how can I send you this?

See Uploading files

I am unable to upload a gif below 4mb otherwise I cannot show you what happens.
So is there any other solution?

So the Selection Tool image is doing the exact same thing as the Split Tool image ?

Upload it to giphy and then give us the link:

It does look like you have notes sitting on top of each other to me, like @Martin.Jirsak has mentioned.

Try selecting one note that acts like this with the arrow tool (i.e. click on it so it changes colour), and then press the cursor down button on your keyboard and it will move it down on the screen.

You’ll soon see if there’s another note hiding behind it.

I tried to move the double note as skijumptoes (nice nickname btw;) mentioned and indeed this seems the case. How is this possible? This must be since I have my new midi keyboard (nektar panorama t6). Why does this double all notes? What can I do to prevent this?

1 Like


It seems the keyboard is sending the MIDI Notes via 2 MIDI Ports. Double-check Studio > Studio Setup > MIDI Ports Setup. Do you have any MIDI Port doubled? Do you use multiple MIDI Driver types?

Yes Martin indeed this must be the problem if I am correct

I am not sure why there are 2 ports active on In and Out. Never had this. Would the ports reset be the best option?


This is not the MIDI Port Setup.