Incompatible EuCon software version detected??


Installed CB Pro 8, V 8.0.20.

After starting, the message

Incompatible EuCon software version detected

Installed adapter version: 7.0.1
Installed EuCon software version: 2.7.1

Please download and install the EuCon software recommended on Steinberg website, reinstall the EuCon adapter and restart your application.

  1. Never seen before!!, V 8.0.10 did work perfectly with this setup
  2. No issue named in this regard on Steinberg website nor there is a recommended software
  3. I WILL work for various reasons with EuCon V 2.7.1, because all newer versions does not work properly!

Any ideas and/or suggestions?
(To summarize: EuCon V 3.2.2 does not set fader to 0dB with shft+fader on Artist Mix)


Yea… Cubase 8.0.20, and Nuendo 7 now require that you use the latest EuControl ver. (3.2.2), or the Steinberg EuCon adapter will not engage! :smiling_imp:

I rolled back to Cubase 8.0.10 almost immediately because of the reason you cited regarding the broken functionality of EuControl 3.2.2!

There are other issues that are directly related to Cubase 8.0.2 that also made me feel confident that this was the right move for me!

I value the flexibility of the Artist Controllers in conjunction with Cubase Pro 8, but with Steinberg making a broken version of EuControl a requirement to use the EuCon devices with Cubase, and Nuendo… I’m suddenly faced with the idea that it’s time to start looking for alternatives to the Steinberg offerings!


Hi Al

Thks for your Information - OK, does not help to solve the problem, but ensure me to roll back to 8.0.10 as well.
(After two(2) hours of de-installing and installing various EuCon versions with no success!)

It’s really hard to believe, that no one is aware of these problems (neither Steinberg nor AVID) :frowning:



I must admit, that I didn’t accept to be forced by a software to not using the AVID Artist gear.

So, I tried and tried and tried to make the system work and finally accepted as well, that the Artist Mix will just hardly go to 0dB after pressing shft+fader wit v 3.2.2. (sometimes it’s really a mess…)

As well as I have to find out, that der EuControl “never” shall be placed in the Autostart folder - gives an Error, because does not linking with the Ethernet adapter (is just starting up too early)

OK, now

  1. Starting the Audio Computer
  2. Wait some time…
  3. Starting EuControl (it’s really working like this :wink:)
  4. Starting Cubase v. 8.0.20
    Voila - The system is running as it should - so far no abnormal issues noticed… :wink: