Incorrect recording of Midi note placement in relation to metronome and editor grid

I purchased Cubase 12 Pro in the sale a few months ago. I feel I may have spent alot of money on an over hyped/rushed new version. A long time ago I used cubase every day to produce a lot of work. Back then we were all concerned with audio as the machines of the day could barely cope. Not a thought was given to midi. It was always rock solid.

Recently I have noticed that my work seemed “slushy”. Further examination showed that the midi notes recorded were way off the beat. Im a reasonably proficient keyboard player and can usually hit a mark ±6ms. The recordings were showing notes recorded upto 60ms before I had hit the key.

After several weeks of research I decided to do a few tests.

The first involved routing midi out to via a looped midi cable. Then based on various advice given in forums, articles and the knowledgebase here, tested various settings in Studio Setup. I tested lots of variations.

  • Midi Port Setups including : Windows midi device, DirectMusic drivers, WinRT MIDI and emulated variants .
  • The above with System Timestamp
  • logical and random combinations of the above

The best result from the above test was approx ±3ms Jitter and lag of 6ms (Jitter incl) NB all notes placed later than control.

This I thought although not great was workable.

Then I tested each of the above combinations playing a midi controller through the interface. Wild !! Best I could achieve given variations of my playing was on average 20ms recorded before the note was “played”. This was frustrating. Which led to me reading further and testing all the suggestions I could find ie “setting up a daw on win 10” - Steinberg knowledge base, reinstalling the operating system, altering the bios, testing with RTL Utility, testing an alternative midi interface and controller (see below). Plus lots of variations with the Audio System settings in Studio Setup like turnig off Adjust for Record Latency, changing 64 to 32 bit float etc. The permutations of doing all of these tests is very time consuming. So pointers with explanations behind the reasoning would be very useful.

From my reading I believe that the metronome sounds a number of samples before the actual timing should be placed to take into consideration latency. I rendered the click and could get good midi recordings if I moved the audio forward and then recorded midi.

In conculsion, I believe the timing engine is miscalculating the number of samples and feeding that error to the metronome.

Equipment -

midi controller - Nord Lead 3 (plus tester - maudio 88 keystation pro)
Focusrite Scarlett 2i4 (2nd Gen) Firmware 1051 Driver 4.102.4
Cubase 12 Pro - Version 12.0.52 Build 393 - Built on Nov 24 2022
Windows 10 with all updates. Fresh install with microsoft bloatware removed and just the focusrite propriatry driver plus cubase 12.
Optiplex i7 6th gen 32gb ssd latest bios and firmware (dedicated audio machine)

2 Likes

Man, I can’t believe this is STILL an issue in 2023. I dealt with this crap for years over several different versions of Cubase and was never really sure what the proper combination of settings was and if it was ever actually corrected. I’m getting PTSD just reading this (although you are much more calm and collected than I ever was lol). How can Steinberg call this pro software when one of the most basic processes required to make music is faulty?

TBH this is one of the reasons I ultimately (and recently) made the switch to Mac. I apologize if that is an unhelpful statement as I know how annoying the whole Mac fanclub mentality is, but this is one stressor that I’ll never have to deal with again. I hope you find a less costly solution.

3 Likes

Agreed it’s really strange it has not had any priority for many years. It’s broken and has been for many years. Also there is no clear option or solution to solve it. They added a few boxes to tick just so you feel you can try to remedy and then blame you for not ticking the right useless box when it’s still broken. And dont get me started with having to move weird files into folders I have never encountered, I have never seen this kind of solution in any other software, maybe pre 2000. Only conclusion is Steinberg doesn’t take midi seriously which is the main tool for most composers.
Rant over

1 Like

Here’s a possible (should be unnecessary) fix. Use a sample for your click and edit the sample to have the appropriate ms of silence at the beginning?

I am having exactly the same problem.
Do you know what?
I am using Voyetra Sequencer on a Intel 286 with MS DOS 5 and a Sound Blaster 16 midi interface now.
Zero latency, I really mean zero. Finally I got my timing back!
This is a machine from the late eighties and the sound blaster from 1993.
Why is it so hard to get midi working with modern machines? Just annoying.
Sorry, I know this isn’t a practical advice…

1 Like

Ok, I just tried another DAW on the same machine I have the problems with Cubase. Works out of the box with the other DAW. Midi notes are recorded and played back perfectly on time (besides my latency roundtrip of 8ms) and not 60ms to early. Also this DAW has no dongle or such. It is getting easier and easier to move away from Cubase.

2 Likes

As suspected Steinberg have know about this problem for approx 10 years. They pretend they don’t know about it hoping you will go through support and be worn down with endless attempts at a workaround. But basically there isn’t one. The company needs to warn potential purchasers that if they want to record accurate midi, the may not be able to with their software !

System Timestamp not helping with early MIDI notes - Cubase - Steinberg Forums