input from audio interface seems to work, but recordings are all blank

Hi, I’m having a really weird issue.
I have a pair of mics connected to the Steinberg UR22C Audio Interface, and am trying to do a recording using Cubase. (I am on Cubase 10.5.12, Mac OSX Mojave)
I set everything up according to the manual of the UR22C, and according to all the explanations I could find online (in the Studio–Audio Connections and Studio-Studio setup parts of Cubase). I even checked the “audio midi setup” settings of my mac to make sure the audio interface is selected as the input. On the track i’m trying to record to, I can see the volume monitor meters (or whatever that’s called) move as I’m testing the mics, so it’s definitely reaching Cubase. (The audio interface also works properly when I use it for Zoom meetings and in other applications - so no issue with the drivers, which are current)
But, when I actually record, the file that is created is totally blank - silent, nothing on it. I’ve tried everything I could think of, and am out of ideas.

Here is a video of a screen-recording of me showing the options in Cubase and showing the recording that ends up blank, even though on the left you can see that audio signal is coming in.
Has anyone here encountered this? Am I missing something in how I’ve configured things (I try to show all relevant options in this screengrab), or is it some kind of bug?
I had hoped that getting the audio interface by Steinberg would work extra-smoothly in Cubase…
https://www.dropbox.com/s/5ud3gx8wzi7drat/cubase-example-norecordingdata1.mov?dl=0

One thing I was surprised by is that I cannot select the built-in mic or speakers in Cubase once I’ve selected the audio interface - but maybe that’s normal, that one cannot mix & match and use the built-in audio for output, and an audio interface for input? But in any case, this is a minor issue - my main problem is that the recordings are blank.

That meter you are looking at in the Inspector is not for the signal going to the Track. The meter for the Track is the black rectangle all the way to the very right edge of the Track under the magnifying glass icon. You’ll want to see a signal there.

I think what you are looking at is an inspector tab for your audio interface (notice the tab is named UR22C). I don’t have anything like that on my system (even hidden) and guess this is showing up because the UR22C is more tightly integrated into Cubase than my 3rd party interface can be. That meter is most likely showing you the signal at the UR22C, although I can’t confirm that for sure.

Probably you haven’t set the input for Track to be the UR22C. Expand the top tab labeled “Audio 01” and in the slot labeled ->] select your input for the Track. Now if you have Monitoring enabled on the Track you should see the Track’s Meter moving and recording should work as expected.

Regarding the computer’s audio, Cubase requires the use of an ASIO driver for the audio interface and only one can be active at a time. You could use the Generic ASIO driver that comes with Cubase to access those system devices, but then you couldn’t use the UR22C. Folks do use ASIO4ALL when they want to access multiple audio interfaces. Reports are that this generally, but not always, works fine. However it will increase your latency a bunch.

thank you so much for your reply!
I did set the input and outputs for “audio 1” as UR22C. I was showing the UR22C tab to show that the signal was coming in. So Cubase is getting it, but is not routing it to audio 1 correctly.
Here is another short video of the audio 1 tab, showing the input device. I think this is correct…
Any other ideas what I should try? I could try a different driver, but since the audio is reaching Cubase (just not showing up on the recording) I think the driver is probably not the issue.
https://www.dropbox.com/s/kyxl3roeytqxzq9/example2.mov?dl=0

https://www.steinberg.net/forums/viewtopic.php?f=283&t=187069

I agree it doesn’t seem to be the driver since it is seeing a signal. All the settings also seem correct from what I can see.

One odd things I noticed at he very end ~0:43s you are in the Inspector Tab, but what is being displayed doesn’t look like a normal Inspector. Probably not part of your problem, but I wonder what’s happening.

If you look at the buss you named UR22C in the MixConsole does it show a signal (FYI if you toggle the Automation Write button on then off in the MixConsole that buss will then show up in the Project Window so you can watch it there too)? If not that suggests that suggests isn’t set correctly in Audio Connections (although it looks right to me).

Take a deep look at the entire signal path from the Input to the audio Track. Check that the Pre Gain isn’t turned down on either Channel. Or maybe an insert that has its output level set to 0 - stuff like that.

OMG - that did it. thank you svennilenni! It turns out that Cubase wasn’t allowed to access the microphone by Mac OS X – even though somehow, I could see signal coming into the UR22C in Cubase… but it wasn’t allowed to actually record.
Apparently it’s just a problem for Mojave and Catalina (so starting with Mac OSX 10.14).
I recently upgraded to Mojave and was never asked whether Cubase is allowed to use the microphone… I think Mac OS X set it to no, because I had never clicked “yes”…
Anyway, now it works. Thank you so much for your help!! And thank you for the other replies too!

You´re welcome.