inserting lyrics in non European language


While inputting lyric in Korean, I found a unique behaviour which could be of Dorico, of Qt or of macOS. I think it could be the same for other non-European languages.

  1. space key does not work when the input language is Korean. I must change input language to English to let white space key. E.g.: "bye ". So I always switch the input language from Korean to English and from English to Korean.
    • works correctly after pressing space key, but the white space is added after a syllable. Pressing “-” twice adds “-” after a syllable and proceeds to the next note the popover. E.g.: “some-” “what”.

Could it be changed inside of Dorico team? It seems to be very complicated to solve it.

Dorico works fine with the IME, at least in our supported languages of Chinese and Japanese, but you do generally have to hit Space twice, once to confirm the choice of word from the IME, and once to advance to the next position.

The IME in Windows and macOS have different behaviours.
I only installed Dorico in macOS, and hitting space twice does not work as your description.
Hitting spacebar in Korean IME just inserts white space without proceeding to the next note.
To proceed to the next note, I should use the right arrow key or switch the input language to English.

Regretfully, there are no music notation software applications which support the Korean language, not only in the term of menu language but also in term of text input in lyrics and other text. The Korean music market seems to be very small, unfortunately.

Well, K-pop is a $700m international industry, but I guess it doesn’t use notation software much :wink:,_21st_edition)

Could this chart be referred to in developing language support in Dorico?

That’s a lovely idea, prko, but Steinberg is a German company (owned by a Japanese company) and Dorico’s development team are English. I would imagine that they have fairly detailed figures on who’s buying their products in which countries. Naturally that’s a slightly circular issue: if they don’t develop Chinese or Indian versions then they won’t pick up many customers in China or India.

Yes, of course!

Regardless of political and historical conflict, good products will, however, be bought by the users in the world, and attractive culture will be spread worldwide.

Just one more thing to say: the translation of GUI might be not so crucial as the optimised text inputting/displaying feature. If the product is useful enough, some users in the local communities will translate the documentation.

PyongRyang, what particular IME setting are you trying to use? On macOS there are five different options for Korean language input.,_22nd_edition) is probably more relevant. “Total number of speakers”, not “number of native speakers”.

I am using 2-set Korean. Most Korean (at least in South Korea) use it. I am attaching the keyboard preference window:

We’ve been looking into inputting Korean lyrics into Dorico and we now understand the issue. We are hopeful that we will be able to improve support for typing lyrics using the Korean input method editor in a future version. Thanks for bringing this to our attention.

Thank you very much! :wink:

Today I have installed Dorico SE on a Windows machine

This problem does not exist under Windows 10 Pro.

  • Under Windows, pressing spacebar moves lyric input box to the next note even when Korean IME is activated.
  • Under macOS, pressing spacebar does not move lyric input box to the next note even when Korean IME is activated.

We haven’t made any changes to the way the Korean IME is handled on macOS since you reported this issue. It remains on our backlog for a future version.

I understand that my request could be much delayed because I see there are too few Koreans who are using Dorico at present. :wink:

But if you encountered an issue with the Korean IME, I can imagine it might also affect other scripts, like Chinese and Japanese, which have several text entry methods.

We produce localised versions of Dorico in Chinese and Japanese and have special handling for their IMEs. We know what is required to fix this for Korean, we just haven’t yet had a chance to do it.

Another year gone by, a very peculiar one at that. But wondering if we will be seeing this fix soon? Or is it still farther down the list of fixes?
Also if rather than extender lines (which aren’t used in most Korean notation) hyphens could be set as default when inputting Korean.

I’m afraid as yet we’ve still not implemented this fix, but we’ll try and get it done later in the year. Sorry for the inconvenience in the meantime.