Key Commands and non-Latin Input Source

Dear developers and the users,

I previously reported that spacebar in lyric popover does not work when Korean-IME is activated under macOS.
https://www.steinberg.net/forums/viewtopic.php?f=246&t=156135&p=838865&hilit=lyric+korean#p838865

This occurs still when using Dorico 3.1 under Catalina. I think the developer team need more time to fix it.

Today, I would like to report a related issue to my previous report.
Usually, I do not use Korean IME when using Dorico. However, Korean IME remains after typing Korean lyrics, and none of the key commands works.

Could the key command work as usual even though non-Latin-based IME is selected?

No, if the IME is active, then Dorico doesn’t “see” the key command in the same way, I’m afraid.

Ok, thanks for your kind explanation.
It’s a problem I should get used to.

Dear developers,


Today I have installed Dorico SE on a Windows machine.
Under Windows 10 Pro, Dorico works correctly even when Korean IME is activated.

  1. All popovers work when using Korean IME with Korean Input.
  2. All key commands work even when using Korean IME with Korean Input.
  3. Pressing spacebar moves lyric input box to the next note even when Korean IME is activated.

Under macOS,

  1. No popovers are evoked when Korean IME is activated
  2. Most key commands do not work properly when Korean IME is activated
  3. Pressing spacebar does not move lyric input box to the next note even when Korean IME is activated.


    Could these issues under macOS be easily fixed? If not, I should consider using Dorico only under Windows when working with Korean text.

By clicking a password input box under macOS, Windows, Linux, Android and iOS, Korean IME is temporarily disabled and Latin_based IME is activated even though Korean IME is selected.
Could the algorithm of the password input box be a solution to this issue?

You don’t need to double-post. It’s double the reading for everyone. :wink:

Dear Dan,
I am sorry for double posting, but they differ slightly from each other…


Dear Daniel,
I tested key commands with Chinese and Japanese IME under macOS.

  • Key commands work well even though each of the three Japanese input methods is activated.
  • Key commands do not work when one of the Chinese input methods is activated.

As I mentioned in my last post in this thread, Dorico should block non-Latin based input systems, but allow them only

  • in text input boxes invoked by pressing “cmd + l”, “cmd + x”, “shift + cmd + x”,
  • in prefix and suffix boxes for dynamic, tempo and rehearsal of the properties panel,
  • in comment boxes, and
  • in music symbol editing boxes.

I do not know how these could be implemented in Qt and in programming environments. If my diagnosis and suggestion are only wordy and make no sense, please ignore it simply. :wink:

This issue was first reported around 2016. It’s now April 2022 and still not fixed. I cannot but keep using Sibelius instead. It is very disappointing.

I believe the holdup is Qt-related. I have this kind of problem (which I reported a long time ago myself) when using the Dvorak-QWERTY layout which is intended to revert the keyboard layout to QWERTY only when the Command modifier is pressed, thus in theory retaining QWERTY keyboard shortcuts while allowing Dvorak text input. Some things work, some don’t; it’s hard to predict. The best bet is to type “bilingually” at this time.