Inter-app audio feature not available (?)

Hi everyone,

the Cubasis manual says I can use inter-app audio by selecting inter-app in the instruments list.
In fact, the inter-app feature does not appear in my instruments list.
I wanted to connect to Xewton MusicStudio which supports inter-app audio.

I run Cubasis 2.3.1 on an iPad Pro 9.7 with iOS 11

Why does inter-app audio not at all appear in my instruments list?
Who can help? :neutral_face:

Best,
Hartmut

Hi Hartmut,

Cubasis supports both IAA audio and IAA Midi.
It always depends on the app instrument/effect manufacturer, what IAA type is supported.

IAA Midi

  • This option works for MIDI tracks (and effects)
  • Tap the instrument icon in the track list and browse the Inter-App Audio folder
  • Pick an IAA Midi capable instrument from the list

IAA Audio

  • This option works for audio tracks
  • Open the routing tab in the inspector
  • Tap on Mono input to open the Audio Inputs selection
  • Tap the “Inter-App” button
  • Pick an IAA audio capable instrument from the list

Please also have a look at the “Limitations of Inter-App Audio” article available here:
https://www.steinberg.net/forums/viewtopic.php?f=183&t=104551

Best,
Lars

Hi Lars,

thank you for your reply.
What you wrote is, what I had already figured out from the online manual. I have also read the article about the limitations of inter-app audio.

But the problem is that the item “Inter-App Audio” does not appear in my instrument list.
I made two screenshots:
http://gaumedia.de/screenshots.html

Here you can see that I even do not have the option to use “Inter-App Audio”.

So what can I do?

Best,
Hartmut

Hi Hartmut,

Gave it a short check on the latest Cubasis 2.3.1 (fresh install) with the same device (iOS 11.1.2 here).
IAA folder shows up as expected.

Best,
Lars

Hi Lars,

I have obtained Xewton Music Studio some days ago, because it works quite well and it has excellent orchestral instruments.
Then I read about Cubasis and I tested out Cubasis LE in demo mode. I liked Cubasis a bit more than Music Studio, but I did not want to dismiss the orchestral instruments of Music Studio.
That said, I decided to buy Cubasis, because I have read that inter-app audio allows me to use Music Studio as a node for Cubasis. So I relied on this feature.

But it is not available on my machine!

I have a new iPad since two weeks, everything is up to date (incl. iOS 11.1.2) and I uninstalled Cubasis and installed it again. But the problem still occurs.

Sorry, but the fact that you do not have this error on our device, does not help me.

What else can we do?

Best,
Hartmut

I solved the problem:
Cubasis only lists the item “Interapp-Audio” in the instrument list, when there is at least one IAA node app installed on the system. When I installed Nanologue, the Interapp-Audio item appeared on the Cubasis instrument list with Nanologue as a subitem.

This is a bit confusing. It would be better to have the item “Interapp-Audio” always listed in the instruments list as it is in the Effects Tab.

Xewton Music Studio is supposed to appear as Interapp-Audio instrument, because they say it’s an IAA node (since version 2.5.1), but this is a problem I have to solve with them.

Best,
Hartmut

Good morning Hartmut,

Thanks for the update.

When there are no IAA instruments or effects available, it is not possible to display the appropriate folder.

As stated above, it depends on the instrument/effect manufacturer what IAA formats they offer.
Music Studio can be used for IAA audio, and works as expected in our testing.

In this context, please note that Apple has introduced the Audio Unit format some time ago, which can be somewhat seen as a successor to IAA.
The Audio Unit standard provides more flexible option compared to IAA, and many instrument/effect manufactures support the format already.

Please have a look at one of our available tutorials (at around 6:45 minutes) to learn more about AU support in Cubasis: https://www.youtube.com/watch?v=TNZ_WeD7Z-4&feature=youtu.be

Hope that helps!

Best,
Lars