Is Hyper Control No Longer Supported?

I know my Axiom Pro is a very old keyboard, so I wouldn’t be surprised if the HyperControl protocol is no longer supported in Cubase 11.

In Cubase 10.5, I could press the Mode button on the Axiom and it would bring up a list of plug-in parameters on its screen, that I could then control with the endless encoders. I’ve just noticed that this isn’t happening in Cubase 11.

It seems I can still control the parameters with the encoders, but I no longer get them displayed on the Axiom screen. I have the hypercontol.dll file in the right place - and all the other Hypercontrol functions seem to be working fine.

I wonder if anyone knows if this is down to discontinued support, or if I should be looking for an issue that’s causing it.

I had one of those few years back - thought they were dead.

Is there an entry under Studio Setup > Remote Devices for the axiom? Just check that the MIDI Out port is correct in there. It used to be hypercontrol port you had to select and from that extension is where the screen is updated I believe.

There was also another file as well as the .dll that you had to copy wasn’t there? A custom file or something they called it. They had them for different DAW’s.

1 Like

Hi,

MIDI Input to receive the data by Cubase. :wink:

1 Like

Just to clarify, they said everything was working other than the screen feedback, so presumed it’s most likely the input is correct, but the output was either not connected or going to an incorrect port.

No doubt it’ll be something different entirely, the easy fixes never work! :slight_smile:

2 Likes

Hi

Thanks for the input. Everything’s set up as it should be, I think. I’ve spent many, many hours trying to get obsolete hardware working with modern software, so I’m more familiar than I’d like with the sometimes infuriating Studio Setup menu. :slight_smile:

I’ve double checked everything, and it all seems right.

I’ve just been over all the Hypercontrol stuff again, and from what I can make out there is just the AxiomProCubaseHyperControl.dll ‘personality’ file that needs to be in place. Could be wrong though - I too have a distant memory of another file.

A bit more fiddling has revealed that whilst most of the Hypercontrol functions seem to be working, there are other areas (in addition to the screen feedback) where it’s behaving oddly. So, either there’s something wrong in my set up that I’ve not spotted yet, my Axiom is on the blink or Steinberg’s (very welcome) modernising of the Remote Devices set up has rendered the old thing obsolete.

I wonder if anyone out there is still using Hypercontrol with Cubase 11?

I really hope so, I was quite pleased to read that you’re still using them - my controller died but always loved the integration it offered - NI’s integration using wrappers for parameter controls, which I moved to, I really don’t like.

Maybe it’s worth replying on this heavily populated thread?

It may wake up some of those that have posted before, or you could ‘accidentally’ tag @jaslan into this conversation. Ohh oops! :slight_smile:

Hehe. Good idea. Thanks.

It’s still a really nice keyboard. I’ve tried others - thinking I should update - and I haven’t found a reasonably priced one with a keyboard action to match yet. If the worst comes to the worst, I’ll just put it in generic midi controller mode and use its knobs and buttons that way.

Quick update. I realised I still have Cubase 10.5 installed, so I opened that - and Hypercontrol is working perfecly in there.

I can’t think of anything that’s changed between C10.5-C11 that would affect this not working- I could understand if an O/S update or change broke it as the underlying extension would fail. But I’ve got very old components running that have remained to this day - mainly as the underlying functions of Cubase have barely changed in years.

Maybe try removing the Axiom remote device from the studio setup screen, and then adding a new one perhaps? That may give it a kick… somewhat desperate suggestion, I know. :slight_smile:

Like you say, perhaps the under the hood work of the new MIDI API has broken a link somewhere, as there has to be some fragments of that development in C11.

Yes, I’ll try a remove and re-instate. I do know that Cubase’s interaction with my main midi controller (an ancient Tascam US-2400) has got more robust and reliable since the upgrade to v11, so they’ve obviously been working on that side of things - and perhaps Hypercontrol has been an unintended casualty.

OK - that worked! Many thanks for the suggestion. I removed the Axiom remote device and added a new one. I feel a bit of an idiot for not trying that myself, but I’m very grateful for your help. :slight_smile:

1 Like

Yes, HyperControl is working in C11 here. The HyperControl installer installs in the C7 directory, I think, so you have to move it.

2 Likes

Thanks Jaslan. All working now.

An odd little update here - I’ve found that I have to delete and re-instate the Axiom Pro in Studio Set Up > Devices each time I start Cubase, if I want the full Hyper Control functionality. Not sure what could be causing this…?

Hi,

Does other settings remain after Cubase restart? Doesn’t Cubase crash silently while quit?

Hi

Thanks for replying. Everything else is absolutely normal. I start Cubase and everything is normal - except that Hypercontrol is not working fully - as outlined in my first post. I go to Studio Set Up > Devices and delete the entry for AxiomPro - I then add a new Axiom Pro entry. At this point all the Hypercontrol functions start working perfectly.

Unfortunately, the next time I start Cubase - we’re back to the Hypercontrol functions not working properly and I have to do it all again. As I say, everything else is behaving as normal. No crashing or freezing or anything at all. If I never pressed the ‘Mode’ button on my Axiom - I wouldn’t know there was even an issue.

When it’s running ok, do you see any .xml file related to it in C:\Users\USERNAME\AppData\Roaming\Steinberg\Cubase 11_64 ?

I know generic remote setups save in there, but I’m not sure about third party extensions - But those settings must be saving somewhere. Makes you wonder if they’re not being read correctly each time you start Cubase up, or maybe not saving as it should.

Just an idea, really.

I agree, it does appear as if something is being written somewhere - causing the error. I’ll have to have a poke around. Thanks for the tip.

Well - I never did get it working without an off-and-on-again in Cubase 11. The good news is - I just popped the hypercontrol.dll into cubase 12 and it worked straight away. No messing about. :smiley:

1 Like