Is it possible to hide the barline under a bar-repeat number?

As shown in the screen shots below, Sibelius (top image) hides the bar line under the “2”, but Dorico doesn’t.

I prefer the Sibelius way - it’s cleaner. Is there a way to get Dorico to do this?

I didn’t see anything in Layout/Notation/Engraving Options or in Properties (unless I missed it).

Thanks!

2-bar_repeat_Sibelius

2-bar_repeat_Dorico

I run into this all the time, and it would be great if Dorico would have a setting to automatically erase the background here. For now my workaround is to just input a few non-breaking spaces as Shift-X text, switch to Engrave, select Erase Background, and position the spaces. With the current drawing order that will erase the barline but not the 2. You can then copy it elsewhere as needed.

If you run into this all the time, why not do this?

2 Likes

Because it never occurred to me to do that :man_facepalming: That’s a pretty great fix, thanks!

Thanks, Leo!

That certainly works, but it took me quite a while to figure out how to do this, not being very experienced in the edit window. This kind of change should be in Engraving Options, IMO.

I agree it would be good if Dorico could handle this automatically. I’ve made a note of this requirement.

2 Likes

I used @pianoleo 's work-around (see above) for a project in Dorico 3.5.

When I open the project in Dorico 4, it looks like this:

2-bar-repeat-Dorico-4

Resetting the number 2 in Library menu > Music Symbols… > Bar count 2 (bar repeats) puts it in the correct location, but the bar line is no longer hidden:

2-bar-repeat-Dorico-4-reset

How can I put a white background behind the “2” again, to hide the bar line?

When I try Leo’s method in Dorico 4 I can drag a white rectangle on top of the 2, but when I click “Z order” to move it to the back, it jumps up to the right, and I can no longer move it - neither dragging it nor changing offset values has any effect.

Suggestions?

Anybody?

Dorico 4 seems to have broken Leo’s fix (unless I’m missing something…). See my previous post.

All I can say is that this does appear to be broken here too. Sorry.

1 Like

It would obviously be preferable for Dorico to do this automatically, so we’ll make sure that it does, as soon as possible.

3 Likes

Regardless, there’s a bug report which is that it used to be possible to layer glyphs behind each other in music symbols in either order, and now it isn’t.

1 Like

I don’t think that’s quite it, Leo. There is definitely a change, yes, related to the changes we made to try to improve the relative positioning and scaling of music symbols used in chord symbols. Please see this earlier thread:

1 Like