[Issue B-14022] Workspaces

I thought I would have a look at this Workspace business, but I don’t think it is working correctly, unless I am misunderstanding what it should do.

I have set up a workspace on two screens comprising the Project window with the Transport panel below it on one screen and the Mixconsole with the Inserts rack visible on the other screen.

This worksplace has been saved as ‘global’ on the Workspace tab. It is the only workspace I have defined.

I then saved the project and closed N7.

After relaunching N7 I selected the project from the top of the Recent Projects list, but only the Project window and the Mixconsole were displayed - no Transport panel.

I tried closing and re-launching again and this time only the Project window was displayed.

Is this correct? - I understand from the operation manual that the global workspace will be used in the absence of a specific Project workspace.

If I select my Global workspace after launching a project it does display all the correct windows though.


Did you try to call the workspace, you stored?

There is also preference, which could affect it. Check Preferences > General > Open Project in Last Used View, please.

Yes. The last sentence in the previous post states that.

And yes, that option is set in Preferences/General.

How is it set? There are 3 different options (Always, Never, For external projects), how to set it.

If you call the Workspaces, can you see the MixConsole time in the Windows menu? This give me hint, if the MixConsole window is open or close.

Good Morning Martin,

It is set to ‘Always’.

I’m sorry, but I don’t understand what you mean by ‘call the Workspaces’ and ‘MixConsole time’.

FYI, I have just launched N7 for the first time today and opened the same project and it did display the correct Workspace - Project window, Transport panel and Mixconsole.

I then immediately closed N7 without touching anything else, and immediately re-launched it. This time the Transport panel was not displayed.

I then immediately closed N7 again without touching anything else, and immediately re-launched it. This 3rd time only the Project window was displayed!

There definitely appears to be a bug here.


By “call the Workspace”, i mean, to select it in the Worskpaces menu.

“MixConsole time” is typo, I ment “MixConsole item”.

Could you send me the “Window Layout.xml” file, which you can find in the Preferences folder > Presets, please?

Selecting the workspace from the workspace menu does work correctly. The issue seems to only relate to N7 automatically using the Last one used or the Global workspace.

I tried to PM you the .xml file but the PM system does not accept .xml files!

Where should I send it to?

Can you see the MixConsole item in the “Window” menu list, please? Then, we could know, if the window is open (and hidden), or close.

No, MixConsole is not on the Window drop-down menu.

I have done this process now three time and every time it has the same pattern - On the first launch all three windows are displayed, on the second launch only the Project and Mixconsole windows are displayed, and on the third launch only the Project window is displayed.

I see, it meens, the MixConsole is not open. Thank you, I will try to reproduce it with your Winow Layout file later today. I will inform you back.

The N7.0.35 version history refers to B-14022 WORKSPACES which appears to relate to the problems described in this thread (see OP), but it does not fix the issues.

The issues remain unfixed.

Either B-14022 fixes some different problems or it fixes nothing. I know what my money’s on.

All best wishes for the new year to all the official Steinberg testers and all of the other testers not employed by Steinberg who actually pay for the privilege of being testers (that’s us) :wink:

N7 is, nevertheless, a great update.

I’ve also found a strange issue with Workspaces.

I have a 2 monitor setup. My main monitor is in front of me. The second monitor is ABOVE that mounted on a monitor arm.

I put the MixConsole on the second monitor (the upper monitor) and maximize the window.
Then I save the workspace.
When I recall the workspace, the MixConsole is displayed on the primary monitor in front of me, not where I saved it on the upper monitor.

Workaround: When I move the MixConsole to the upper monitor and slightly adjust the window size of the MixConsole (not have it full screen but have 1-2 pixels to the edge of the monitor on each side, and THEN save the workspace, it works. I can recall it.

Somehow Nuendo doesn’t like maximized windows on second monitors (or it only happens when having monitors above each other). Either way, it’s a bug. Minor and with workaround, but a bug.