ISSUE: Strange behavior of solo button

I am used to clicking on the solo button on a track to, well, solo that track to listen to it in isolation, and then clicking solo again to then hear it in context of the full arrangement.

That usually works, but not in this case:

Here, I have a project with a couple of synth (VST instrument) tracks (they happen to be frozen but that doesn’t make a difference). A few of those tracks have mute automation:

When I solo the first track (that does not have mute automation), it will then also solo the two following tracks (that happen to have mute automation) - but I wanted to solo just the first track that I clicked solo on!

To make matters worse, when I click on the solo button on the first track again (to un-solo it), it then mutes(?!) that track, and leaves the other two tracks that Cubase decided to solo (without me touching the solo button on them) on solo:

What a mess!

The only way to get out of this is to click the global solo button, which will allow me to clear all these various unwanted mute and solo states and get back to a sane place.

It’s curious that this happens only with tracks that have mute automation on them, so it must somehow be related to that.

Is this somehow “as designed” behavior and I just don’t understand why it’s acting like this (in which case I would love an explanation), or is this simply a bug?

It’s because the Automation is telling the Track to do something different than what you want. Try Suspending the Automation before you Solo the desired Track.


An alternative approach is you can use the L Listen button to emulate a Solo if you set the Listen Dim level to -infinity.


1 Like

That is it - thanks @raino! I really appreciate you sharing the Listen workaround, I shall try that.

I will also say that while this technically makes sense, I would argue it disregards user intent. When I hit the Solo button, I … mean it. So I would have expected Cubase to be smart enough to ignore any mute (and just mute, no other) automation on that track when Solo is engaged, and re-enable that mute automation when I un-Solo that track.

So, maybe we need a “Solo, but I really mean it” button?!

1 Like

Just to close this out - using the Listen button meets my needs 100%, so that’s the solution here!

I’m having a related issue with the solo button, has this been resolved?