Issues with downloading Cubase 12.0.10 in the Steinberg Download Assistant

Maybe the server is so busy right now…?

@hide Have you been able to download the update? We can’t see any issue on our side.

Now I’m getting this error after launching the SDA. :cry:

then this.

@hide, could you check if disabling your firewall or antivirus or VPN solves the issue?

I’m using ESET, and no VPN. I tried turning off the ESET of AntiVirus as well as the Firewall feature but still no luck. Should I download Cubase v12.0.10 individually? If that’s the case, could you give me a direct download link?

Strange. Here you go: Cubase Pro 12 Downloads | Steinberg

1 Like

I see! I’ll give it a try. :slight_smile:


Do you have the SDA installed on the system C drive, please?

hmm… I could open the SDA but this issue came again.

By the way, I downloaded “Steinberg_Download_Assistant_1.32.1_Installer_win.exe”.

Yes. I installed it on the C drive(system drive).

I also have ESET and had no issues upgrading the SDA and then Cubase to 12.0.10.

I’m using Windows 10 Pro. :slight_smile:

I just discovered the log file in the folder “AppData\Local\Steinberg Download Assistant\logs”.
Here is the log(Timezone is JST)… But I almost gave up to install via SDA. I’ll install v12.0.10 individually. :sweat_smile:

2022-04-13 22:56:57.793  INFO 3684 --- [JavaFX-Launcher] o.s.boot.SpringApplication               : Starting application on ...snip for security... with PID 3684 (C:\Program Files (x86)\Steinberg\Download Assistant\app\Steinberg Download Assistant.jar started by house in C:\Program Files (x86)\Steinberg\Download Assistant\app)
2022-04-13 22:56:57.793  INFO 3684 --- [JavaFX-Launcher] o.s.boot.SpringApplication               : No active profile set, falling back to default profiles: default
2022-04-13 22:56:58.984  INFO 3684 --- [JavaFX-Launcher] n.s.e.d.d.a.internal.Aria2Configuration  : Aria2 Installation found. Starting ...
2022-04-13 22:56:59.025  INFO 3684 --- [JavaFX-Launcher] n.s.e.d.c.SystemInformationServiceImpl   : getPid() - This JVM's name is '...snip for security...'
2022-04-13 22:56:59.026  INFO 3684 --- [JavaFX-Launcher] n.s.e.d.d.aria2.internal.Aria2Process    : Start Aria2: C:\Program Files (x86)\Steinberg\Download Assistant\3rd Party\optional\aria2\aria2c.exe, --enable-rpc, --rpc-listen-all=false, --dir=G:\Downloads\Steinberg, --auto-save-interval=1, --retry-wait=5, --max-concurrent-downloads=5, --max-overall-download-limit=0K, --max-tries=5, --stop-with-process=3684, --file-allocation=falloc
2022-04-13 22:56:59.056  INFO 3684 --- [Thread-7] n.s.e.d.d.aria2.internal.Aria2Process    : stream: 04/13 22:56:59 [e[1;32mNOTICEe[0m] IPv4 RPC: listening on TCP port 6800
2022-04-13 22:56:59.382  INFO 3684 --- [JavaFX-Launcher] n.s.e.d.d.r.PersistedDownloadRepository  : Loaded 41 persisted downloads
2022-04-13 22:56:59.443  INFO 3684 --- [JavaFX-Launcher] n.s.e.d.c.UserAgentServiceFromSystem     : getUserAgent() - User Agent: Steinberg Download Assistant/1.32.1 ({"ClientBits":"32", "OSName":"Windows 10 Enterprise", "OSVersion":"10.0 (19041.1.amd64fre.vb_release.191206-1406)", "OSBits":"64", "OSLanguage":"en_US", "AriaVersion":"1.18.10"}; +
2022-04-13 22:57:01.441  INFO 3684 --- [JavaFX-Launcher] o.s.boot.SpringApplication               : Started application in 3.885 seconds (JVM running for 4.542)
2022-04-13 22:57:01.442  INFO 3684 --- [JavaFX-Launcher]       : Java Version: 1.8.0_312
2022-04-13 22:57:01.443  INFO 3684 --- [JavaFX-Launcher]       : Java Home: C:\Program Files (x86)\Steinberg\Download Assistant\runtime
2022-04-13 22:57:02.930  INFO 3684 --- [JavaFX Application Thread] n.s.e.d.selfupdate.SelfUpdateService     : SelfUpdate completed ... there is no newer version available...
2022-04-13 22:57:02.942  INFO 3684 --- [JavaFX Application Thread]    : Restoring persisted authorization
2022-04-13 22:57:02.955  INFO 3684 --- [JavaFX Application Thread]    : Refreshing authorization
2022-04-13 22:57:02.963  INFO 3684 --- [JavaFX Application Thread] n.s.e.d.o.t.TokenRequestClientNimbus     : Requesting tokens with grant refresh_token
2022-04-13 22:57:03.289  INFO 3684 --- [JavaFX Application Thread] n.s.e.d.o.t.TokenRequestClientNimbus     : Successfully retrieved tokens
2022-04-13 22:57:04.111  INFO 3684 --- [JavaFX Application Thread] n.s.e.d.o.u.UserInfoRequestClientNimbus  : Successfully retrieved userinfo
2022-04-13 22:57:04.111  INFO 3684 --- [JavaFX Application Thread]    : Updating authorization successful
2022-04-13 22:57:04.604  INFO 3684 --- [tornadofx-thread-1] n.s.e.d.r.RuntimeComponentServiceImpl    : Found the following installed runtime components: [eLicenser Control, Steinberg Library Manager, Steinberg Install Assistant, Steinberg Activation Manager]
2022-04-13 22:57:06.882  INFO 3684 --- [tornadofx-thread-1] e.d.g.r.RuntimeComponentUpdateController : No updates of runtime components necessary.
2022-04-13 22:57:13.875  INFO 3684 --- [JavaFX Application Thread] n.s.e.d.g.d.DownloadChoiceController     : START Cubase Pro 12.0.10 - Application (required)
2022-04-13 22:57:13.882  INFO 3684 --- [JavaFX Application Thread] n.s.e.d.i.WindowsInstallHelperAccess     : Start Install Helper
2022-04-13 22:57:15.537  INFO 3684 --- [JavaFX Application Thread] n.s.e.d.i.WindowsInstallHelperAccess     : Install helper is available (attempt 2).
2022-04-13 22:57:15.538  INFO 3684 --- [ForkJoinPool.commonPool-worker-25] n.s.e.d.d.aria2.DownloadServiceAria2     : start() downloadChoice: Cubase Pro 12.0.10 - Application (required) State: NOT_STARTED
2022-04-13 22:57:15.539  INFO 3684 --- [ForkJoinPool.commonPool-worker-25] n.s.e.d.d.a.DownloadArtifactServiceImpl  : start() downloadArtifact: G:\Downloads\Steinberg\WIN64\Cubase Pro 12.0.10 - Application (required)\ State: NOT_STARTED
2022-04-13 23:00:09.474 ERROR 3684 --- [Thread-7] n.s.e.d.d.aria2.internal.Aria2Process    : stream: 04/13 23:00:09 [e[1;31mERRORe[0m] CUID#10 - Download aborted. URI=
2022-04-13 23:00:09.475 ERROR 3684 --- [Thread-7] n.s.e.d.d.aria2.internal.Aria2Process    : stream: Exception: [] errorCode=2 Timeout.
2022-04-13 23:00:09.475  INFO 3684 --- [Thread-7] n.s.e.d.d.aria2.internal.Aria2Process    : stream: 04/13 23:00:09 [e[1;32mNOTICEe[0m] Download GID#92fd6b6aa98fb352 not complete: G:/Downloads/Steinberg/WIN64/Cubase Pro 12.0.10 - Application (required)/
2022-04-13 23:00:14.899  INFO 3684 --- [ExitApplicationEventHandler] n.s.e.d.c.ExitApplicationEventHandler    : Exit application now.
1 Like

You have nothing in your windows hosts file blocking access? I mean, you’d know if you had altered that - so doubtful.

But I applied a list of ad-blockers in there once based on a website guide, and it killed an adobe download tool many months later, spent hours working out what was causing it (duh!).

1 Like

My hosts file is so simple and there is no customized…

# Copyright (c) 1993-2009 Microsoft Corp.
# This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
# This file contains the mappings of IP addresses to host names. Each
# entry should be kept on an individual line. The IP address should
# be placed in the first column followed by the corresponding host name.
# The IP address and the host name should be separated by at least one
# space.
# Additionally, comments (such as these) may be inserted on individual
# lines or following the machine name denoted by a '#' symbol.
# For example:
#          # source server
#              # x client host

# localhost name resolution is handled within DNS itself.
#       localhost
#	::1             localhost

i’ve only just discovered Windows Sandbox, don’t really know anything about it, other than, maybe it could be used for testing something like this(?). ie, not sure if Sandbox uses your system settings, or if it’s an actual separate virtual OS.

My system doesn’t use any kind of VM(ex. Hyper-V) now. And yes… I know about the Sandbox but it’s a little complicated to install just the Cubase using VM configuration. (Haha, I’m actually a server engineer and I know what it is! :wink:)

1 Like

So your drive G references on that log is ok and can be written to?

And what if you try to ping ? Does it resolve with the dl server?

System Time/clock is in sync?

Yes, of course, my G drive is fine to store any files. And I can connect “”, for example, I could download the latest C12 with this endpoint URL already. But… if possible, I’d like to install the latest C12 via SDA.

I wonder what would happen if you uninstalled both the SDA and SAM, then only installed the SDA first.