Issues with using Musical Mode for audio

Hey, I am having some issues with changing audio clips to musical modes.
Sometimes - when I change an audio clip from linear to musical mode, it stays the same, both in it’s musical position and it’s linear position until I change the tempo - than it reacts to it. This is the desired behavior. The problem is sometimes it doesn’t happen - sometimes the audio changes (gets longer or shorter, probably by tempo changes, it is unclear what is even the original state of the tempo track that it calculates by. This is my first question - how to ensure audio doesn’t change while changing to musical mode?

Second issue: Let’s I changed an audio to musical mode, made a change to tempo, and than changes back to linear mode - the audio snaps back to its original position ( before the tempo changes) - which is understandable, but still weird considering MIDI doesn’t do that. With MIDI, I can set the track to musical mode, change the tempo, set the track back to linear mode, and it will play the same. So my second question is - how to change audio
from musical mode to linear mode without changing the way it is played?

I suspected it’s a problem because audio wrapping must be nondestructive, so I “rendered in the place” the audio, to get a new version, which matches the tempo without stretching, the problem is, issue number one is often happening in that case.

If you wander why do I even need this - it’s useful when I’m doing “tempo matching” in which I sometimes want to change tempo to match an existing track by its time, and sometimes change tempo to have the track follow, thus it is useful to switch between the two options. Sometimes - and this is the weirdest - toggling the option doesn’t get you back when you started! and clickc the audio multiple times make it shrink or move on the track like a weird caterpillar.

Can somehow clarify how those works? And explain in details how to solve those issues? I suspect it has something to do with wrap tabs but I couldn’t figure out how to fix this myself.

Sounds like you are confusing 2 different concepts - this is very common BTW because of the way things are named.

First there is no such thing as Linear Mode, however there is a Linear Timebase (and a Musical Timebase).

Musical Mode only applies to audio files and it is either on or not. If it is off the length of any Audio Event based on that file will not change as the Tempo changes (you’d want this for a gunshot cue for video). If Musical Mode is on then the Audio Event will expand and contract with the Tempo (you’d want this for a vocal part).

Musical/Linear Timebase only applies to Tracks- both MIDI & Audio. This controls which timeline (Minutes/Seconds or Bars/Beats) the Events & Parts on the Track are anchored to. Say at tempo X bar 8 is at 5:00 seconds. If you opened 2 Rulers, one Bars the other Seconds, and put a Part on a Track at bar 8 then you can see how these work. When you change the Tempo you’ll notice the relationship between the Rulers also changes. If the Track is in Musical Timebase the part will always stay on bar 8 although where it is in mm:ss will change. But if the Track is in Linear Timbase then the Part will always be at 5s but its location in Bars/Beats will change.

Several things can mess up how Musical Mode works. Cubase fairly often doesn’t get the tempo of the Audio File correct (even though you just recorded it at 110bpm in Cubase :unamused: ). Make sure to verify and set the tempo to the correct value before turning on Musical Mode for the file. If you have something like a comped vocal where you’ve used clips from different takes those can cause issues especially if the same audio is used in multiple sections, like a repeated chorus. That can cause Cubase to try and stretch the same bits of audio differently. The solution, as you found, is to render and work on a clean audio file.

There are several threads here that cover the nuances of this in detail. Worthwhile to search them out.

…and this is a really good explanation as to how it works (and how to understand it better).
To the OP, seriously read through this and carry out raino’s suggestions until the concepts (which aren’t obvious until you understand them) click into place.

@raino Thanks a lot for the explanation, this did clear things up.
Render in place did work for me most of the time, but I found myself in a situation where it didn’t, thus the frustration.
I also tried to “Export Audio Mixdown” and re-import it, which didn’t work either, but resulted differently.
Here’s a screen shot of the original, the render in place, and the export audio mixdown, after setting the later two’s Musical Mode ON, along with the tempo track.

I expect the length of the audio to remain like the original, but it didn’t.
Note the trouble begins only a specific aprt of the audio, which is aligned until bar 34. (You can see it visually)
I suspect it might be related to my rendering setting, so there they are:

Can you please help me figure out what went wrong? Did I miss something here?

Disable musical mode for that “Render in place”-clip…!?

Your render settings look fine to me. Although I almost always include a tail so I don’t accidentally cut something off - but that won’t effect this stuff.

Hard to tell exactly what got messed up with your rendering attempts but most likely it was because the settings for the Mode & Timebase weren’t the correct combination. Plus the results will also vary depending on if the Tempo Track is active or you are using a Fixed Tempo at the time of the rendering.

It’s a good idea before you start to mess with Tempo or Pitch to use Save As… to capture a clean ‘before’ copy that lets you get back to a known state if needed.

Obviously I can’t since this will ruin timing completely. The whole point is keeping the same timing, but with “musical mode” on.

Have you tried? The clip already has the timing / tempo information included from the rendering. If you now set it to musical mode, the tempo track will be applied once again.
From theory but without having tried, I ˋd say you have to „set definition from tempo track“.

Posting for future readers:
I have found that this issue does not reproduce if you makes sure the audio clip starts and end on measure lines (use “snap to grid” for that), before using render in place.
I guess this is a bug…?

I see in the discussion you missed a point.
Cubase manual states “Switching between linear and musical time base results in a very small loss of positioning precision. Therefore you should avoid switching repeatedly between the two modes.”

As soon as we create an audio track, better we decide if we want it in either musical or linear time base and avoid switching

if your purpose is “doing “tempo matching” in which I sometimes want to change tempo to match an existing track by its time” consider also to use the function “set definition from tempo” for a smoother result, an excellent tutorial below