Jerky zooming

Hi,

I’ve always had “low quality audio waveforms” turned on in the arranger because I was running Cubasis on an iPad 2.

Now that I have upgraded to an iPad Air 2 I thought that I’d change the audio waveforms to high quality.

I was very surprised to find that zooming in and out in the arranger can be extremely laggy. I’m currently working on a track that just has 12 audio tracks in it, and the zooming in and out is shockingly jerky. Because of this I’ve switched back to low quality waveforms.

I thought that the iPad Air 2 would be more than capable of zooming smoothly with this option turned off.

Was I wrong? :slight_smile:

I know that this is a comparatively minuscule issue, but I’d appreciate your feedback if possible. Does the arranger zooming need optimising?

Many thanks

Hi,

Sorry for the inconvenience! Would you mind sharing your project with us so we can have a closer look? You could upload it to dropbox for example and send me the link in a private message.

Thank you!
RG

Hi RG,

Thanks for your response,

I have just tried to upload the project to Dropbox for you, but unfortunately I’ve just encountered an issue with Dropbox that prevents me from doing this! :slight_smile:

I get an error when trying to upload the project to Dropbox using Cubasis. Cubasis goes through the process of making the files smaller for the upload, and then cancels the upload and gives an error message. I’ve attached a screenshot to show you the error.

To reproduce the latency issue with scrolling and zooming, you can use the “On and on” demo project to reproduce the issue, although it isn’t nearly as bad as it is in a project with a few extra audio tracks, such as the one I tried to send to you.

Scrolling around is smooth if tracks are zoomed right in and scrolling is smooth if tracks are zoomed right out, but there is a window between these two points of zoom level where zooming is very jerky.

If you look at the second attached image that shows the arrange screen, this is the level of zoom (horizontally and vertically) that causes latency.

I hope that you’ll be able to improve this.

Many thanks
image.jpg
image.jpg

(Just remember to turn “low quality audio waveforms” off) :slight_smile:

Hi again,

sorry to hear dropbox is not working right away… can you give this topic a look about it please?

http://www.steinberg.net/forums/viewtopic.php?f=183&t=57401

as an alternative you can export via itunes and then upload the project in your web browser to dropbox or any cloud service of your choice:

Please find all of them described in the In-App help of Cubasis as well:

http://www.steinberg.net/fileadmin/files/PRODUCTS/Apps/Cubasis/Cubasis_Help/Index.html

  • Connect your iPad device with the computer
  • Launch iTunes
  • Click the “iPad” button from the top menu
  • Choose “Apps” in the following window
  • In “Apps” view scroll down to “File Sharing” and select “Cubasis”
  • Afterwards all Cubasis related documents will appear to the right
  • Drag & drop the “Projects” folder to the desktop to create a backup of all your projects
  • To create a backup of all files all it takes is to drag & drop all of the folders…

To transfer files from the computer back to Cubasis simply drag the desired files to the “Cubasis Documents” folder in iTunes.

Thanks!
RG

You don’t need a particular project to reproduce it.It was never a pleasure to use high quality waveforms,no matter what device (Air 2 currently).You just need a slightly higher (audio)track count to encounter the lag

Thanks for backing up my point Crabman :wink:
Steinberg - Please look into this issue further - You don’t need anyone to send you a project to reproduce the issue. Just open ANY project with a medium / high audio track count and turn low quality audio waveforms off. Then zoom in and out and scroll around to experience the surprising level of lag.

Many thanks for your continued work to make Cubasis great.

Any further news on this?

Thanks for your time :slight_smile:

Hi Dancore, Hi all,

All displayed audio files have to be read out for an accurate and correct presentation in the arrange window of Cubasis.

Depending on the number of audio files of your project and the zoom rate this can take more time with the result of slowing down the system.

While “High Waveform Quality” should work well for most standard cases, we’ve introduced the “Low Waveform Quality” option to get around lagginess when working with bigger projects combined with higher zoom rates.

Best,

Lars