Key command for 'Edit instrument channel settings' ?

Similar to this thread: https://www.steinberg.net/forums/viewtopic.php?t=68897 - from Cubase 7.
I’d like to be able to open the ‘edit instrument channel settings’ using a shorcut cause I must press that button every 10 sec.
I only have 8.035 where it’s not possible - you can only assign it to open the MIDI edit, which is not what I want. I want to open the audio track for whatever VSTi I’m using. Is that possible in 8.5?

Hi,

It worked to me, here. Key Commands > Edit > Edit Channel Settings. Assign your own custom Key Command.

Yes, this has worked in every version of Cubase for as long as I can remember.

Nope. That’s what I don’t want. That just brings up the MIDI settings for the MIDI channel. I want the audio settings.
You know ‘edit instrument channel settings’, not ‘edit channel settings’. So I take it it’s still not possible in 8.5 then?

If the Audio Channel/Track is selected, then the Edit Channel Settings window appears.

Or do you mean for the Instrument track? Then you have to select the Instrument Return.

I can’t seem to find ‘instrument return’ anywhere in the key commands list?

No, there won’t be any audio channel selected as I’m working on MIDI tracks.

You know, I load a VSTi, create a MIDI track for that VSTi and now I want to EQ it, but I don’t want to have to press the little ‘e’ button every time, so a shortcut would come in handy. But is it possible to assign?

Why don’t use “Instrument Track” instead of “Midi tracks” ?

You know what, I just tried that. I’d never used instrument tracks before.
And yes, the key command does work.
However, with instrument tracks you load an instrument on each track, right?

So, seeing that 90% of my tracks consist of multi out instruments, eg. Kontakt and Omnisphere, how do I go about doing that? I definitely don’t want to load 15 instances of Omnisphere.

simply load your instruments in the track instruments and select your track instruments / right clic / add Midi tracks (choose the number you want), and all the midi track gonna be plugged to your instruments track with midi channel /2/3/4…
But you gonna have better performance if you load 8 Kontakt in eight instruments track than loading one kontakt instance with 8 different intruments Inside !

If I’m doing this right I get 1 instrument track and the others are MIDI tracks, which then can’t use the shortcut.

I’ll have to test whether 8 instances of Omnisphere requires the same amount of CPU/RAM as one instance with 8 channels. I think it might not do.
But at least it’s a option if I want to use the shortcut.

not same thing on memory but better CPU management…

I have a macro for doing this which I’ve tied to a key command.
It’s quite a long winded macro but it works.

To elaborate on this a bit. The reason you get better CPU performance from multiple instances of a VSTi rather than a single one is because modern CPUs have multiple cores. If you load a single instance of Kontakt and run 8 instruments in it, all of those instruments will be running on a single core with the potential to max out that core even if others are doing nothing. If instead you have 8 instances of Kontakt their load will be spread out across all the cores. So it better balances your CPU usage.

That said it really doesn’t matter if MIDI or Instrument Tracks use more CPU as long as you aren’t at risk of maxing out your CPU. A computer is always consuming all of its CPU capacity, it is either used doing something beneficial (e.g. running Kontakt) or thrown out because there was nothing useful to be done at that moment. So if there is some feature of Cubase that makes life easier for you but it also consumes some CPU you should use that feature because the CPU potentially consumed would just be wasted if it wasn’t used - this of course assumes you aren’t at risk of using all the CPU.

Interested in your macro for this. please share??

Thanks

I’m also interested in that Macro! Please, could you share it with us?

Has there been any updates on this issue?

Luga01, woud be interested in seeing your macro as well

Hello, sorry, I haven’t been monitoring this post for some time.

The first part of the macro opens the default ‘edit channel settings’ window (the one we don’t want to see every time)
Then you have to add ‘Focus - Forward’ exactly 25 times. This moves the focus to highlight the ‘E’ button on the channel which will open the instrument channel settings instead.
Lastly add ‘Focus - Confirm’ which effectively selects the ‘E’ button.

Save the macro and bind it to a keypress.

One very important point is that you must have the ‘Show Output Chain’ button highlighted at the top of the edit settings window for this to work. If the first time you use this macro it seems like it’s still opening the old ‘edit channel settings’ window then highlight the button just mentioned then the macro will work properly forever more!

The macro is as follows…

Edit- Edit Channel Settings
Focus - Forward
Focus - Forward
Focus - Forward
Focus - Forward
Focus - Forward
Focus - Forward
Focus - Forward
Focus - Forward
Focus - Forward
Focus - Forward
Focus - Forward
Focus - Forward
Focus - Forward
Focus - Forward
Focus - Forward
Focus - Forward
Focus - Forward
Focus - Forward
Focus - Forward
Focus - Forward
Focus - Forward
Focus - Forward
Focus - Forward
Focus - Forward
Focus - Forward
Focus - Forward
Focus - Confirm

Hope this helps someone. Russ

Hi Russ

Thank you for your reply, it’s a very clever work around! However I’m still having one problem perhaps someone might be able to address:

I have some instruments that have multiple outputs and the midi channels that are routed to the additional outputs don’t show the correct output chain with that macro. See attached picture…
The output chain always defaults to Output 1-2 (in this case “Hi Strings”)

I can get it to show the correct output by changing the outputs in the inspector then changing them back, however this doesn’t save when I close the project and reopen it.

Has anyone encountered this problem and have a solution?

Thanks,
Dylan
Screen Shot 2018-05-20 at 4.49.11 PM.png

You’re right, Dylan.

This is an obvious bug in Cubase that needs to be sorted.

Russ

Hi,

I tested this with Cubase 9.5.30 and it works as expected here to me.

So I add a MIDI track. In the Output tab I set HSSE Out 2. Save project, Close, Reopen. The HSSE Out 2 is set.