Komplete Kontrol Integration Issue with Cubase 13

Hi all, few weeks back, I seamlessly used my Komplete Kontrol S49 keyboard with Cubase 13 Pro. Suddenly I started facing 2 issues:

  1. There’s no direct sound when playing any VST instruments after I load it to the instrument track. Cubase records the notes I’m playing and correctly replays that back after recording, however there’s no direct sound, even if I have direct monitoring switched on. If I launch Komplete Kontrol application outside of the DAW, it works correctly.
  2. Keyboard keys started controlling some of the basic Cubase functions such as “save”, “undo”, “redo”, etc. For instance if I play C4 key, it triggers Save dialog.
    I’m adding screenshots of my settings that I found relevant. Any help would be highly appreciated. I tried to reinstall Cubase 13, updated everything to latest versions, but the issues persist.
    Thank you

Hi, I see a Mackie Control there as well. What ports is it assigned to?

Hi, besides the Kontrol S49, I use Icon Platform M for DAW controller. I don’t know how to get to exact port. Adding screenshot.

You have to remove the “All MIDI Inputs” from the “MIDI Input” port of the Mackie. Select from the drop-down menu, the port of the Icon P M, as described in its user manual. Based on the screenshot you post with your MIDI Port Setup I don’t even see the Icon there. Is it recognized by Cubase?

Furthermore, you should uncheck the Komplete Kontrol DAW-1 In ‘All MIDI Inputs’ from your MIDI Port Setup.

Yes, it’s recognized. I just had it switched off when taking the screenshots. I changed the Midi Input to Icon and it seems the problem with keyboard controlling the cubase faded away

The problem of having no sound from VST persist. I unchecked the All midi Inputs from Komplete Kontrol. Now it even does not record the notes.

After the restart, I can see the notes being recorded. But no sound at all [even in the play back mode]

Mind posting screenshots of Studio→Audio Connections→Output and Studio→Studio Setup→Audio System?

This is all I can see there in Audio connections Output

I see nothing wrong here. Maybe there’s something going on with the Control Room?

There I don’t see anything strange neither. What is surprising - it worked correctly before :frowning:

I think that perhaps you should open another thread only for the no-audio issue, since it may attract users here than can be helpful and at the moment just don’t visit this thread because of its title connected only to the Komplete Kontrol.

I have the same problem here for S61! Please help. All sliders an play-stop-rec works well, but Keys modewheel and Pitch not working! All is ok with Ableton 12!

Could you please a screenshot from your Studio Setup→MIDI Port Setup and if possible another one showing in the inspector of a track the midi port it is route to?

Here we go

And midi port setup picture