Komplete Kontrol Issue

Having a Native Instruments S61 controller i make extensive use of Komplete Kontrol so that all my VST instruments load through it and therefore i can control them via the controller and also have the lightguide on the keyboard show correctly.

With 10.5 I had no issues jumping between tracks and the displays on the controller would change as different instruments were on each track. Now in 11 Cubase isn’t telling the controller that the track has changed and therefore i end up with controller showing instrument settings for a different track. I haven’t dug further yet but my template has a few hundred instrument tracks all using Komplete Kontrol that are disabled and I enable them on demand as I need the instrument.

I reopened my project back in 10.5 and it worked perfectly, so if this is a bug in 11 then it makes it pretty unworkable for me i rely on using disabled\enabled tracks and Komplete Kontrol.

Hi,

To me it looks like setup issue. Make sure the output of Komplete Kontrol Remote Device is chosen correctly, please.

I compared all settings between 10.5 and 11 and they are the same, ive reinstalled the S61 driver and it started workng and then just randomly stopped. Fire up 10.5 works perfectly, go bac to 11 and still not workings so it some random issue occuring in 11

Kontakt 6.4.2?

No this is Komplete Kontrol its the VST that communicates with the Komplete MIDI Controllers and you load other VST instruments into it.

I have the same issue with not displaing track VST info on KK keybord, only my problem persist only when I make track duplicate.
100% bug and not some setting problem. It also works flawlesly on Cubase 10.5 for me.

Having the same issue here! I lose Komplete Kontrol connection when 1.) Making Duplicate of a Komplete Kontrol Track, or 2.) When enabling or disabling a track. #2 is intermittent; sometimes KK connects properly, sometimes not.

Both issues happened in 10.5 as well.

Seems like something to submit to NI though right?

For me with C10.5 there was no case, C 11 everytime.
There is no workaround, maybe to save some user VSTI
presets, cause with newly created tracks it works as it should. But we are loosing time…
Im 100% bug came with C11and has nothing to do with NI. Maybe the man who record youtube tutorials with new C11 functions and uses Komplet kontrol keyboard there knows something more about this issue.

One thing more is clear here, Greg works on MAC and me on PC so it is clear it is DAW!

I made a video to show the bug in action.

https://www.dropbox.com/s/ym2djbfmmhi312d/KomplteKontrol%20Disconnect.mov?dl=0

To recap, Komplete Kontrol will disconnect when:

  • importing Komplete Kontrol tracks from another project
  • enabling a disabled Komplete Kontrol track (or disabling an enabled one and re-enabling)
  • duplicating a Komplete Kontrol Track.

When duplicating a track, Komplete Kontrol will initially connect, but then never connect again once you navigate to another track.

Martin - what do you think? Still a setup issue (if so can you explain further)?

Hi,

Now it reminds me this thread (there was even bigger one of the same topic, but I can’t find it right now). It’s a bit different, but something definitely happened in the Quick Controls area in Cubase 11. I’m just wondering, if your issue could be a side-effect of this fix.

Unfortunately I have on way, how to verify this.

Interesting…the problem DOESN’T show up in 10.5. Either I have a very short term memory, or I was running into some other bug in 10.5, because I swear I’ve had issues with disconnects there as well, but bug I’m describing above is in 11 only.

Anyone found a solution to this? Ticket open with Steinberg, no response yet, stuck on 10.5 in the meantime…

This problem is still locking me out of Cubase 11. But I can’t find many people posting about this bug, mostly because I just don’t think that many people use komplete kontrol.

If you’re using Cubase 11 and komplete kontrol can you chime in to say where you’re experiencing this bug - or even if you’re NOT experiencing it?

Yes, I just noticed this, it happens for me when I enable a disabled Komplete Kontrol track as well as importing from a project, what a Pain! Steinberg PLEASE address this!!!
A workaround is to either “enable” or import tracks and then save and reload the project. Unacceptable though…