Kontakt, Halion Sonic SE, VST Instruments and Cubase 8 Pro


I have a performance issue with Cubase 8 Pro when using VSTi’s.

This can be any VSTi’s but in the project I’m using as an example, I am using Kontakt and Halion Sonic SE (HSSE).

I have an instance of Kontakt and an instance of HSSE. The HSSE instance has multiple instruments routed to different audio outputs.

I have attached an image showing the Cubase performance meter and the respective CPU meters in Kontakt and HSSE.

I am getting pops, crackles and dropouts.

I’ve been through the usual suspects…

Any help appreciated.

Such a configuration with a 4770 should not give you any trouble like that.
Any new gear added recently or is there a digital signal in your setup that mismatches the program settings ?
f.e. I see you’re using a saffire. (firewire) Did you try to do the same without using the saffire ? (f.e. with onboard soundcard (just to check if it’s audio driver related or not))

kind regards,


No new hardware or changes…

Yes, I have a Steinberg UR22 USB interface and get the same problem if I use that instead

with a 4770 you should be able to run many of those plugins at the same time. (f.e. 50 shouldn’t be a problem at all, combined, with multiple outs, whatsoever…)

  • your pictures of the meters show no spiking or no unusual high load. Do you have spikes in the performance meters when you have dropouts, crackles,… ?
  • also: dropouts mean that the audio is not reaching the driver in time. That is different from crackles and pops, which are indicators that the audiosignal that is being used is not translated as suspected. (most of the time a bit/Mhertz problem)

There is definitly a mismatch in your system, but you have to track it down.

WHat are you running in the backgroud ?
Are you using windows audio at the same time when running cubase ?
Are you listening to netwerk audio in some way when running cubase ?
Is there a proces that takes a lot of processing power away ? (performance meters are not CPU meters)
These questions because you have only 1 clock for your audio driver, if you use two different sources… that is a mismatch.

The pops and crackles appear whenever the Cubase performance meter reaches around the half-way point. Below that, it’s fine. There are more pops/crackles than dropouts.

I attached taskmanager…

For all users:

NO for Windows audio
NO for network audio

wow, that is not easy. It seems there is no issue, but there is.
Are you using external drives for the software libraries ?
If so: don’t. They have a very low transfer rate, certainly when multiple usb’s are connected.

Try to disable multicore processing in Kontakt AND Halion. Helped me and seems to be recommended…


That’s exactly the frustration! You hit the nail on the head.

No external drives.

For info, on USB I have a MIDI keyboard controller, keyboard, mouse, iLok, Cubase dongle. I have tried with the MIDI controller disconnected but it made no difference.

I did try this at first. However, with this setting on my system, Kontakt clearly had a problem with multiple instruments, as it was crackly, popping, dropping out. In many of my projects, both Kontakt and Halion Sonic SE have multiple instruments. Each instrument within the Kontakt and HSSE instances are driven by a MIDI track and the respective output routed to it’s own audio channel.

In some projects, the performance meter in Cubase goes way beyond 50%, but I don’t think it should be that high for the projects I’m working on.

And this problem is with the best setting I have found on my system ( which is Kontakt set to 4 cores, Halion Sonic set to 3 cores.) When I had Kontakt on more cores, the Cubase meter goes even higher, and it pops like crazy. I can’t seem to win with it.

If I turn multi-processing off in Cubase, it sounds different and somehow “less”. I exported a single instrument track with multi-processing ON and did the same with it OFF. I started a new project and imported both onto separate audio tracks and inverted the phase on one. But it wasn’t silent or quiet. The only thing I changed on the export was turning Cubase multi-processing off.

I’m working at either 24/44.1 or 32bit/44.1 on these projects, so it’s not like I’m pushing things at 96 or anything like that.

It isn’t just Kontakt and Halion Sonic - I get the same problem in Cubase when I use more than a couple VSTi’s. I get the same with a few instances of, for example, padshop pro. Any VSTi’s really. The multi-timbral / instrument VSTi’s obviously add the extra dimension of complexity too.

It’s driving me mad this issue. I’ve replicated two projects in another daw on my machine - Sonar X3 - and I get no issues. The performance meters don’t even touch 20% in Sonar, so I can’t understand how Cubase can get to 50% so quickly and run into problems so easily on the same system.

I have tried re-installing everything (twice now) but it made no difference.

I don’t care for the GUI in Sonar X3 and the workflow in Cubase is far more productive for me, but it’s getting to the point where it’s preventing me from carrying out my work. It’s also restrictive artistically and I find myself too bogged-down in technical issues.

I don’t want to be a pain, but you DID try with multi processing OFF in both samplers, right? I reinstalled the whole thing recently, and when I was about to switch on multiprocessing for Halion, it advised against it. So I switched it off for Kontakt as well and I have been fine since.
As far as I understand it, Cubase uses the virtual cores from the hyperthreading for ASIOGuard, and that might conflict with the samplers. And since hyperthreading is designed to be transparent to the operating system and other software, Halion and Kontakt have no way of knowing of they’re getting in the way of ASIOGuard or not…

All the best,

I recently got a new kb and mouse… Both with leds… This caused a lot of power issues, audio included… I got myself à powered USB hub that resolved it…

Just a thought

For me the problem is very logical now after reading the last two posts of OP.


That is a good article about core handling.

Before coming to any conclusions about the multi-core performance of your particular sequencing package, make sure you have any appropriate parameters set correctly. For instance, in the case of Cubase/Nuendo you’ll need to tick the ‘Multi Processing’ box in the Advanced Options area of the Device Setup dialogue, while for Sonar the tick-box labelled ‘Use Multiprocessing engine’ is the one to check. With these settings deactivated you’ll only be using one of your cores, and performance will plummet.

You do NOT need to do any core handling by vsts that are being used WITHIN cubase. IN fact: you can not. It is the host that does the core handling, not the VSTI.

Core handling provided for these vsti’s are there because they can be used as STANDALONE programs. Standalone, the core handling is done by the VSTI, and in fact they host themself in that case.

If you want to experiment with exclusive core handling, you need a program that allows you to do this. F.e. Vienna Ensemble Pro. That is a server based program that works outside cubase, and interacts with cubase through plugins within cubase that receives audio from them. (like rewire)

Also: Best is to work with instrument tracks, one preset per vsti. That is the most convenient way to work with vsti’s in cubase, and every new kontakt or other vsti will be assigned a different core, and so on…
If you go multitimbral in one VSTI, you are just stacking all neede resources on to a single core, because for the host this is just one single vsti.

With cubase set to a single core… your entire program AND all vsti’s loaded within the host only get one core. No wonder you will have very little resources available.

Try it: Multicore ON, no core handling by the vsti’s, and one preset per vsti. you’ll see that there is nothing wrong with your system, but you are just killing your own resources. That’s the issue here i think.

kind regards,

You’re not being a pain - any help appreciated! Yes,I did turn both off. In fact, that’s how I used to have things set up for most of the time with Cubase 7.5. Multiprocessing Off in both Kontakt and HSSE but on in Cubase with ASIO guard on.

But in Cubase 8, if I have ASIO guard on, the Cubase performance meter jumps up to around the 80/90% mark in these projects, and the crackles etc are even worse.

Now I am on Cubase 8, I need to a solution for this. I’ve tried Asio Guard at low/med/high and with the audio buffers at 256, 512, 768, 1024 and right up to 2048 but, although they give varying results, there’s no noticeable improvement.

It was that which lead me to turning Asio guard off and trying different settings within Kontakt and HSSE.

I even tried a different audio interface completely (not installed or connected at the same time as the other) but the results were almost identical, which suggests to me it’s not that.

I don’t see as yet why I don’t get similar issues with Sonar X3 (or even Studio One). I added a silly amount of VSTi tracks to a project in X3 just as a test and it handled a ridiculous number before having problems.

I’m hoping Steinberg can log on to my system and see this problem for themselves.

I’d prefer a PS/2 mouse and keyboard, but my m/b only has one combi ps/2 input which does not work with the mouse-and-keyboard adapters you can get. I might replace one of them with a ps/2 version, though.

[quote="dman2014I’m hoping Steinberg can log on to my system and see this problem for themselves.[/quote]

Install teamviewer for that. It’s free.

kind regards,

But in Cubase 8, if I have ASIO guard on, the Cubase performance meter jumps up to around the 80/90% mark in these projects, and the crackles etc are even worse.

Now I am on Cubase 8, I need to a solution for this. I’ve tried Asio Guard at low/med/high and with the audio buffers at 256, 512, 768, 1024 and right up to 2048 but, although they give varying results, there’s no noticeable improvement.

It was that which lead me to turning Asio guard off and trying different settings within Kontakt and HSSE.

Great! It is an ASIO guard issue. That is a different story. Just turn it off untill it gets fixed for you or a SB-dev or mod jumps in. Stay away from the core handling settings imho. :wink:
And BTW, you can still use cubase 7 when you have a license for 8.
It should still be there.

kind regards,

Install teamviewer for that. It’s free.

kind regards,

Thanks, I have it on.

Yea, on 7.5, I had multiprocessing on in Cubase and asio guard on. I never had multiprocessing on in the VSTi’s.

But on Cubase 8, set up like this, the performance meter is at 80/90% in the projects.

The reason I stopped using separate instrument tracks was that, let’s say I had 9 instruments I want to use via HSSE… If I create a rack HSSE and wire 9 MIDI via it and the outputs to 9 individual audio tracks, I only need one instance of HSSE loaded. With separate instrument tracks, I would have needed 9 instrument tracks - 9 instances of HSSE loaded.

I found the individual instrument tracks pushed my Cubase meter even higher as more instances were added and loaded.

The same with Kontakt.

Sorry, it’s getting a bit mixed up here…

The issue exists with asio guard off - the performance issue is just even worse for me with asio guard on in Cubase 8.

I had problems with 7.5 too, but it seems worse in 8. I have a number of projects in 8 now and have started to use the features in 8.

There must be some cause in play here why I have these issues with Cubase but not the other daws. It’s not as though we’re talking about tens of VSTi’s or a 100+ track count.

I’ve given a hint to one of the mods of your issue. Steveinchicago has used teamviewer with users before and he is a kind and well informed source. Maybe PM him and he can have a look at it. For me, the main reason to put the questions is to look if a quickfix was possible, and if not to gather as much info so that other users can jump in. I think we’re there now. But i’m out of ideas for the moment.
What could also be usefull, is to load one of these projects where that huge load is present, and then to screenshot the taskmanager with all cores individually listed. That 80/90% can mean different things… the performance meter only shows the highest load from one of your cores.

And meanwhile, keep the post on top of the list, and you’ll get looked at certainly. :wink:

kind regards,

Here’s a screenshot of the performance meter with multiprocessing OFF in Kontakt and HSSE and ON in Cubase. AsioGuard is on too. This is the best I could get from trying different settings of asioguard low/med/high and varying buffer sizes.