Kontakt volume gets reset

Can anyone tell me why Kontakts volume is reset every time I press play?

Because Kontakt’s volume slider responds to MIDI CC7, which is sent from Dorico’s MIDI mixer.

You can unlearn it in Kontakt (right click on the volume fader: unlearn CC7)

1 Like

Yep. Thanks Saxer.

Ok, tried this on mac and pc now. I’ve unlearnt the midi cc and Dorico is still moving the volume control. Any more ideas?

Also if I change the volume control to respond to pitch bend etc Dorioc still resets it on playback.

Very few ideas, and unfortunately might not be helpful, but:

1.) In addition to unlearning the midi CC, have you also configured the instrument itself not to respond to volume messages? Click on the wrench icon > INSTRUMENT OPTIONS > CONTROLLER > Uncheck “Accept standard controllers for Volume” (and pan, if you run into trouble there too). (If you load instruments for each project instead of using a template, you might want to re-save the instrument so that next time you load it, this preference stays where you want it.)

2.) You could also try setting “natural” in your expression map to send a CC7 message … I think (but not 100% sure, and away from my rig right now) that sending CC7 = 100 will set Kontakt’s volume slider to 0 dB. (If that’s not the right value, a tiny bit of experimentation should find the right one, IF this works for you at all.)

Finally, a friendly warning: All of the above might not work, depending on the instrument, for reasons I don’t understand. For example, unlearning and unchecking “Accept standard controllers” works for me in LA Scoring Strings … but in the Chris Hein solo strings instruments, I have given up on ever being able to fix this, because nothing I’ve tried works. The only option in this case would be to host the plug-in in another program, such as Vienna Ensemble, and pull down the channel fader there to compensate.

It can be very frustrating; I hope you find a solution!

Thanks for the help. Option 1, unchecking ‘accept standard controllers’ has worked. I’m sure I did this yesterday and it didn’t work. But it’s working now! Thank you!

I’m glad it was helpful! You have no idea how many times I was banging my head against my desk, bewildered, the first few times I ran into this non-intuitive Kontakt behavior.

Problem for me is that unchecking icon > INSTRUMENT OPTIONS > CONTROLLER > Uncheck “Accept standard controllers for Volume” (and pan, is not a global change. It has to be done each time you load a new instrument in Kontakt. has to be some sort of conflict in Cubase 10/Kontakt 6. native Instruments says it’s Cubase?? I agree.

Additional comments;

I also repeated loading an instance of Kontakt 6 into Protools 11.3 and into Digital Performer 10.x. And there were no issues with volume changes. And the "[options/ INSTRUMENT OPTIONS > CONTROLLER >Accept standard controllers for Volume] was checked. No problem in either DAW. This is definitely a bug in Cubase pro 10.0.4. Never had this issue until installing the latest Cubase 10 update. :confused:

I am running into this same issue when using Spitfire Kontakt instruments. In their case “accept standard controllers for volume” is already unchecked, but the Kontakt instance is still having its volume slider reset every time I hit “play” in Dorico.

Is there a way to disable the CC7 data coming from Dorico?

I don’t think there’s any way of disabling the sending of CC7 except to change the volume type for dynamics in the expression map you’re using to send velocity, but Dorico will still send a “reset controllers” message when it starts playback.

Dorico sends CC7 from the MIDI section in the mixer. It’s quite separate to dynamics. What is it that you’re actually wanting to do?

Have it not send CC7. :slight_smile:

The broader context is that I have a Vienna Ensemble Pro instance hosting a Kontakt plugin, which in turn hosts several Kontakt instances in a multi. I want to be able to adjust the relative levels of each Kontakt instance within the multi, because certain articulations are way louder than others despite being from the same instrument. The only way I can make these level adjustments - given my specific setup here - is to use the per-instance volume slider in Kontakt, which is apparently countermanded because Dorico auto-resets its value via CC7 with each playback.

There’s a “Accept Standard Volume Controllers” button in Kontakt settings which should theoretically control whether CC7 is monitored, but in the case of Spitfire instruments these apparently are already un-checked. Yet the volume slider still resets. I don’t know whether Spitfire modifies the standard Kontakt logic in making their plugins.

More detail than you probably wanted, but now you know what I’m trying to do!

Ok, that’s something that’s not currently possible in Dorico.

I was struggling with my Chris Hein libraries too, Orchestral Brass and Woodwinds in my case, but I just found out you have to open your mixer, select the Midi intruments to show and change the setting of the fader there. Once you’ve lowered it, the volume of the output slider in kontakt will respond to that setting and be much softer.

I have tried everything the this feed suggests to fix it and it still continues to reset the volume, even uncheck the suggested box in the Kontakt player. I use Glory Days from Orchestral Tools and can hardly hear it. I noticed the first post about this issue was 2019, two years ago. As bug manager of a software, this should have been a priority to fix as countless companies use the Kontakt player for their VST engine. Maybe it’s lucky I use BBCSO and Spitfire use their own VST engine and EastWest use the now very efficent Opus engine. What do you sugget to resolve this problem?

I really don’t think it’s either appropriate and/or correct… Kontakt instruments have not proven yet to be the most interesting ones when using Dorico (or any notation software), and even if you don’t like the sounds, Dorico (at least Pro) is bundled with HSSE+HSO, and the priorities are clearly more to add features and improve the tool rather than solving problems with some third party plug-ins (which are not even VST3…) My two cents :wink:

@MarcLarcher hello,
Well, I’m partly agree with you. The team should spend more time improving the app and adding new features. But keep in mind that Dorico is a DAW-like software, which means they have to fight on two fronts.
For example, for me the DAW functions in Dorico are very important, because I’m writing in Dorico not only for performing musicians, but also for virtual instruments for end products. After all it’s not possible for every client to record with real orchestra, so the VI’s could cover such situations well. I also prefer to work mainly with notation instead of MIDI mock-up, and at the end to provide score sheets to the clients, in case one day they decide to do an orchestral recording.
So, for me, and not only, both sides of Dorico are equally important, just like Yin and Yang in the Tao philosophy. :slight_smile:
This issue with sending CC 7 data to Kontakt should be fixed. The guys behind Dorico could take Cubase as an example. It doesn’t send any CC 7 data by default, unless you start playing with the MIDI Volume Faders in the Mixer. Exactly the same should be the behavior of the Mixer in Dorico.
Even I’m wondering why this wasn’t done at the very beginning?! :slight_smile:
About HSO, well this library sounded acceptable 10 - 12 years ago, and even then it was far less realistic sounding than EWQL SO Platinum Pro and the VSL products. Nowadays HSO is completely useless for end products. Currently Steinberg has only one orchestral product which worth - Iconica, but they don’t work to add more articulations to it. Still It can’t compete with many of the other orchestral libraries.
Kontakt is still the most widely used sample player, so it should work well with Dorico, no matter that it is VST3, or VST2.4. :slight_smile:

Best wishes,
Thurisaz

Perhaps you could highlight where in my post I state Konkatk is the most interesting. My two cents mate!