LAN connection not detected by Connect Performer

I have a Windows 10 PC with a trial licence of VST Connect Pro I have two Windows 10 laptops with VST Connect Performer 4.0.40. They are all hardwired on my LAN and other network functionality is normal.

Neither laptop shows the VST Connect Pro machine as being available to connect. The ‘LAN button’ in the VST Connect Performer machines does not illuminate as described in the manual and clicking on it has no effect.

I suspect there is a problem with the VST Connect Pro machine. The reason for testing on the LAN is that I cannot maintain sync with a remote recording session despite have fast and stable internet (64Mb/s down, 17Mb/s up both ends) and I am trying to diagnose the problem. I have tried disabling Kaspersky Internet Security on the machines to no effect.

Any help would be greatly appreciated. I so want this to work but after a week of struggling with this I’m close to giving up.


just guessing - possibly a windows firewall problem ?

is this the same laptops are you are using for the remote (internet) test ?

Windows Firewall is turned off on the Pro m/c. It has Kaspersky Internet Security with a firewall but I disabled that to no effect. One of the laptops also has Kaspersky and the other has Malware Bytes. I disabled all of it for just long enough to run a test. No luck.

The 'remote machine for the internet test was a Mac. The symptom there was intermittently getting a ‘Performer’ red sync light when on playback and immediately every time I tried to record, whatever I did with stream speeds.

With the big machine running SE and a laptop tethered to my iPhone I got exactly the same symptoms. Connection speed from the tethered laptop was 16.3 Mb/s down and 12.7 Mb/s up.

My idea was to run the LAN test to prove conclusively that the issue was with the ‘Pro’ machine. I so want it to work and I will certainly buy the Pro licence if it does, but I’ve been frustrated at every step with this.

a LAN test sounds like a sensible plan - at least that’s what I’d have done.

Are you definitely running PRO on the studio PC. There are two different plugins: PRO and SE - just having the licence on the dongle isn’t enough.

Definitely running Pro. There are two options in VST Cloud on my Cubase 10.5, SE and Pro. It says Pro at the bottom of the Connect window.

running out of ideas now - I’ll give it a try on the LAN later if I get chance

FWIW there is a newer version on (clutching at straws obviously)

Thanks. I’ve upgraded both Connect Pro and Performer to the very latest No change.

LAN connection has never ever failed on me, and no such reports at all, that‘s weird. router needs to allow udp broadcast, this usually even works within highly restricted company networks. You know you must not log in on either end, just run both sides and then the blue button appears on the Performer, right?

same here - LAN has always worked - what’s odd is that this is the same PCs, the same router/network that allows studio/performer to connect over the internet ?

Thanks for the input gentlemen. Yes I did realise that neither end should be logged in. Yes it is the same PCs network and router that allow connection over the internet. I’ll check the UDP broadcast thing now. It’s a standard BT router.

Update: I could find no option to enable/disable UDP broadcast in the router. I had a port forwarding rule mapping and redirecting port 443 from the internet in the router. I removed it and restarted Connect and Performer. No change.

restricting udp would be a bit odd - plus if it’s a basic BT router can’t imagine you can do that much to it ?

I do think there is something odd/unusual in any firewalls you have on the PCs that block traffic but on only on the same subnet ? - I know you are using Kaspersky but try disabling the windows defender firewall too ?

arguably this the problem you are actually trying to solve is the lack of sync when you are using over the internet so usual checks are for this are:

  • are you wired both ends
  • what buffer settings etc
  • increase “remote delay”
  • have you tried with a totally blank/new project
    -update to latest version on

Regarding the LAN connection failure:-
Yep standard BT router.
Firewalls: I’ve tried specifically opening ports 51111-51113 for UDP both ways on all firewalls - no change. Then I tried totally disabling all firewalls on both the studio and performer machines - no change. Still no LAN connection possible.

Regarding the ‘proper’ remote session issues:-
The previous sessions I was running SE. Next attempt will be with Pro at my end.
Wired both ends
Buffer was fixed at 447 IIRC. I couldn’t change it
Didn’t try increased remote delay - will do in next test
We were at the latest version both ends when we ran the test. A new one has come out since then. The next test will use that.

I think I’m going to have to try to remember how to use Wireshark…

good luck :slight_smile:

let us know what happens on the next text…I’m hoping the feedback and debugging will help others

OK Chaps, I’ve got Wireshark running on a laptop monitoring my LAN. I’ve got VST Connect running on the Studio machine and I’ve got VST Connect Performer running on another laptop. Latest versions. What should I be seeing because nothing seems to be happening between the two VST machines?

can’t help on such a low level, sorry.

I’d assume you’d see broadcast packets from the Studio machine ?

I need to re-learn Wireshark. There are some broadcast packets coming out of the Connect machine but they might not be the right ones. No responses from the Performer machine evident. I’ll try again tomorrow from a better informed position, I hope.

Well I can see UDP packets going out from the Connect m/c to the Performer m/c and responses going back but still no action. That’s it. I’m outta here. So much promise and so little delivery.

just checked today - and I know it’s of zero help but connected fine on my LAN (windows to windows) - so something that is more specific to your network ?

Did find as strange bug though - as soon as I started a VST connect performer on a PC on my LAN it immediately kicked off the internet session I had running - Closed down the VST connect performer but that upset the Studio plug - had to remove and reinsert it.