LAN connection not detected by Connect Performer

Thanks dr for your interest and input. However after more than 3 full days of trying to make it work I really can’t proceed with this. I had intended to make up two portable ‘remote’ systems, each with a laptop, half-decent 2 channel interface and a set of headphones. These would get shipped out to band members currently in Coronavirus self-isolation so that we could continue with a current project, stave off boredom and have some fun. These are guys whose considerable talents ‘lie in areas other than IT’ so giving them something flaky would be a total waste of money and time. Compared to functionality of the rest of Cubase this is extremely disappointing.

Alan

hi Alan

totally understand - I’m not saying vstconnect is perfect, far (very far!) from it - it can be totally frustrating and annoying - full of irritating bugs and ‘gotcha’s’, but I believe that the very, very small team developing it are committed to get this working with no real support from SB as a whole. It has languished in the ‘forgotten’ drawer for such a long time.

I’ve used it with people who have no tech skills whatsoever - it can be done - I’m posting here so much because, I hope, with the input of the community and the developers (who post here !), that we can fix the issues and get this working more reliably.

if you wanna PM me, I’m happy to try a remote session and see what happens ?

don’t give up just yet :slight_smile:

I had a look using Wireshark on my Mac, that’s really an advanced tool without guidance for a layman user, but I did see packets on port 51113 going between the ip addresses corresponding to the mac and and my PC, when I initiated a VST Connect session.

I would presume if the data isn’t being passed something else is going on in your network.

Also, something worth noting is that there is more than speed to consider concerning the quality of a network connection, the ‘behind the scenes’ data management itself, done by the the computers and routers has overhead that increases on poor connections. So a good focus for troubleshooting would on improving the connections, eg., use an Ethernet cable to connect the computers to their respective routers, restarting the router, the cable modem etc…

OK Chaps, I’ve slept on it and come back for another go. Thanks for the encouragement.

Steve: I do have quite a complex network here, including a managed switch. I had checked the configuration of that but just to eliminate it I tried a direct cable connection between the Performer and Connect machines, obviously just the two machines, fixed ip addresses, sharing enabled etc. The machines could ‘see’ each other and file transfer both ways worked fine. STILL the Performer machine did not detect the Connect machine, no LAN light. I uninstalled Performer, rebooted, re-installed - no change. Re-installed Pro - no change. It doesn’t appear to be my network stopping it working…

Very interestingly I did not see packets on ports 51111-51113 when I tried the LAN connection with Wireshark running. I ran Wireshark on the Connect machine, the Performer machine and a standalone machine. There was traffic on other ports in the 5000 range. I used to play with this stuff a bit, a long time ago. As reference was made to no longer needing to open ports 51111-51113 I made the assumption that they were no longer being used (but I did try opening them anyway to no avail).

dr: I will PM you. Thanks.

Alan

just another random thought - did you delete the VST connect preferences (.ini files) in the performer ?

Just did that. No change

…let’s see how we get on tomorrow :slight_smile:

You will not see messages on the VST Connect ports other than broadcast packets (255.255.255.255) before a local connection is established.
Opening those other ports is still ok and may help to establish a true peer-to-peer connection, but it does work without as well in general so there is no need for that anymore.

Thanks. Can you tell me what I should expect to see from which ports on the initiating machine and what the response should be and from which port?

broadcasts are 51117. The other port used internally is 51113

Thanks. I’ll get on it.

alanharvey, don’t know if this will be of interest, but it might rule something out, or trigger a new thought…

https://www.steinberg.net/forums/viewtopic.php?p=982837#p982837

Thanks for this Steve,
I’m going to try running both on the same machine tomorrow for sure. Today I’ve monitored both my Connect and Performer machines using Wireshark on them when hard wire connected to my LAN. There is no activity on ports in the range 51111 to 51117 when sitting on the same LAN and otherwise able to communicate with each other. The correct firewall rules are in place but I did try disabling the firewalls to no effect.

When running a test with dr the other day over the internet I did see activity on those ports but stupidly didn’t save the trace file.

You mean you and dr connected successfully, and everything worked?

maybe a clear definition of what is being called a LAN should be informative.
I’ve been in contact with steve and i am up and running with my buddy, so no problems for me.
But i ran in to the same problems before that.

A typical case would look as followed:

guy has a main computer and buddies (guitar vocals with their laptops) who have no idea of how to use the internet and connections.
They put their machines physically to the main site and say: do your thing.
The issue that they maybe are running in, as i was, is the fact that LAN is not clearly defined and is not connecting.
(note: Once set up and everyone back home everything is running fine.)

That being said, i never found out how to make a working LAN connection since the software said time after time: connection not allowed on the same network. (connecting locally with the numerical access, wireless)

So to find a solution maybe a more clear definition of a LAN, and how it is used successfully, is needed.
Should we crosscable pc’s, can we use a router, can we use a wireless LAN (certaintly does not work) and so on.

you need (and additional) PRO licence to make LAN connections work - it doesn’t work with the SE licence thq comes with cubase.

just to answer on behalf of alan ( :slight_smile: ) - we connected and it worked but there were the usual (!) sync problems. In fact the buffer just emptied itself over a few seconds then audio contact was lost. Interestingly the video didn’t drop - we were still connected just fine.

internet “quality” issues I suppose :unamused: Plenty of bandwidth - low latency etc etc
https://www.steinberg.net/forums/viewtopic.php?f=221&t=185559&p=982325#p982325

working on sync improvements

I tried this and it worked! LAN light came on. Connected, recorded, perfect sync 100%. So could the Windows firewall be the problem, even when it’s disabled? Any other ideas?

So many threads…missed that one, replied there