"library manager privileged helper steinberg has wrong version"

I had a problem with the Library Manager
I using original cubase 12 pro in a MAC MINI M1

“library manager privileged helper steinberg has wrong version”

I already looked in the forums, did I download the new version Steinberg Library Manager 3.2.20 or is it not this version?

I restarted, uninstalled and reinstalled and the problem persists.

Any solution for this?

Daniel Sarkis

Screen Shot 2023-02-26 at 10.38.57

Maybe try to install the latest Library manager:

I said that in the text…I downloaded and installed this version already

Than I’d try (re-) installing the Download manager (Includes also these helper utilities)

Same problem !!!

Okay (Sh*t). Thanks for letting us know.
Some more ideas: is the OS ‘supported/compatible’ with Cubase 12 Pro?
No idea about Mac, but do you have the necessary ‘Admin’ rights (I am a Windows user)?

But as last resort: Contact Support. Be patient (expect at least 7 days before they get in touch)
They typically ask a system.nfo file so you can attach that right away.

And of course: Good luck!

Cubase 12 pro supported on Mac Mini M1
Well, I think, I have the Admin’ rights.

I can’t find Contact Support…only the foruns

You need to login to your Steinberg account. Then you’ll find the link to support

I tried,
It opens several pages to look for a representative in Brazil, which is YAMAHA.

They probably don’t even know about this problem.
This is direct support with the program developer Steinberg.


I sent an email…will wait.
Thank you very much

Hello everyone,
I had the same problem with the Steinberg Library Manager on my Mac Mini M1.
For me, the problem was with the SteinbergHelper start objects, which were not activated.
After activating and restarting the computer, everything worked again.
In the screenshot you can see which start objects from Steinberg are involved.

I hope I could help you.

Best regards


Hello my friend,

Yeah…do the same …and now works fine.

Thanks a lot

I’ve been looking for days how to fix this and this worked, thanks!