Limitations of Audio Unit extensions

Limitations of Audio Unit extensions

Dear all,

Below please find the summary of known issues / limitations when using Audio Unit extensions with Cubasis 1.9.8.

Cubasis 1.9.8 - Limitations of Audio Unit extensions
• Using multiple instances of an Audio Unit plug-in in a Cubasis project, or quickly switching between projects that contain Audio Unit instances can lead to AU instrument loading issues, instabilities, or render Cubasis unreliable.

We expect this iOS bug to be fixed by Apple sometime soon. If you encounter loading errors with Audio Unit instances please try to load these plug-ins manually using the “reload” button or quit and restart Cubasis to reload your project.

• Performing edits in a project that contains Audio Unit plug-ins during playback can lead to temporary timing issues. A workaround for this iOS related issue is planned to be released with the next Cubasis update.

• The maximum number of Audio Units that can be loaded in a project depends on the device in use. Memory and CPU limits can be exceeded by loading just a few Audio Unit instruments or effects, resulting in errors or stuttering during playback.

• Loading complex Audio Unit plug-ins can take some time, even on newer devices, since the process is comparable to loading a complete app inside Cubasis.

• If an Audio Unit plug-in fails to load, Cubasis might also become unresponsive or unreliable. If you encounter problems, please quit and restart Cubasis. Cubasis cannot compensate for issues caused by 3rd party Audio Unit plug-ins.

• Depending on the Audio Unit plug-in “state saving” might not be supported. As a result, plug-in parameters are reset to their default values every time a project is reloaded.


I don’t have the option in my Cubasis is it because I don’t have an app that is compatible?

Hi Pump,

Audio Unit extension requires iPad Mini 2, iPad 4 or newer model and iOS 9.
Next to this a compatible AU instrument/effect is required to be installed.


Ok that’s the problem I have the iPad pro but I know now I don’t have any compatible apps

The Arturia iSem is a AU App.

My Apps, Animoog, Nanolog, Nave, iSpark, iProphet, iMS 20, iMPCPro, SampleTank, SMPLayer. All have interapp audio but no AU.

There’s a free AU synth on the app store called Bassalicious. There’s an IAP to upgrade the synth but the free version (with one oscillator) is fully functional as an AU if you want to test out AU functioning in Cubasis without paying anything.

I, too, own a bunch of iOS synths but none have upgraded to AU.

Hi Lars,

Thanks for the update.

I’ve had problems with the iOS audio aswell, is there anything that you suggest me doing in order to fix that, as a temporary solution?

Thanks in advance.

Hi Applelover,

Please specify more in detail, what problems you’ve experienced.


Is that fixed or not yet? i am getting same error if you have fixed it then please suggest me the same way to get it done!

Hi focin123,

Please specify more in detail what problems you’ve experienced, so I’m able to comment.
Here is a guide how to report issues:


Please help

I’ve just seen the disclaimer so I now know it’s an older issue

But I risk losing a track I’ve spent months on

Any way of taking off Amazing Noises Limiter so I can get my track back

I use iPad Pro and latest IOS, all up to date


Please specify your problem more in detail.
Does the project fails to load (also if you wait a moment)?


Yes the project fails to load totally, it just hangs indefinitely :slightly_frowning_face::slightly_frowning_face::slightly_frowning_face::slightly_frowning_face::slightly_frowning_face:

I’ve tried deleting the AU apps (I presume I’ve gone over the ‘threshold’ max no of AUs in a project, I wasn’t aware there was an issue or a limit until the problem occurred and then I found this post) but this doesn’t work either

Also tried hard re-start of the Ipad, but this doesn’t work either

Any ideas, how I can just get into the project and then I would remove or turn off all the AU effects…?


Hi Alastair,

Please have a look at the private message I’ve sent you.


Just to say Lars and the guys resolved my problem (superheroes!) with minimum of fuss and maximum of great customer service attitude!

Hi Lars

I’ve also got the same problem as Alastair10538 and didn’t realise there was a limit to the amount of aus’ you could use on a project. Subsequently my project won’t load and crashes cubasis after a short while.

Is there anyway to rescue the project?



Hi Glenn,

Please upload the project to Dropbox or similar and let me have the download link via private message.


I have about ten AU apps (fully paid) and all are AU compatible, yet only TWO show up in Cubasis 2.5. I’m running iPad 5G on iOS 11. Please help, because this is getting VERY frustrating! Is there a folder I can drop these apps into so Cubasis can see them?

1 Like

Hi SlowPoke,

Thanks for your message.

Cubasis is fully compatible with Audio Unit and Audio Unit MIDI.
So far we are unaware of issues, where AU apps did not show up properly.

Please create a new topic and let us have more details about your issue.
Please follow this scheme to report the problem: