Locator moves when changing tempo


I have this issue where Locator Range moves when I change tempo.

It is SUPER annoying and I don’t believe I have experienced it any other Cubase versions.

Any solutions to this? Video - Locator Range moves when changing tempo

Tempo is musical information, and it adapts to a real time frame, that’s why the locators move relative to video content.

120 bpm means 2 beats for one second
60 bpm means 1 beat per second
If you have your locators at 1.1 and 1.4 the right locator moves from 2s to 4s.
The video frame stays on the same position in time, but the beats move.

But there is no video content and I have been a Cubase user since SX3, and I almost 100% sure that it hasnt always been like this. Or atleast a feature that could be switched on/off.

Whether or not you have video content isn’t related, but See this search: ruler time domain cubase

This looks buggy.
The Locators shouldn’t move like this when changing the tempo, they should stay where they are, regardless of the time base and ruler settings. The Locators are fixed to Bars+Beats.
If the ruler is set to Seconds or whatever mode other than Bars+Bears, it’s normal that the Locators move in relation to the sexagesimal system.

But your video shows Bars+Beats ruler, so they must keep their position.
Based on your current ruler display parameters, changing the tempo is only supposed to make the Cursor move slower or faster, not move the Cursor and Locators.

Please try removing the Defaults.xml file located in C:\Users\name\AppData\Roaming\Steinberg\Cubase 12_64
Don’t delete it, just move it elsewhere and start Cubase without it.

When the primary time display is set to something other than bars and beats, and you then set the ruler to bars and beats, when the tempo is changed the locators stick with the time, not the bars.

You can demonstrate for yourself:
in this order,

  1. Set Primary time display to Timecode, Samples or Seconds
    2.Set Project ruler to Bars and Beats; Bars and Beats linear

The locators appear to move. But they are still anchored to the time-linear position.

note – I edited this for completeness and made some corrections


It is no bug, and it is the same since very long time now.

There are two working modes available.
Time linear and Bars + Beats Linear.

@st10ss This has nothing to do with the ruler modes. These later are only for setting how the time is displayed visually :
Time Linear = Fixed Cursor speed and Bars have different length,
Bars + Beats Linear = Bars have fixed length and Cursor has variable speed.

The behavior explained in this topic is due to the Display Format set in Project Setup (or Primary Time Format set in the Toolbar), but Steve removed it ! Now it is left with undefined answers.

Your explanation was wrong. That’s all.

Maybe we were not precise enough with our descriptions.

Come on! Just try it before posting. This is a cult for real! The cult of ignorance!

Instead of being brain-stimulating, this forum is just source of trouble.

The Locators and Cursor were moving when changing the tempo because the Display Format was set to Second or Timecode. In this case they keep their position in seconds, that’s the reason why they are moving away when the ruler is set to Bars and Beats.

When changing the Display Format to Bars + Beats, the Locators and Cursor follow their Bars and Beats position.

How the heck was that wrong!?

1 Like

If you multi-track a live performance, you don’t need tempo changes.

Your project is set to time linear.
If you change the tempo the bars and beats change totally.
If you set your locators on the bars and beats ruler these change as well.
But all audio events stay on their exact same position in time.

The better solution is to work only with time based rulers in this case.

A right-click on the main ruler should explain more.

1 Like

This is not correct. The ruler modes affect what is happening visually when the tempo changes.

Time linear ruler mode means all events set to linear time stay at their position in time, and don’t follow the tempo changes. If your main ruler is set to Bars and Beats, the tempo changes move the grid. If it is set to a time (seconds, FPS, timecode) the tempo changes don’t move the grid.

Tempo linear ruler mode is reversing the behavior.
Tempo changes move the events set to linear time base. But the grid stays where it is. And the events in musical mode stay at the Bars+Beats position.

The locators are always set with the primary time display.
It gets difficult if the rulers and the time display are different.

… and this is the case without regard to the rulers’ time-domain, because the the the Primary Time Display is global for the project. So regardless of how the rulers are set, the project display is based on linear time, and not bars and beats.

set your Primary time display to Bars and Beats.

That’s what the problem was here.

I don’t think the ruler does all that.

The ruler does either Time Linear

like here, where measure 1 is looooooooooong, because it takes more time to go through a 16/4 quarter=40 and accelerating measure, than the 3/8 at quarter = 225 next measure. (And notice how the beat lines come closer and closer together.

Or it does Bar+Beats Linear like here

where each QUARTER NOTE (vertical lines in the background) is equidistant visually, no matter what the tempo is.

So the first case is clear. Time passes in a straight line, the bars and beats are squeezed to fit this linear passage or time.

The second case though is not completely clear. It’s beat linear, but since the beat is always a quarter in cubase it doesn’t always produce predictable results. There could also be a true BAR linear mode, where all bars would be the same visual length, no matter if it’s a 16/2 measure followed by 3/16.

But in the OP’s case, it’s just that they had turned their primary display away from Bars & Beats, that’s why the locators moved.

1 Like

OK. Maybe I wasn’t clear enough.

The main ruler, the main time display (locators!), the ruler mode and the track setting are all doing it together.

The ruler, time display and the mode define how the grid and the locators are behaving, and the track mode defines what the events are doing.

Thank you for providing a solution. I like a detailed explanation as much as the next person but today I am running short on time and just needed to fix my issue. Thanks Louis!

I had the same bug and your method solved it.

Encountered the very same problem.
Deleting the Defaults.xml file does helps, but only for a time.
This looks like a project related preference, as I have the project, loading which turns back this buggy locators behavior. And empty projects created afterwards inherits this as default setting.
But in other projects, created before, it works as usual.
Maybe someone knows how to fix this ones and for all. Since setting up a anew every time after removal defaults is tedious.

UPD: On second thought it still looks like a bug, because with ruler set to “seconds” or “timecode” cycle locators keeps its position according time. But their behavior does NOT changes if switched to “bars+beats”.

Is your timeline set to Time Linear? That would produce this, if I understand correctly what you’re saying.


“Time linear” or “Bars+beats linear” in this case does not affect cycle locators, their position still moves away from corresponding bars. It defines what is being stretched/shrunk - project field with events or cycle within upper ruler.