Low performance with a lot of edits

(I also sent a support request on this issue)

Im running a Mac Pro 3.1 - 8x3Ghz Xeon 10GB Ram, SSD for OSX and 1TB WD hdd for projects. Radeon 7970 3Gb Gfx card.

the project is clean, all unused media removed and deleted from trash.

the issue:
when editing drums, lets say 16 tracks, everything chopped up with a lot of events and autofades when zoomed out so the screen renders all the events the performance is very low, the zoom in out lags.

it is not OS related, the same happens on another machine with the somewhat same specs and running OSX 10.9

when zoomed all the way in and working with cut and so it works great.

so the question:
is this a cubase problem, or my hardware performance?
my machine should be more than powerfull

I dont get at all why this is happening, can you please shed some light on this

Thanks in advanced

Yes, I’ve experienced this on Windows machines as well. I think it’s to do with rendering all the graphics associated with a very high number of audio events. If possible, glue some of them together into parts and you should have snappy zooming again.

Maybe the solution is a more powerful graphics card. I don’t know if that would help but would be interested to know the answer?

This has been an issue for some time. Once the editing is finished, save the project to another name. Then bounce the edited audio tracks. Click yes when it asks about “replace events.”
Once the bounce is executed, the interface should speed up again.

yes I am doing that now, or been doing for years now, just wish there was a fix for this.
so the answer is, its cubase issue not hardware?

There is no ‘fix’ for this. The fact that the way audio is held ‘non-destructive’ means that the original audio remains the same until bounced. These edits are performed in real-time while keeping the virgin audio untouched so that you can revert back to the original. That is a good thing.

The severity of this issue is directly related to your particular computer performance and hardware. Not a Cubase fault. Depending on the quality/power of our systems, we have to place the stamp of ‘done’ when we run out of resources. I have a quite powerful system and I need to do this myself after a large amount of drum edits. I despise this acronym ‘YMMV’ (Your Mileage May Vary) but it applies here. System performance will change how much you can get away with.

I just had a conversation with a client last night about how long it would have taken with tape and a razor blade. I feel blessed to be in the digital generation… :slight_smile:

My computer should be more than powerful enough to handle this, i blame cubase coding, not that i know what im talking about.

but how powerful computer do you need for something like this?

I suppose I might try a better video card, though keep in mind you can only get what your system is capable of. Not a Mac guy so I don’t have any input there. I don’t see a reason to blame the program (Cubase) for the issue.

The same thing will happen with 5 tracks on a 2005 single core PC using the same Cubase program. If it would run it…

but if a dual 4 core 3Ghz and a Radeon 7970 3GB GDDR5 is not enough, what is?
there is nothing spiking in the activity monitor, the computer is not under heavy load.

I dont understand the technical stuff behind this, what is the reason for the slow down, what hardware is resposible for this CPU, RAM, GPU?

the machine can run hundreds of tracks, and no slow down whenthe cuts are not visible on screen, but soon as i scroll up to the chopped drums, bye bye performance

Is there someone with a more powerful Mac than me that this does not happen to?

I spoke with a buddy of mine who is a Mac user. Protools guy but he suggested lowering your screen resolution down to the lowest possible as a test to see if the graphics were the issue.

Just an idea.

I am only trying to help in any way I can. I understand the frustration for sure.

Thats a good idea, I will test that out

okay, i lowered the resolution to the lowest possible setting, the performance was much better than 1080p

so In my mind then, i got performance issues with my GFX card, I do not believe its not powerful enough, but I dont think it is working as much as it could (this is not a stock GFX)

Been thinking about getting a better graphics card for these occasions. Seems that wouldn’t help :confused:

Someone already said it: bouncing edits is the only way to get it back snappy. Track Versions are helpful to keep kind of a backup in case you realize some bad edits or phasing crossfades later (original, pieces part 1, bounce part 1, pieces part 2, bounce part 2 etc.).

I do believe it will work with a faster GPU like mine Radeon 7970. now it has the same performance as a Geforce 8800GT (the stock apple GPU in my machine) and that should not be the case.

but since this is not a stock Apple GPU, I have a sneaking suspicion that i don’t get full hardware acceleration out of this card. trying to find out, but google hates me on this.

Does the problem go away if you select all of your sliced events and then go to Audio–> Events To Part?

Could you send us the project? Maybe attach a link it to a post, or send it to me per pm, or send it to support and tell them to also forward it to me.


If I do Events to parts, the performance is a tad better, but still sluggish.

this specific project is 96k/32bit so its a big one, and i don’t know if i can share it.

but with that being said, this is not project specific, its been like this for years now, with all projects.
if you have a let say 5 min song, use the hitpoints and cut it up, this should reproduce the issue with a lot of slices and events. there are no crossfades, just autofades and slices.

JHP this is the way Cubase has behaved since SX. If you cut up drum parts into slices then zooming in and out for editing causes sluggish behaviour even with powerful GPU.

Yep, I have this problem quite a lot when doing fine detail editing. I use the Track Versions these days to dup the events and then bounce them. I used to use tracks hidden in closed folders.

Also on my system there will be quite a delay in swapping tools (e.g. pointer <> scissors) so editing becomes really tricky and slow too. And a similar thing happens when the number of VariAudio blobs increases.

I have a medium powerful graphics card, usually the most modern that I can buy without a fan which means it’s always a several points behind the fastest available.


I have done some stress testing on my GfX card, run some benchmarks, and it looks like it runes as it supposed to.
im about to give up, i cant for the life of me understand why cubase are sluggish.

but as i can see, im not the only one, so this IS a cubase issue, not hardware…

I can confirm this from version 7.5 and up (been with cubase since the first Cubasis)

It’s not. Cubase doesn’t use the GPU for graphics processing or compositing.

Exactly, I have a powerfull graphics card, isn’t the solution!