MAJOR CYCLE MARKER EXPORT/GENERAL EXPORT FLAW - Rounding to the nearest sample = loop creations not accurate = mess

Super strange issue here, when listening back and checking the exported files (import to track on) they do not align with the source material and it’s as if everyone put pieces of these audio files into a hat, shaked them around, and then randomly picked them out.


There have been issues in the past where the start and end points on the exports have not been correct, resulting in the audio to seem as if the cycles were put in the wrong spot chopping off transients or something but this is not the case. I’ve noticed this is more likely to happen if what is being exported is not perfectly on the grid. Usually, just trying the export again will then be right.

I’ve tried just re-exporting in this instance, and it gave a different random result. The 3rd time almost got all the cycles right, but the last one was wrong.

So there is for sure some erratic behaviour going on here. Not sure it carried over to 10.5 or not.

edit

Closing and restarting Cubase seemed to fix it, but it is a recurring problem. Maybe if the program is open for long enough, not sure… but it’s like export sync goes out of wack or something.

Another inconsistency

Is there a setting I need to change somewhere??


edit

If this is a bug… this is a terrible terrible enormously frustrating and destructive bug…

I have been doing thousands of cycle marker exports over the past few months and I have no idea when this started… it’s a such a small chunk it could have easily gone unnoticed and could cause all sorts of problems for me in the future.


edit2

This above issue is not being resolved with program restart it seems.

As far as i remember its connected with block size/samples- render rounds it to the nearest one.

Here is an older post with similar anomaly https://www.steinberg.net/forums/viewtopic.php?t=38874

I don’t understand.


So if I change my buffersetting, this will also change?

This can’t be… it would take some much work to get things to align properly, surely a protocol would be put in place to solve such an issue?



Thanks for the thread link, I was only able to find this one which describes the same problem was in the Nuendo forum:




edit
my project settings are
44.1khz
32bit float
100bpm

It automatically rounds the render to the neares sample.
I dont think if you change the buffer it will do any difference.

I did a backup of the project and upconverted it 88.2khz and did the same exports and it’s better, but it’s actually now a barely-noticeable-hair-short of the grid.

So I guess this is a ‘nearest sample’ thing…

… but still… this seems kind of absurd to me and I don’t get it. If I bounce the same audio files in place, just using event bounce or whatever, this nearest sample protocol doesn’t come to play… so then why for export?

If it’s for some commercial audio standard protocol and the thinking is that Audio Export is the final thing people are exporting and should be to standards… then there needs to be options in export to solve this… because I use this for all sorts of reasons other than final project export… Like errrr… loop creation…

This could potentially screw up tempo detection, offset loops off time, not line up in project properly, cause other grid editing problems if you are editing unrelated audio to ‘Snap to Event’ - if it snaps to these exports when slicing, that’s not good.

total mess.

Yes it can get messy if you need exact loops. I dont know why cubase haandles this in such strange fashion- in Ableton i never came across this problem.

Yeah… I am just coming to… what I thought was the end… of a massive loop creation project utilizing cycle markers… some 3000 files… ummmmmmmmm

fk my fkn life, this project was such a labor of love, pain in the ass, mind fk, test of focus, self-degenerating time sink of a btch that I am just wrapping up, the above photo is literally the last project which happens to be the only one in 44.1 which made this issue stick out, and now I cant’ have the confidence THAT ANY OF THESE 3000 FILES TURNED OUT THE WAY THEY WERE SUPPOSED TO.

fk my life. fk my fkng life. fk it, give me the corona. infect me please.

Maybe try to convert it to a higer sample rate if it gives better results (make a copy).

Stay positive :slight_smile:

This is a huge protocol problem.

Is this actually normal, or is this a bug? Does anyone know? I can’t see this being a tolerated export behavior by the professional community…

Example at 88.2khz