Major Plugin display bugs in 7.2

I appreciate the update to 7.2, lots of good new features.
However, I’m opening a session I had worked on yesterday and the Waves plugins sometimes appear all white until I close and reopen them…iZotope 5 has a bigger issue, I can’t even see it at all. I can see the outline but it is totally transparent. I played with the window transparency settings but still nothing.

It’s a big problem to not be able to see the plugin at all, the ones that are glitchy are at least fixable, but far from ideal.

I am on OSX 10.7.2 with a Mac Pro and the very latest 5.0.1 of oZone5

It seems that opening a new instance of oZone 5 will make it appear, but saving and and reapplying settings for many sessions is far from ideal.

Also, when I try to move a plugin window, some glitches happen and the plugin turns white. Closing and reopening the window solves this.

Here are some photos, it’s pretty bad.
When the plugins go white, you can’t even move or close them, the only way to close them is to use the option in the master fader section, which is easily blocked by the white plugin itself.

Also, the meters in the Waves plugins show levels even when no music is playing, as show in the photos.

Links to the screen shots:


thanks for the feedback. We’ll look into this issue.


Thanks, I appreciate your timely response and it really slows down the workflow and makes things rather difficult…

Also soundtoys plugins GUI appears white here (Mac latest version native bundle v.4 and devil-loc)

Yes, the white is actually not just specific to Waves and oZone, just the two I happen to be working with most yesterday. UAD plugs appear to have the same issue, all are the most current versions.

It seem to be a global plugin issue.

Often, I don’t see the very top part that allows you to close or make the window small, it’s just white but still seems to function if you guess correctly where the button would be, however, when you guess correct and close it, it turns white instead of closing entirely.

I’ve found that using the plug-in visibility option in the master section opens and closes them correctly, but they are still very buggy overall.

Soundtoys are even worst, trust me :slight_smile:

The fun is that this version passed the full Steinberg tests unlike 7.1.1. Whatever…

I do trust you…it’s a total mess.
I hope it’s a quick fix, borderline unusable.
Is the download to 7.1 still posted incase I need to revert?

iZotope 5 nearly unuseable, transparent GUI with outline.
oZone 4 at least shows up.

+1 :frowning:

I wonder if this is a bug from trying to make other plug-ins more compatible, or something of the like.

This is technical, but WaveLab 7.2 is based on “Cocoa”, while earlier versions were based on “Carbon”.
Carbon is till supported in OSX but is regarded as obsolete by Apple. For instance, 64 bit application can’t be Carbon at all.
WaveLab 32 bit can host plugins made with Cocoa or Carbon (but hosting Carbon and Cocoa plugins is very different “from inside”). I think the issue that are reported here concern Carbon plugins. Of course, Carbon plugins have been tested with WaveLab 7.2, but apparently certain Carbon plugins that we did not test, create problems.

Thanks. What does this mean in the real world? Is there a fix coming or do I need to boot it in 64-bit to use the Cocoa versions, if that is even possible???

UAD plugs are working fine here FWIW. Win 7 though.

To use the 64 bit version of WaveLab, you don’t need to reboot in a special mode. You have to open the Info dialog for WaveLab and uncheck “32 bit”.

BTW, the VST iZotope plugins seem ok (not the VST3 versions).

Thanks, normal VST of iZotope does work. When I boot in 64-bit I lose the Waves, UAD and most other plugins.
Do they have special installers for 64-bit or are they not ready for 64-bit?

It seems that this could be a big problem since many major plugins are 64-bit yet. Not PG’s fault, but it would be good if all 32-bit plugs worked at least as good as they used to going forward.

As much as i was starting to like WL, and the 7.2 (otherwise), I don’t know if i can handle working with it when most of the plugin windows go white and act up.

Even the VST of Ozone has the symptom of going white at the top of the plugin when switching windows or other random times.

Hi PG,
I don’t think this bug is mainly the fault of the plugins. If I have all plugin windows for the master section closed, and use a different program like mail or safari, when I return to Wavelab the plugins try to reappear but then have the problem of being white and not displaying correctly.

I think many would appreciate if you look into this problem further, since it really slows things down by windows getting in the way that you can’t close easily or in some cases, plugins that you can’t even see the GUI and it’s transparent like Ozone 5 VST-3

I tried a few Steinberg plugns and they seem ok, but it’s bordering on unacceptable how most common 3rd party plugins behave in Wavelab 7 Mac.


I will look into this. There are several cases: I can reproduce with Izotope and Soundtoys. I think the problem is different in each of these cases, and I think the problem is on the side of the plugin, but I have to see if I can find a way around that (the fact that these plugins appear correctly in other hosts don’t prove anything). There is also a 3rd case where you get a blank panel. This, I think, is a WaveLab issue. According to various feedback, this seems a rare issue, though. But I still have to reproduce it.

Thank you. Let us know if you find a quick temporary fix, or better yet…an update that solves these issues.