mapping Nordlead or synth knobs as midi controller?

2 questions

First: Can somebody explain me or share a video of how can I do mapping of knobs from external synths as if where MIDI controllers?

I tried with:

Remote devices - Generic Remote - Fader1 - Learn - MIDI input (All MIDI inputs) - MIDI output (not connected) and also tried ( output 828mkII)

But is not working, Adress still showing number 7, am I doing something wrong?


Second: after that, how can I assign/ map that Synth knob to a knob of some VST?


Thanks in advance

Hi,

  1. Yes, you are at the right place.
    A) Set MIDI In.
    B) Click Apply.
    C) Now you can use the Learn function.

  2. Use Quick Controls or VST Quick Controls.

Hello Martin, back to the thread… I tried with no luck

What exactly I should set in MIDI in? as I will use external synth as midi controller, there is non controller (I haven’t)



  1. Use Quick Controls or VST Quick Controls.

sorry by the nob question, but what I should do in Quick controls?


I feel a little bit lost in Cubase whit mapping

Thanks in advance

You should select your HW synth as a MIDI Input. But it’s a good question in fact. The question is, if the synth does send any MIDI data by using the knobs. Some synths send it to the internal sound engine only.

Quick Controls are more universal. You can use them for both VST (plug-in effects) and VSTi (instruments). Once you make your assignment in the Studio Setup window (so you select the input MIDI Port, you assign controller X/Knob 1 is assigned to virtual Quick Control 1, controller Y/Knob 2 is assigned to virtual Quick Control 2, etc.), you can assign the virtual Quick Controls to the virtual knobs/faders on the plug-in. To do so open the track Inspector > Quick Control tab. Enable Learn in the Quick Control area there, and click to one Quick Control slot. Open the plug-in, and move the virtual knob/fader, you want to control by this Quick Control (i.e. the HW controller assigned to it). The connection is done.

this is the problem, I can’t set my HW because doesn’t appears there… correct me if im wrong but as my HW is connected to my 828MKII Ive added this in the input, there I only have:

not connected
all midi inputs
game controller 1
828 MKII

the second step I do is; flag learn then I move “fader” renamed as Cutoff and I move a knob from my synth, the address its 74 (its getting the midi)

but after that I im not sure what to do…


uhm… this is more complex than Ive expected…


how can I back to defaults? I messed up and now my synth (as hardware) not as vst, is not detecting the frequency knob when I record…

Does this mean that if a user can not be controlled, it should work as it should on the synthesizer?.. this is very strange…

Please some help in to this as I use a lot my HW…

Hi,

Please read something about the Quick Controls here, or watch some videos here.

Yes, 828 MKII is the right MIDI Port then.

I tried all this with no success … surely im missing something or im very fool to have this working…

I have this done, https://steinberg.help/cubase_pro_artist/v9.5/en/cubase_nuendo/topics/vst_instruments/vst_instruments_connecting_quick_controls_t.html?hl=quick%2Ccontrols

but I cant find the way to assign that to the cutoff of the vst…


I assigned “frequency” from “standard layout” to the cutoff of DIVA u-he, … but that “frequency” knob is no one in my synthesizer (nordlead) and the dress of the freq knob in my synth is 74… I have no idea how I should set that 74 to the standard layout or directly on DIVA…

pfff this is so confusing …

Hi,

Follow this video, please.

ive watched the video from start to end… I did step by step… but not working as expected… when I “do” the assignment, the frequency knob than I want to control de frequency knob of the VST, going directly to the “output” knob of the VST,

on several videos I seen like this one, no one explain how to tell to your physical knob what should control in the VST… or what im missing? most of DAWS can do this in a very intuitive way

In this last video, him is explaining than you can click on “no parameter” to change it, but I dont get how, I did that of “no parameter” I delete all, but the VST “output” still chained to the frequency knob of my synth…

im attaching a video, is just 1 min duration, and I show the steps im doing… maybe will be easier to identify what im doing wrong… (sorry by the big screen) with full screen you can watch it clearly https://youtu.be/XV-Gj9sCQ6M

Too quickly assign quick controls, you hit that L shaped symbol in the QC pannel, now you just need to select QC 1 and tap the control you want assign too it on the plugin gui. Select QC 2 and repeat and so on. When done, just turn of the Learning function. Remeber to save the Qc Template.

Thats about it.

Hi,

As I and (Reflection) recommended, use the Learn function.

  • Enable Learn
  • Click to the slot 1 in the QCs.
  • Move the parameter 1 you want to control in Diva.
  • Assignment is established.
  • Click to the slot 2 in the QCs.
  • Move the parameter 2 you want to control in Diva.
  • Assignment is established.
  • Etc.



Hi guys, first of all thank you for the patience, and for share your knowledge

I tryed to do this last steps, but … im still doing something wrong… I dont know what is it… this are my settings screenshots, please notices than “learn” function at the images are uncheck but was check when I moved my frequency knob from my external synthetiser

and also here is one more video, only 1 min left, of the new steps you showed me… but as you can see my external knob frequency is not learning or something im doing wrong because still chained to output from VST https://youtu.be/XUqC8HkyNJM

maybe down here is the answer to my problem? Im very confused …

I had no issue repeating your issue.

Cubase is not happy having the same controller/midi using both Generic remote and QC Vst. I think you should try and only use one of the options and not both.

Personaly I use Generic remote to map out the QC. And leave the QC and QC vst not connected. The Generic Remote is stable and can be expanded too control other things. That might be handy if You want to set up a custom controll for a plugin using more then the 8 QC.

I will ad a photo of my Generic remote wich cover my QC. You can use that as a guide to map out QC.If you deside to go with Generic Remote.

And whenever something get unresponsive, just reselect the track/plugin you are controlling. QC can be abit touchy some times.

HI,

  1. Please don’t mix up Generic Remote Device and Quick Controls. If you want to use Quick Controls, remove the 828mkII from the Generic Remote, and set the Generic Remote’s input to None. Maybe this would solve your issue already.

  2. Once you are doing the Learning process, please make sure only 1 slot is selected. To select it, click to the name of the parameter. Don’t click to the slider. Once you are in the Learn mode, don’t move any other slider in the Quick Controls. This could make an assignment to the other Quick Controls slot and a mess. Just click Lear, click to the slot (the name field) and move the virtual synth controller. Disable Learn. Nothing more, no step in-between. No move of the HW controller, no move of any QC slider, please. Once the assignment is established and the Learn is disabled, you can move the HW knob to test it.

Ive tryed this method and Reflection method… nothing works for me here… seems like Cubase is very unflexible using a HW synth as a midi controller… always going to the output …

here the vid:
https://youtu.be/-R1XkEB3R3g

How fustrating this must be for you. :frowning:

Try and make it sterile.

Try removing your hw synth as midi input to the instrument. This way the only midi transmitting is the qc too the plugin. That will rule out any mirroring midi.

Also in the video I dont see you assigning midi control to qc-3 (you might have done that prior to the video?) wich you assign frequency control too. Only see you showing that qc-1 wich you assign midi control too working.

Hi nordlead26,

I’m afraid, you are still messing the HW part and the SW part. CC74 (cutoff) is your source. the MIDI device can send any MIDI CC. You assigned MIDI CC74 (Cutoff) to QC1. Now it’s up to you, where do you assign it to. You assigned it to the the output. Everything is fine. You cannot expect the CC74 will control Cutoff in Diva, because you assigned it to different controller.

Btw in the VST Quick Controls, you have CC74 assigned to QC1 and QC5. It’s not a good idea.

Do you know, what is difference between QC and VST QC? Why did you switch to the VST QC now?

Please, could you make a video with step by step what did we advised? Could you show us this works to you or it doesn’t and what doe it do?

I will confirm that the direct QC options, do not play nice if you have other controllers or used other controllers.There are some rulers missing in the software, some place.

Any how I made a video of how to setup with Generic Remote. No audio, but I made sub, so remeber to turn it on.
https://youtu.be/WXam6z_fUo4

possible problem not sure of nord
make sure “local (control)” is set to “off” on synth
mapping knobs on moog phatty works great using generic and learn

CC74 in my HW is frequency…

No, thats what ive tried to say starting from the beginning… I never assigned to the output of DIVA, I never touched, some how is “pre assigned”… This in the case of QC. If I try with in Generic control, this go directly to the Cubase output… it weird


uhm? I didnt switched to VST QC, in my video Im showing I haven’t MOTU input in VST QC or Genering C, only in QC …

I will do… but believe me, what you cant see in my previous videos was for make you faster for you guys, but I did all the steps you showed to me… I will do one very detailed…



I see here is the confusion, as I said to Martin, I didnt assigned the DIVA output to CC74… was there already… CC74 correspond to frequency on my hardware synthesizer, Im not using a MIDI controller… if you see movements on “output” is because that…

it is… comparing with Ableton live, mapping here (as maybe im messing in something) seems to be complex than easier… I guess with a MIDI controller instead of a HW could be different history