Midi channels randomly change

When using Opus in Multitimbral mode, I may have 6 or 7 instruments loaded. I create midi tracks and map each one to the correct midi channel for each instrument. As I work on the project, now and then various instruments will either stop playing, or else they will play the wrong instrument. When I look at the midi channels, the channel assignments will have changed randomly. A track that should be assigned to midi channel 2 now is set to midi channel 8. I have to go back through the entire project and check every single midi track, resetting the incorrect ones. But after working on the project for another ten minutes, the channels will once again get reassigned randomly. It is very annoying and causes me to lose a lot of time simply correcting things instead of getting real work done. Has anyone see this? We need to get this fixed.

1 Like


Do you disable any of the track or the source Instrument Track?

No I do not.


So the MIDI Channel in the Inspector changes?

It changes in both the Track List and the Inspector.


This is weird. I’m not aware of any Key Command or even MIDI Command (MIDI Remote, Mackie, whatever), which could do this.

Could you try in the Cubase Safe Start Mode [Disable preferences], please?

I’m not the only one getting this. Take a look at this:

I just Googled this problem and this thread came up.

I’m having the same problem. The MIDI channel assignments randomly change on their own.

btw, I’ve had this problem going back to v10…didn’t bother to report it only to have someone say “we’ve never heard of this issue.”