Midi Controller fader controller no input at all

Hi guys,
Two weeks ago I bought a Korg NanoKontroler and couldn’t get it to work. I sent it back and purchase a much better AMC3 USB based midi controller.

Same issue. Zero activity from it.
I tested it on a Linux machine using Ardour DAW and it worked fine. So I know it works.

I purchased the AMC3 to have better control over various VSTs controls from Spitfire and Swam. To configure it they use TyCommander. I did this, assigning controllers 11, 21, and 1. When I open up a plugin like Spitfire’s Abby Road One it should work (since it’s been programmed already) to operate the default expression and other controllers I just programmed it for. It doesn’t do anything. So I right clicked on the control within the plugin and midi learned it…moved the fader of the new AMC3…nothing. I also unlearned the midi controller and tried to let it relearn the controller. It doesn’t see it at all.

I was thinking maybe I have to set up a MIDI REMOTE within Cubase but when I do this it doesn’t see this AMC3 as an available midi port.

I can’t tell at this point if this has to do with Cubase or Windows. My guess is windows.
I’m talking about this with the manufacture who also uses Cubase and Spitfire plugins but I thought I might throw this out there to you guys to see if anybody has any thoughts about this.

Got some screenshots of Tycommander and a MIDI utility called MIDI-OX recognizing the AMC3.

Thank you as always.

With the Korg it was almost certainly this problem, which is still a problem on my machine with the newest korg drivers. You can see the fix in here by registry edit.
It is not unusual for MIDOX to see it and Cubase not to with the Korg issue

With the AMC3 it may well be the same problem thought that is class compliant…but worth checking I guess.

Thanks Robw I did find that video also but I learned a few thing in the last hour.

MIDI OX doesn’t see the controller only when Cubase is running because I would guess the midi drivers are being used by Cubase which is why I get a “not enough memory” when trying to run a test with MIDI OX. As soon as I close Cubase base it works fine and sees the controller and displays the CCs that are programmed into it.

More interesting if I close Cubase and open say the Swam Sax plugin as a stand-alone without Cubase hosting it the CC controllers work fine.

So what in Cubase is causing this lack of communications?

Also the manufacturer of the AMC3 gave me a new firmware that changed it from a USB to Midi device to an HID controller but the same issues occure.

Some MIDI drives are single client only - so only one application can use them at a time.

If you start only Cubase can it see the Midi controller as available?
If it is available, is its All Midi In box checked?

Hmm well yes . In Studio/Studio Setup/Midi Port Setup I do see it in both in and out sections.
This time All Midi In was checked but I had tried to set this up six or so times and I know it was enabled at some point. This is an image of the Midi Port Setup. It shows as AMC3_####
I’ll try this again. Thank you very much Rob

I just checked it again and it still doesn’t work. Is it only me or does anyone else feel like they spend at least much time messing around with gear and trouble shooting things that should work as I do actually making music?

We all do from time to time. You have a new piece of kit so it’s kind expected.

At least now we know Cubase can actually see the controller.

Let’s see if anything at all is getting to the track - Can you please:

  1. Create an instrument track with any VSTi you fancy on it
  2. In the Inspector go to MIDI Inserts and add a MIDI Monitor
  3. Open the MIDI Monitor and move your controller - see it if shows up in the MIDI Monitor

By default, the MIDI Monitor should show any live events coming through without any need for playback or recording.

If you are getting results can you take a screen shot and send it through - that will mean your controller is working but for some reason not recording.
If you get nothing at all then the plot is really thickening!

My apologies if I am spelling out stuff you know to check. Just saves and to and fro if I don’t make the assumption. Clearly you know how to operate Cubase.

hi Rob…well I’m verynew to Cubase. I was using Ardour on Linux for a long time.
I used a VST I already running in the project Swam Sax. I inserted the midi monitor and nothing shows up when moving the controller. However I do have two keyboards with some CC control faders and these do show on the midi monitor. The difference is that the keyboards use real 5 pin din jack not a USB smoke and mirrors approach to midi.

I originally had all three faders set to channel 1 I recently changed them to channel 12. For control does this matter? I have a MOTU Midi Express 128 8 port midi patch bay. I have a few external rack modules most on their own port but some there is more than one unit on different channels. So like the DM5 drum modular is on channl10 port 4, The Alesis NanoBass andNanoPiano module is on port 5 but channels 1 and 6 are used and so on.
Is there any chance of conflict when it comes to channel on midi? This new AMC3 controller is USB to midi…so I guess it’s on it’s own “port” separate from the “real” midi?

Guys still can’t get this or any other stand-alone CC controller to work when Cubase is open. They work when using the plugins in stand-alone mode (without Cubase running) and all the settings look correct from what I understand in Cubase. There’s got to be something I missing. Any thoughts on this?

Is the track’s input set to All MIDI inputs?

Yes it is. If you look above in this post it shows the midi setup. The only think I can think of is that this device is USB not 5 pin din analog MIDI. I know it’s related to a setting in Cubase but it works without Cubase running and I also tried it in Linux using Ardour DAW.
This is driving me nuts!

Sorry, I don’t see the picture. I mean the input of the track over at the inspector, not at studio setup.

Edit: Do you have access to the device in Cubase at all? Can you make a Remote Surface for it? I mean does it show its ports? I’m guessing yes, since you can see it in studio setup, just making sure.

Yes I do have that setup in the Inspector to all midi in and I have it setup for “In ALL MIDI” in the MIDI Port Setup. But this isn’t the only controller I had this issue with. I just sent back a Korg NanoKontrol that had the same issue.

Ah, I now saw that you also couldn’t set up a remote because the ports aren’t available. Did you also try switching to the winRT device? At least to be able to say that you pulled every available rope on Cubase’s side.

It’s quite something, I don’t understand how the device is visible to some parts of Cubase but not to others. I think the manufacturer should know more. It’s a pity, because it looks a good enough device.

1 Like

Hmm you mean just check off the WinRT" midi? I didn’t try that
The manufacturer gave me firmware to flash the unit so it’s detected as a HID (Human Interface Device) rather than standard USB to Midi. That’s the way it’s set up now. The PC sees it as a new HID device and Cubase obviously sees it. Ahh. I don’t think this is related to this particular unit as I’ve had the same weird issue with the Korg controller too which I sent back…after using it as a wheel chock after changing my oil. :stuck_out_tongue_winking_eye:

Yeah just tried WinRT. Nope. It actually stops all of my midi gear from working because all of the gear is using the MOTO MIDI Express 128

1 Like

With many controllers, if you have their configuration software open, they become unavailable to any other application, because their Windows midi drivers are not multi-client.

So the trick often is to open Cubase first, before any other app that might connect to that controller.

Thanks Nico but it’s never that simple for me :unamused:
I did however try that after you had mentioned it just to make sure but it didn’t make any difference. Thank you for trying to help though. I do really appreciate it.

can you maybe post screen captures of

  • your track settings for the virtual instrument track in question
  • your Cubase Preference settings for MIDI Filter
1 Like

Sure thanks Nico.
Just and FYI. I just got in a USB TEC Breath Controller and I have the same issue with this. It shows up in Cubase in the Midi Setup and the drivers look right just like this new AMC3 midi controller but none of it works.

Cubase in the midi activity monitor in the bottom right corner it shows activity for the breath controller including bite, breath pressure, node and tilt and all three faders from the midi fader controller also shows data during movement of the faders.

I never worked with the midi filter. So anything in this dialog when checked off it will filter this data OUT of the midi stream?

Yes-- and your settings there look fine (those are the defaults I believe).

But I think I may have found the problem: It’s in your track settings:

Your Instrument Track is only listening to what I presume is your master keyboard (port 2 of your MOTU Midi Express). So it’s ignoring everything else.


You’ll need the track to listen to “All Midi Inputs”

and then in your Studio Setup - MIDI Port Setup, ensure that “All MIDI Inputs” has all of the ports check boxes marked that you want to your instrument track to listen to.

  • Port 2 of your MIDI Express (so it listens to the master keyboard)
  • your AMC3 fader controller
  • your breath controller

… and in the future, whatever else external midi controller your instruments are supposed to listen to.

1 Like