MIDI devices from the MIDI Device Manager are broken in Cubase 12

My MIDI devices which I created in Cubase 11 are broken in Cubase 12. The panels are gone. I use Windows 11. You can easily recreate the problem: Start the Device Manager, create a new device, add a panel, add some faders and knobs to the panel, save and close the editor. When you open the device again, erverything is okay, the panel with the faders and knobs shows up. Now close Cubase 12 completely and restart it. Open your newly created device and - the panels are gone. I have to use Cubase 11 again for my external device to control it properly. Please, Steinberg, get it fixed soon.

1 Like

I can confirm the issue of missing device panels in Cubase Pro 12 (Windows 10 here).

@MatthewTheDusty , @Aivaras : Thank you for the report. I will have a look and report back, later.

@MatthewTheDusty , @Aivaras : I can confirm the issue. Sorry. I’ll take care of it asap.

1 Like

@MatthewTheDusty , @Aivaras , the issue has been solved. It will be included in the upcoming maintenance release (if nothing unexpected happens). Thank you.

2 Likes

Many thanks, J.!

1 Like

@JRoeper, the fix doesn’t seem to have made it into C12.0.10 as the issue seems to persist.

1 Like

@Aivaras that is not expected. I double checked that the issue made it into C12.0.10. QA confirmed the fix, also. Are you talking about the exact problem reproduction procedure, that @MatthewTheDusty was describing at the beginning of this thread? Can @MatthewTheDusty confirm the fix?

I’m talking about:

I just tried to load the inspector panels, which I created in C11, in C12.0.10 and failed to (as I did in C12.0.00).

Can you load an inspector panel created with C11 in C12 on your end?

(By the way, I cannot edit those panels from the MIDI Device Manager, either.)

Hello @JRoeper and @Aviras,
I can confirm the fix. For me it works fine now.

1 Like

I think you should create an external instrument and connect it to you device. Look here:

https://steinberg.help/cubase_pro/v12/en/cubase_nuendo/topics/vst_connections/vst_connections_external_instruments_setting_up_t.html

Then you can create an instrument track and select the external instrument for this track. It will show up in the inspector panel then.

After looking into the issue more deeply I have determined that during the upgrade from C11 to C12 the panel XMLs were not automatically copied from “\Cubase 11_64\Panels” to “\Cubase 12_64\Panels”.

After manually copying the files to the new location I can access them in C12!

1 Like

Thank you, @MatthewTheDusty for confirming the fix. :+1: :slight_smile:

1 Like

Hi @Aivaras :slight_smile:, thank you for the details. I guess the panel XMLs were migrated to “\Cubase 12_64\Panels”, but were then deleted later due to the bug present in C12.0.0. Am I right in assuming that the original issue is solved for you as well, Aivaras?

Yes, you are. Thank you very much for your work!

1 Like