MIDI-Noten spielen zu lang

09.09.2012 ERLEDIGT.
Das Problem hat sich um ASIO-Treiber gehandelt. ASIO4All hat bei meiner Einrichtung nicht ganz perfekt funktioniert.

[Man kann auch diese Paragrafen überspringen. Mein zweiter Eintrag hat mehr Details.]
Hallo Cubase Forum.
Ich habe 30.08.2012 um 21:06 GMT diese Frage auch auf Englisch gepostet. Ich beherrsche Ihre Sprache nicht besonders gut, geschweige denn die technische Begriffe. Deswegen Entschuldigung.
Die Taktangabe ist 4/4. Ich erzeuge eine MIDI-Spur. (Das Projekt hat keine andere Spur.)
Darin zeige ich zwei Querbalken mit dem Key-Editor ein.
Der erste Balken hat Tonhöhe F3. Er dauert von 1.01.01.000 bis 1.04.04.006. Der zweite mit Tonhöhe G3 Balken dauert von 2.01.01.000 bis 2.04.04.118 .
Wenn diese Noten über ein MIDI-Keyboard zurückgespielt werden, dauert die erste Note etwa 15% länger als gezeigt. Die zweite Note wird zwar aktiviert, aber die Erste spielt noch immer. Derselbe Effekt wird durch den Tonkarte des Computers produziert.
Wenn die Noten diesselbe Tonhöhe besitzen, ist der Effekt noch komplizierter. Aber ich langweile Sie nicht mit noch mehr Gerede. Wenn jemand erklären könnte, was los ist, dann wäre ich sehr dankbar.

Trevor Brawn

Sustain Pedal gedrückt?
Sustain Knopf gedrückt?
zu viel Release?
nachdem der “Fehler” trotz “keinen gewählt MIDI-Eingang” (keine MIDI-Inserts) und nur dem VST als Ausgang gewählt, wo der Sound entweichen soll, auftritt: sitzt das “Problem” wahrscheinlich vor dem Belchtrottel… (i.d.R.^^)

Mit anderen Klangerzeugern besteht das Problem auch?

Danke für die Antwort, Loop Breaker.

Hier sind ein paar mehr Details. Noch mal Entschuldigung wegen der Sprachfehler.

KURZFASSUNG:
Mit Cubase 6 ertönen alle Noten in MIDI-Spuren 15% zu lang.
Aber mit Cubase VST & Cubase Studio 4 kommt das Problem nicht vor.

Ein einfaches Beispiel ist ein Projekt in 4/4. Metronomzahl 60.
Die einzige Spur – eine MIDI Spur – besitzt 2 Noten:

  1. F3 von 1.01.01.000 bis 1.04.04.006
  2. G3 von 2.01.01.000 bis 2.04.04.118

Beide Noten spielen zu lang. Also spielt die erste Note weiter, nachdem die zweite Note aktiviert wird. Man hört eine kurze Weile die beiden Noten – eine Überlappung.

System:
Windows 7 Computer. GM Keyboard ohne Sustain-Pedal. Tonkarte.
Die funktionierenden Ausgänge in jedem Fall sind entweder eine USB-Verbindung zum Keyboard (Midisport UNO Out) oder die Tonkarte des Computers.

Projekt:
Die Herkunft der Spur mit den zwei Noten ist ein Typ 1 MIDI-Datei TWONOTES.MID

Keine Effekten sind explizit angestellt.

Die wichstigten MIDI-Parametern der MIDI-Spur sind Folgendes:
MIDI Kanal 1
Das Kanal der beiden Noten: 1

MIDI Programm 20: Orgel oder 41 Viola oder 57 Trompete.
Die Überlappung der Töne kommt immer vor.
Natürlich spielt die zweite Note auch zu lang.

ANDERE PROGRAMME
Wenn die folgenden Programme geöffnet werden, TWONOTES.MID importiert wird, und das Resultat gespielt wird, spielen die Noten genau richtig durch dieselbe Einrichtung (den selben Rechner, dasselbe Keyboard, dieselbe Tonkarte).

MIDI Maestro
Cubase VST 5
Cubase Studio 4

Die zwei Noten stellen das einfachste Beispiel des Problems dar.
Leider stimmt das auch für die 20 Studio 4 Projekte die ich soweit in 6 geöffnet, gespeichert und gespielt habe.
Die drei Programme oben funktionieren richtig. (Für VST 5 und MIDI Maestro exportiere ich zuerst eine MIDI-Datei.)
Mit Cubase 6.5 und Cubase 6.5.3 spielen alle Noten in jedem Fall 15% zu lang.

Es muss gesagt werden, dass das Playback in Studio 4 zittert gelegentlich.
Ich habe keine Verbindung zwischen das Zittern und CPU Auslastung festgestellt.
Aber das ist vielleicht ein anderes Problem.

Danke

Trevor

Mit anderen Klangerzeugern besteht das Problem auch? (Instrumentenspur, F11-Rack)


häng einmal “in” auf “out” und nimm die Midi-spur auf eine neue Midi-Spur auf, und schau ob sie ident sind…





falls du grad nicht Midi IN mit OUT stecken kannst: kannst du statdessen einen Virtuellen Midi Treiber verwenden:
der tut nichts anderes als IN auf OUT zu schicken (zB. von einen Programm ins andere oder von der MidiSpur zu einen Generischen kontroller>QuickControls…

loopMidi is gut, aber vorsicht, das du nicht “all Midi” gewählt und den “loopMidi” ausgang gewählt hast,
weil sonst schießt sich cubase selber ab, weil quasi eine Midi-Rückkopplung ohne Zeitverlust^^
darum geh gleich unter Geräte-Konfigurieren / MIDI und mach bei deinen loopMidiPorts das “all Midi in” Hackerl weg…
http://www.tobias-erichsen.de/software/loopmidi.html

Hallo Loop Breaker.

Ich habe nie in 15 Jahren VST-Instrumente benutzt. Ich weiss, ich schäme mich.

Mit loopMIDI und Bome’s MIDI Translator eingeschaltet sieht man in Cubase MIDI-Aktivität 2 Signale mit 0,1 Sekunde Abstand am Ende der ersten Note.
Etwa eine Viertelnote nach Anfang der zweiten Note kommt noch ein Puls, der keinen offensichtlichen Grund hat -
der List-Editor ohne Filter zeigt nur die 2 Noten.

Dieser Puls passt ziemlich genau zum Ende des Klangs der ersten Note.

Ich denke, es gehe bestimmt um die Einstellungen und Software meines PCs.

Ich habe heute Cubase 6.5.3 auf meinen Laptop installiert. Diese Einrichtung funktioniert korrekt durch das MIDI-Keyboard. Man hört gar keine Überlappungen.

Also jetzt gebe ich eine Weile auf, zumindest bis ich die Chorprobe Aufnamen gemacht habe, wir fangen nämlich am 4. September an.

Leider mangelt die Spezifikation des Laptops an Kraft. Deshalb muss ich später zurück.

Ich bedanke mich bei Ihnen für die Hilfsbereitschaft und die Hinweise, die Sie mir gegeben haben.

Trevor

am Midi-thru vom Keyboard steckt auch nix?
ein Screenshot sagt oft mehr als tausend Worte (sind jetzt 2 Noten die eine beginnt ca. wo die andere aufhört?)…
Beim testen wähle immer genau den Eingang nicht “all Midi” (oder wie das heißt) vl. liegt da ja der Hund begraben…

Hallo Loop Breaker.

Ich benutze nur die MIDI-In und MIDI-out Stecker am Keyboard.
MIDI-Thru ist in Cubase ausgeschaltet.
Die Internal-Tonkarte produziert denselben Effekt.

Die Lage im Projekt TWONOTES ist wie in der zweiten Post:

… ein Projekt in 4/4. Metronomzahl 60.
Die einzige Spur – eine MIDI Spur – besitzt 2 Noten:

  1. F3 von 1.01.01.000 bis 1.04.04.006
  2. G3 von 2.01.01.000 bis 2.04.04.118

{Also etwa 113 Ticks Raum zwischen Ende der ersten Note und Beginn der Zweite}

… MIDI Kanal 1 {ich habe “1” im MIDI-Kanal Kästchen der Spur ausgewählt, nicht “All”}
Das Kanal der beiden Noten: 1

Ich habe Songs mit Cubase 1, 3.5, VST 5 und Studio 4 gebaut.
Diese Situation ist mir neu.

Es ist auch ein Rätsel, dass sämtliche Projekte in Studio 4 mehr oder weniger richtig funktionieren, doch jedes zeigt dasselbe Problem, wenn sie in 6.5.x geöffnet werden.

Vielleicht frage ich Steinberg Support. Windows 7 läuft auf beide Maschinen.
Aber es geht um den Computer, glaube ich. Wieso sonst soll der Laptop alles richtig machen und der PC nicht?

Ich brauche einen Drink. Aber leider trinke ich nichts.

Ich danke Dir nochmals. (Entschuldigung, dein “du” ist mir bis jetzt entgangen}

Trevor

P.S. Was ist ein Belchtrottel? Ich weiss was ein Volltrottel ist. Aber eine Internet-Suche hat nichts außer einer Menge Youtube-Einträge über den Film “Der Blechtrommel” gefunden.
Belch auf englisch bedeutet Rülps. Ich bin Ausländer und alt. Ich verstehe die coolen Redewendungen nicht, tut mir Leid.

P.P.S. Hoffentlich werde ich nicht vom Forum verbannt, weil ich das Wort “Rülps” getippt habe.

aso, etnschuldige, ich neige gerne dazu im slang zu sprechen…
bei uns sind im übrigen alle musiker “bei du”, und hoffe das es dich nicht stört wenn wir uns “du’zen” und dieses “erhabene fürstliche _Unterdrückung_srelikt” (=“Sie’zen” / die Adjektive davor = Sarkasmus)

Ein Belchtrottel = Computer da sie oft aus Belch sind und den Rest hast Du schon richtig verstanden, nur halt auf das Stück “Blech” bezogen^^)

Da dein Problem bei Dir nur mit einen Programm auftritt (Cubase 6)
liegt es anscheinend an deinen Cubase einstellungen (wie du selbst schreibst)…

Midi-Thru deaktivieren ist normalerweise keine gute idee…
ich meinte nicht den Kanal sondern den Midi-Eingang (über Alle 1-16)



Mach einen “Cubase-Einstellungen-Reset” indem du den
Cubase Anwendungs Einstellungen Ordner umbenennst (das wird dir der Support auch erst mal sagen…)
dan starte Cubas neu; Cubase wird den Ordner nicht finden (weil du ihn umbenannt hast)
und einen neuen erstellen (mit neuen einstellungen)
https://www.steinberg.net/index.php?id=2022&tx_p77sbknowledgebase_pi1[article]=224&tx_p77sbknowledgebase_pi1[]=&L=0&#2
kurz von mir zusammengefasst:
Start drücken>
alle Programme>
Cubase6>
Dateiordner der Cubase-Anwendung ODER GLEICH:“C:\Users\user\AppData\Roaming\Steinberg\Cubase 6_64”
und benenn den Ordner um,
starte Cubase



Der Wohl beste Thread im Forum.
English:
https://www.steinberg.net/forum/viewtopic.php?f=130&t=23576
Deutsch:
https://www.steinberg.net/forum/viewtopic.php?f=131&t=23926



Lg

Hallo Loop Breaker.

Überhaupt nichts zu entschuldigen. Es war sehr unterhaltsam, mit Dir zu reden.
Ich habe auch ein paar neue technische Begriffe gelernt.
Das Siezen ist mir auch etwas bedrückend.

Die Sache mit dem MIDI-Thru darf etwas für sich haben.
Ich hatte nicht einmal realisiert, dass man MIDI-thru in jeder Spur ein- und ausstellen kann.
Als ich MIDI Aufnahmen mit dem Keyboard gemacht habe, konnte ich nicht verstehen, warum ich immer Doppelnoten kriegte. Die zweite Note was immer etwa 1/100 Sekunde nach der Erste.
Jetzt weiss ich Bescheid.
Man würde nicht denken, dass ich seit 1994 MIDI Songs mit Cubase gebaut habe.
Oh weh.

Wenn ich Zeit habe, werde ich durch den Inhalt der Links arbeiten, die Du mir geschickt hast. Das VERSPRECHE ich.

Leider habe ich im Moment keine Zeit mehr. Morgen geht’s wieder los. Heute Abend musste ich Partituren aus CPDL für meinen Chor ausdrucken. Dann Dienstag & Mittwoch bis zum Weihnachten weiter mit den Proben.

Du hast Dich sehr viel bemüht, um mir zu helfen. Ich danke Dir.
Falls ich irgendwann Fortschritte mache, sage ich bestimmt Bescheid.

Übrigens, die Engländer(!) haben meine englische Post noch immer nicht geantwortet.
Ich bin eigentlich kein Musiker, nur Chorsänger.

Es war ganz nett, mir Dir zu sprechen.

Trevor

Danke für die Blumen!

ich meinte nicht Midi-Thru am Keyboard,
in den Cubase Einstellungen gibt es auch einen Punkt der heißt Midi-Thru, das kann man auch nur für das gesammte cubase einstellen… aber wenn das hackerl falsch ist geht gar kein midi oder so… alos wirds das nicht sein…


aber versuch einfach mal deine Cubase Einstellungen zu löschen, wahrscheinlich spinnt der Computer einfach, weil doppelte noten sind eigentlich schon komisch, und unter Midi-Einstellungen tu auch einmal spaßhalber alle anschlüsse deaktvieren und der reihe nach testen, aber zuerst Cubase einstellungen zurücksetzen/löschen/unbenennen…

Lg

MIDI-Thru in den Cubase Einstellungen habe ich auch gemeint.
Ein- oder ausgestellt, nichts scheint anders zu sein.

Aber jetzt komme ich zur Sache: Das für mich ursprungliche Problem ist gelöst.
{Oder: Das für mich ursprungliches Problem ist gelöst. Welche Form ist richtig? Oder sind alle beide falsch konstruiert? Ich bin noch nicht so weit.}

Es hat sich anscheinend um ASIO-Treiber gehandelt.
Das ist eine ziemlich lange Geschichte, beim Laptop hörte ich nichts, wenn ich “Microsoft GM synth” als Ausgang wählte. Aber wenn der ASIO-Treiber gewechselt wurde, funktioniert es wieder.

Also beim PC habe ich ASIO4All ausgeschaltet, um ASIO DirectX Full Duplex Driver einzuschalten. Alles war in Ordnung.
(Vorher hatte ich gar keinen Erfolg mit dieser ASIO-Version, also habe ich davor gefürchtet. Aber wenn nichts andere funktioniert…)
Ein Versuch mit dem “Generic low-latency driver” hat zwar ganz gescheitert, denn ich bekam zum ersten mal bei dieser Maschine den blauen Schirm des Todes.

Aber nachdem die Einstellungen gelöscht worden waren, funktionierte beide Treiber richtig.

Hurrah.

Trotz “trash preferences” (Einstellungen löschen) bekomme ich noch immer die doppelten Noten, aber im Vergleich ist das eine Bagatelle. Die Rhythmen in den Probenstücken sind ziemlich einfach. Also “Quantisieren” + “Doppelnoten löschen” wirkt ganz vollständig.

Sicherheitshalber: Um Einstellungen zu löschen, laut Anweisungen geht man via Start -> All programs -> Steinberg Cubase 6 -> Cubase Application Data folder -> [Alles außer den 4 Ordnern löschen]. Ist das richtig?

Trevor

Das für mich ursprungliche Problem ist gelöst.

es ist zwar “das” Problem, aber ich glaub, das hat was mit den Fällen zu tun…


Da das “Zurücksetzen der Einstellungen” anscheinend funktioniert hat, wirst du es richtig gemacht haben…

Der springende Punkt ist: das Cubase seine konfiguration nicht findet und sie neu anlegt.
Also würde umbennen genügen…

aber den “ganzen Ordner” umbenennen also:
C:\Users\user\AppData\Roaming\Steinberg\Cubase 6_64
auf
C:\Users\user\AppData\Roaming\Steinberg\Cubase 6_64spinnt


Ich würde mal versuchen alle treiber neu zu installieren… Cubase bei bedarf auch…

Mittlerweile glaube ich, dass ich einmal das gleiche Problem hatte, aber es war dann auf einmal weg, (dachte ich bin bekloppt) du bist aber jetzt der 2. von den ich hier les das “doppelte” Noten bei der aufnahme auftertten, die scheinbar nicht auf beabsichtigtes Midi-Routing zurückzuführen sind…

Hallo Loop Breaker.

Entschuldigung wegen der langen Pause.
Ich hatte Grippe, danach musste ich die Audio-Aufnahmen für den Chor machen – 18 Lieder je mit jeder Stimmlage verstärkt, insgesamt 90 Tracks. Das läuft noch immer. Ich habe Furcht, wenn ich damit herumbastele, kollabiere die ganze Vorrichtung. Dann stecke ich bis zum Hals in der Du weisst was. Aber wenn die Zeit erlaubt, mache ich genau, was Du vorgeschlagen hast.

Danke wie immer für die Hilfsbereitschaft. Geschweige denn, ich habe die Gelegenheit, mit der Sprache zu üben.

Trevor