Midi notes all start at the same place when recording

Hi,
I just got Cubase 8.5 Artist, pretty new with is (I used SX3). Now that I connected my Yamaha piano to the Focusrite Scarlett audio interface and started to record midi, all the notes are recorded at the same place when I pressed the first key. I can hear the instrument while playing, but when recording, everything is recorded at the same place, at the very first beat.

Can you please add to your signature information on your system (Operating System, CPU, RAM, version and build of Cubase, Audio Interface, MIDI Interface, etc)? This will help users to give you a more detailed suggestion regarding your issue. Can you please add that information here?

What Yamaha piano are you using? Are you connecting it to the Scarlett via MIDI? Do you have the same issue if you record notes using the Virtual Keyboard in Cubase? Please be sure you have Auto-Q turned off in the Transport bar.

I seem to remember this being a common issue a long time ago - it was to do with the Midi Port Enabler which lives (on my Win 10 setup anyway) in C:/program files/steinberg/cubase 8/ midi port enabler. Unfortunately I can’t remember how you were supposed to fix it, but it might be worth checking it out.

Did you solve this? I have the same problem…LE9

Guys, did anyone solve it?
Has the same problem with Focusrite Scarlett 8i6 3rd gen and 5 pin midi in/out cables. Works fine with another USB midi keyboard.