Midi Notes recorded ahead of playhead

hi there,

i know this has been covered multiple times in this forum but i still can not get any solution i’ve found to work. basically its the old problem of when recording notes via a usb keyboard the actual notes are recorded ahead of the playhead by around 1/32nd note … i’am doing this while using a VST soft synth instrument and not an external piece of midi hardware… it also happens with just a single midi track and nothing else so it cant be related to the processor or any asio overload…

in cubase 4 i solved this issue by moving the ‘port enabler’ file. in cubase 6 on a mac this file doesn’t seem to exist. i’m totally stuck and its getting very annoying… as when you practice playing everything is fine, though once you record something all notes are completely out of time… im getting to the point where i just want to dump cubase and use something else as this never happens in ableton live…

if anyone has a decent solution to this i’d be truely greatful… i have searched this forum for this problem but have only found the above solution which i cant implement in cubase 6

im running OSX 10.6, RME fireface 400, mac book pro i7 2.6gb with 8gbs of ram, with a korg microkontrol as the usb keyboard… any ideas would be truly appreciated :smiley:

EDIT:

after performing the loopback test mentioned else where i thought i’d share my results… have been reading this long long thread… https://www.steinberg.net/forum/viewtopic.php?f=19&t=20516&start=325 and it looks like this is unsolvable ? :frowning:
cubase.jpg

Is this realy around 1/32nd? Wht if you use 60 BPM, 120 BPM, 240 BPM? Is this based on note length, or on time?

Is this issue if you are using both MIDI track and Instrument track?

Let’s see how long it takes until Conman arrives and shouts “There IS NO PROBLEM!”

hi martin,

thanks for the reply! the bpm doesnt make any difference… and yes… this happens on a single midi track with NO vst’s on (as in the image attached in the previous post) and on an instrument track… you can see from the image that USB MIDI (connected directly to the laptop) and CABLE MIDI (dealt with by the RME) has a pretty big difference…

alot of these threads that iam reading go on about the technicalities of this… ultimately this seems to be a systemic problem with cubase as it appears in all versions irrelevant of system setup… i’ve had the same issues on a custom pc and a brand new mac book pro… using cubase 4 through to 6 … its only now that im getting fed up with it! :smiley:

there must be some kind of simple update or logical workaround that can be performed other than having to shift the notes manually… this is really bad especially if you’re wanting to overdub or add to a recording in real time.

any advice would be super cool!

bests!

Using my usual style and NOT making clueless snide comments (they never try to solve they just seem to go “+1” and endlessly complain and WHINE about anything and WHINE about anyone that dosn’t whine with them) about other users.

I will say that it’s worth looking at every other sound setting on your system. The problem could arise from the sample rate you are using both in the soundcard and the Windows sound settings changing them in both locations (one at a time at first, don’t mix up settings or you’ll get muddled).
If you use fairly uncommon samle rates like 48k/96 kHz rarher than the usual 44.1 / 88 then if there’s an unusual bug in one of those settings you may uncover and then report it.
Some faults can be corrected by changing the sample rates in Windows sound settings. I have had to do this myself but in my case the whole sound was gone. I changed sample rates and problem gone. I even changed back to the original and it was still gone! This was on advice from a friend. The result and cause is still a mystery to me and is one of those Windows things. But it is always worth trying everything so I’d try that one even though I know that someone will write in and say that changing the Windows Sounds isn’t likely.
I’d say that if it is a bug it will be in a fairly uncommon setting of the Windows or Soundcard settings, Windows most likely, that are conflicting with some Cubase system calls causing a misplacement of midi.

and your contribution to solving this problem is…?

Have you seen the reports about typical troll behaviour? Picking on others? You’re on thin ice buddy.
Grow up. You and your “mates”.

http://www.bbc.co.uk/news/technology-18408457

hi conman…

thanks for the reply… unfortunately im on a mac and local sound settings at this kind of granularity don’t exist… (unless i use the mac audio in cubase) only via the RME mixer/matrix/system can i change the sample rate / buffer size.

i’ve contacted steinberg directly about this issue and will see if they get back to me… it seems like this is a very common problem for all cubase users with varying setups… its a shame as i love cubase alot, been a user from the very first VST version… all that needs to happen is for them to give some kind of ‘company response’ to the issue rather than letting the community try and create workarounds… its interesting that ableton doesn’t suffer from this slightly crippling problem :slight_smile:

all the best!

it seems like this is a very common problem for all cubase users with varying setups…

It’s not common. And it’s not all Cubase users. Otherwise no-one would use Cubase. :unamused:
If you put your system specs in your signature it would help others to help you.

all that needs to happen is for them to give some kind of ‘company response’ to the issue rather than letting the community try and create workarounds

Sysytem specs. If you ring the mechanic and say “The car’s making a clicking noise, how can I fix it!” he’s going to put down the phone. Do you just want a “company rsponse” or do you want it fixed?
The community is here to help and not JUST complain.
Workarounds are how things actually work rather than the way you want them to work. :mrgreen:

I have the same problem in reverse: notes played too early. I could suppose that this problem si due to latency, causing you to play the notes too early or late to compensate for it.

As for Conman’s suggestion…How in the world would system specifications solve anything? Most of my problems haven’t been solved and look at my signature. Let’s say he posts his system specifics; what is one to do? Buy him a new computer?

Yes, by default the system specs should be in the signature, but as for using them to solve the problem, I don’t believe that it will help unless you think that telling a person that he has to spend more money or weep over his apparently poor equipment is extremely helpful. :frowning:

Question is: Is USB before (and MIDI right), or MIDI late (and USB right)? How can you find out, which one is correct?

If one has a problem then you have to help the guy that you want to fix the problem by being bothered to make an effort yourself. The problem is not hands on for anyone trying to fix it so it’s harder to diagnose. It’s not much to ask for tuppence worth of help.
See, if you can’t make that effort the upshot is that the person with the problem ALSO hasn’t bothered to set up his rig right in the first place. While that might not be right that’s the way life is.
If you loook tidy and professional in your dealings with the thing then you’re more likely to be treated seriously.
“Aw, gee! man there’s sumpn up! Fix the daym thing.” Just doesn’t cut it to a programming trouble shooter.

Fair enough.

…wait do audio interfaces have their own latency/buffer settings? I wouldn’t know, but maybe the buffer settings are inconsistent? (If that’s even possible).

Well, instead of claiming that “there is no problem for anyone, otherwise nobody would ever buy Cubase”, it seems that since this is the umptieth thread about this issue, that there seems to be SOME substance to the annoying abservation the OP made.

It is also safe to say that hardware must have something to do with it, as some people (not very few actually) experience the problem and others don’t. (Which has been proven by tests in former threads). Again others may experience the problematic behaviour, but they never notice or erroneously blame their own inaccurate playing.

I am quite sure that hardware plays a role in this, as I used to have the exact problem myself (with USB audio connections as well as with MIDI-into-internal-soundcard-setups) and don’t have it any more (now with M-Audio). As the problem occured / didn’t occur on a machine with otherwise identical specs (the same machine) I would assume that the way the MIDI enters the computer would be the crucial place to look for the problem (and yes, there IS a problem).

I don’t know much about external MIDI in general, but could this be caused the quantize setting (Delay) on this track in the Inspector, is it at zero? What’s different about this track?

Mauri.

I suppose, there is no quantization on these tracks. Same as there is no input quantization. Am I right?

Is this the test where you connected your RME MIDI out to RME MIDI in.
Enable “activate MIDI click” (and enable your click of course).
Record a MIDI track (Input: RME MIDI in - Output “Not Connected”)?

hi niles,

thanks for the reply! nope its not that specific one… i just recorded the AUDIO OUT of my RME back into the AUDIO INPUT of the RME (audio out being the click from cubase) i then recorded myself hitting my keyboard in time with the click. what you see in the example jpeg is the results from a CABLE MIDI connection from the microkontrol via the RME and a direct USB connection from the microkontrol to the mac laptop…

i’ve recently updated all drivers and now the MIDI CABLE test is the same as the USB test… i know there are so many threads on this issue and its a problem that has hampered cubase since cubase 4 or even earlier… like i mentioned before it looks like there really is no proper solution other than manually adjusting notes, setting up some kind of logic editor macro or just giving up recording notes by hand! :smiley:

bizarrely i have just built myself a hackintosh with osx lion on and installed just cubase on it. using the RME and the MICROCONTROL on this machine and having one single midi track with no vst instruments i DO NOT get the problem!!!

i can only summarise that is must be a culmination of hardware and software latency’s / problems that cubase just doesn’t compensate correctly for… that and also other demands on the processor… the hackintosh has NO vsts or plugins installed yet… so it will be interesting to see what happens to the recording of midi when i start to install these… i’ll report back when i find out more…

thanks for all the advice people and please lets keep this thread constructive rather than inflammatory… we’re all here to help out each other :smiley:

bests!

Applications > Utilities > Audio-Midi-Setup

Best regards.

regarding the installation of more plugins on the hackintosh… after some problems with the startup of the machine after installation of the plugins, the system seems to be rendering midi notes entered via USB MIDI into cubase without any problems… i’ve not installed all my plugins as yet… just a few to test VST instruments and reverb etc etc…

so… my conclusion is still pretty cloudy… god knows why a pretty empty install of OSX lion on a hackintosh running cubase 6 does not run into these issues and a proper mac book pro with not that much installed on does… i wait to hear back from steinberg to see if they have further trouble shooting methods regarding certain plugins, applications and so on…

it must be to with certain resources/applications/plugins and how they introduce latency and demands on the processor… maybe we all need to just have dedicated audio mac/pcs with very little else on to solve these midi timing issues ??

what do people think ?

Amazingly there is no way to adjust for this AFAIK…

A simple ‘offset’ WOULD be sufficient.

Alternatively a method to toggle Midi Insert to be recorded (pre/post toggle) could achieve the PERFECT BALANCE by using Midi Insert delay WITHOUT CODING ANYTHING ELSE!!!

Steinberg, think about this deeply, please.