MIDI notes too early

I know this has been asked before, but no thread (at least no one that I found) focused on the issue and came to a clear solution.

PROBLEM: Notes being played on my master keyboard in accordance with the metronome are recorded slightly too early, i.e. they appear slightly but noticably to the left in key editor.


  • The notes are recorded up to 1/32 too early, in average 1/64 (at 120 bpm).
  • This “negative latency” seems to vary. Some are very near to the beat, others 1/32 early.
  • I can’t tell if the variation on “negative latency” comes from my playing or is part of the problem. However I feel playback differs from the way I recorded it. But that’s just a feeling.


  • Intel i7 notebook, 8 GB RAM, Seagate harddisk (internal), SSD (external, USB 3.0)
  • RME Babyface (USB), Masterkeyboard Alesis Q25, M-Audio Keystation 88es
  • Cubase 6.5.1, Vienna Instruments / Ensemble
  • Windows 7 64-bit


  • switching masterkeyboards didn’t help
  • connecting masterkeyboards via Babyface MIDI-in didn’t help
  • problem occurs on both Cubase and Cubase 64-bit
  • disconnecting USB mouse and keyboard didn’t help
  • empowering Babyface with 2nd USB-plug didn’t help
  • de/activating “Use MIDI Timestamp” (DirectX and Windows MIDI) in every possible combination didn’t help
  • de/activating “constrain delay compensation” option didn’t help
  • using recording offset didn’t help, in fact I haven’t noticed any difference no matter what I entered here (-100.000 to +100.000)
  • trying DirectX emulated MIDI port (instead of native Windows MIDI) didn’t help
  • reducing buffers on the Babyface to second lowest option did reduce the amount of “negative latency”, but it’s still there
  • could be that switching from acoustic to MIDI output metronome helped a tiny bit, but I’m not completely sure on that, again it’s just a feeling.


  • I installed the RME Babyface on my old system (Dual Core tower, Windows XP, Cubase SX 3.1) in order to see if it’s the Babyface that causes the problem and: Suddenly I noticed the “negative latency” there, too. But:
  • Then I connected the old system with my old RME Fireface 800 and: Same problem!!

That leads me to three possible conclusions:

  1. The “negative latency” has always been there, and I just noticed it on my new system because there it was slightly bigger than on my old one. I can’t be sure about that, and I believe that’s not the case. I’m doing lots of percussion and drums “manually” and I’m very exact, I would have noticed if the notes were out of beat after recording.
  2. The Babyface drivers are the problem, and by installing them on my old system I disrupted its (working) driver architecture, so that the issue also came up with the Fireface.
  3. There’s something wrong with the new USB eLicenser. It’s the only thing (apart from the Babyface) I used with the new and the old setup.

This is a very tough and annoying issue. Has anyone any idea?
Thanks in advance!

Did you try to record some MIDI data from your Babyface’s MIDI out to its MIDI in?
What’s the result?

I have the same problem with this configuration

OSX 10.7.3, intel i7 24 gb ram, Cubase 6.07 (and all the 6 versions)
Key AXIOM 49 (USB)

Solution’s in the manual, Knowledge Base and the old forums.

Someone here thinks he’s a super guru, but is afraid to actually provide solutions because everyone would call him on it and show how wrong he can be. And he does this in the guise of saying that no one should be spoon fed.

There has been a lot of discussion related to this in another thread. I would try Niles suggestion of the Midi Out and Midi In test. I would also try the audio thump test. Without the click track, use a Mic to record the key being hit. Compare this to the placement of the midi note in another track. Zoom in to see the difference using the transport bar times.

With this test I had a difference of 13 msec using my Presonus Firepod. Midi is actually later than audio for me. I am now using a Fireface 800 and see a slight reduction using RME Direct Music driver. Midi is now around 9 ms after, audio. However, now I tried another Midi controller and see only 4 ms gap.

Did you try this?

MIDI notes in Cubase are getting recorded to the start of the MIDI clip.
If you are recording MIDI data into Cubase through the Saffire MIDI in port and find that it is all being recorded to the start of the MIDI clip then follow these steps to fix the problem:


  1. Update your version of Cubase to the latest version (updates available from > http://www.steinberg.de> ).

  2. Browse to the Cubase SL/SX application folder (usually C:Program FilesSteinbergCubase SL/SX) and locate the folder “MIDI Port Enabler”.

  3. Open this folder.

  4. Pick the file “ignoreportfilter” and move it into the Cubase SL/SX application folder (one directory up).

  5. Start Cubase. You will now see ‘Focusrite Saffire’ and ‘Focusrite Saffire [Emulated]’ as available MIDI ports.

  6. Select ‘Device Setup…’ from the ‘Devices’ menu.

  7. Go to the ‘Default MIDI Ports’ page and set ‘Focusrite Saffire [Emulated]’ as both input and output.

  8. Go to the ‘All MIDI Inputs’ page and make sure ‘Focusrite Saffire’ is not active and ‘Focusrite Saffire [Emulated]’ is activated (click on ‘Yes’ or ‘No’ in the ‘Active’ column to change it).

  9. Go to the ‘DirectMusic’ page and check the ‘Use System Timestamp’ box.

  10. Click ‘Apply’ and then ‘OK’ to exit Device Setup.

not sure if it still applys to the current version but i remember having the same issue a few years ago and this was what fixed it for me…

1 Like

Yep. I’m a super guru. Used to have the issue, don’t anymore. :wink:

I’ve given where to find the answer over and over but you are too lazy/ stupid to bother to look for it yourself. :unamused:

Perhaps you should start your own super guru forum where you can mingle with your own kind, and leave us mere mortals alone.

This is from the Help section of Device Setup:

“If timing problems with the recorded MIDI events occur with your operating system, try activating the “Use System Timestamp” options.
All MIDI interfaces timestamp their data before supplying it to the application. The application uses these timestamps to position incoming MIDI events in the sequencer. There may be situations in which these timestamps are not in sync with the internal time information of the sequencer, so recorded MIDI events will not be positioned correctly (usually, they occur “too late”). When you activate this option, the sequencer ignores the MIDI timestamps provided by the interfaces (for Windows MIDI and Direct Music inputs, respectively) and generates new timestamps (using the actual system time) for all incoming MIDI data.”

Nope, wrong. :unamused:

What buffer size did you have originally, and what did you “reduce” it to as mentioned above?

Might also try to do the same recording technique with the buffer size at MAXIMUM. Do the MIDI notes move earlier than the 8 msec they are now (1/64th note at 120 BPM)?

Clueless. :unamused:

Try reverting your soundcard driver to an earlier one, or get the latest whichever applies.
Or even disable your soundcard and use the onboard soundcard to see if the same timing anomalies occur.

also try to do the same recording technique with the buffer size at MAXIMUM. Do the MIDI notes move earlier than the 8 msec they are now (1/64th note at 120 BPM)?

On some recent cards using a very high buffer rate can increase instability in the card or driver.
Try adjusting the ppqn rate in Preferences.

Nope. Can’t believe how quickly knowledge disappears. This has been covered so many times it isn’t funny. One setting is all it takes to fix the issue without fail in the dozens of times this came up here and the old forums. I have M-Audio and Alesis kit that suffers from the issue without the fix. I initiate the fix and presto, my MIDI is spot on. :wink:

MIDI issues on Windows (from Steinbergs Knowledge Base):


Don’t panic, just belt and braces just in case. Midi to audio question next. :mrgreen:

i can’t fix it…
The same fu… thing, midi too early, I can’t understand why using Steinberg hard (mr 816) I have this problem
I have installed the driver again (mr) and nothing change.
MAC pro, 10.7.3 (64 bit) CB 6.07 (x64)
AXIoM 49 (1st generation)
intel i7 920 24 gb ram

Can somebody help me?
I have spent 2 days reading forums and I don’t find the solution, is there one or is just a F…Bug?


There is one, no bug. The forum would be up in arms if it was a bug. Like I said, answer’s in the KB and manual.

answer’s in the KB and manual.

I can’t find the fix there.
I read also the hardware manual (MR 816) and nothing
Could you be more specific about it? I couldn’t find anything in CB manual neither, just about buffer, but this is not my problem I think.

Thanks in advance


I’ve been more specific dozens of times at the old forum and here. The answer is in the Knowledge Base and specifically states the issue.

I’ve told you there is a solution and where to look for it, the rest is up to you.