Midi-Remote doesn't recognize my MIDI controller after updating the hardware


I got Novation Launchpad Mini MK3 with a bunch of buttons assigned to it in Midi-Remote.
So, I just updated the Launchpad’s harware, opened Cubase, everything says it is connected and the midi-meter in Cubase receives messages from it, but Midi-Remote just doesn’t respond at all!

Can anyone help me out? I assume, the port might be wrong, but there’s no option to choose any other port and in the midi-script editor it says it is connected as well.

I tried rebooting my PC, switching to another USB port, the issue still remains…

More screenshots:

Hi @andreyshinami,

The hardware update probably changed the MIDI message layout. Please export your script to a “.midiremote”-file and upload it here. I can have a look on the bound midi messages.

After that, please close Cubase, (install and) open MIDIOx. Start recording your screen. Hit the LK-pads from upper left to lower right (western reading direction). Upload your screen-recording here as well.

Hope that’s not too much tech-work :wink:

I hope I got you right:
Novation_LaunchPad Mini Mk3.midiremote (9.3 KB)

I have imported your script. Can you confirm that still the upper left pad sends CC 57 on Channel 2?
Please clear the MIDIOx screen and only press the upper left pad, and post another screenshot.

I see two mapping pages: “Default” (is empty) and “SHS” which has Cubase functions mapped. When activating the page “SHS” I see mapped Key-Commands to Visibility-Agent related things, and a bunch of mappings labeled “Missing”, hmm.

The problem is that neither Default nor my custom SHS page responds. I mean, in midi-remote I can’t even assign any new button because it doesn’t get highlighted =/

Maybe the “Mapping Assistant” window is open, but hidden behind other windows? If so, MIDI Remote idles. But I guess you already checked that? :thinking:

Yes… I checked it. I now tried to delete the script and the controller and it started to recognize the buttons again!

But when I import my previous script, the issue comes back. At least I can reprogram the controller now, as it’s mostly buttons. But, still, it’d be very frustrating if a more complicated controller with lots of pages and knobs went down =/

Have you tried using WinRT MIDI?

Of cause!

Nope =/
By the way, is there an option to get to the same window where I can choose my MIDI ports using already existing script? I wanted to double check my selected ports, but this window appears only when I add a new MIDI Controller Surface.

Yes! It doesn’t let me choose!
It should be
Input Port: MIDIIN2 (LPMiniMK3 MIDI)
Ouput Port: MIDIOUT2 (LPMiniMK3 MIDI)

instead of what I have now:
Input Port: LPMiniMK3 MIDI
Ouput Port: LMMiniMK3 MIDI

I can see that you’re using different pairs of MIDI Ports. That’s most likely the reason of it.

Definitely! The problem is Cubase literally won’t let me change it from the excising script unless I start recreating the controller from scratch!

Any idea how can I choose another port using the excising script???

Please unzip and replace that json file with the one located here:

Novation_LaunchPad Mini Mk3.json.zip (6.0 KB)

I have changed the port names “stone age style” :wink:

Please quit and restart Cubase first, just to be really really sure …

Did the hardware swap midi port naming after the firmware update?

Your script worked! Thank you so much, man! So, basically whenever it happens again, I should open the script with a text editor and just manually rewrite the ports, right?

No, the hardware remains unchanged, it works fine with other DAWs. The problem was that Cubase automatically just switched the ports and there was no option to change it back, I guess.

Lordy, please don’t!

I was just thinking too complicated (typical developer issue).
You can always use the BIG PLUS button and create another instance of that device.

and then select a different pair of ports: