Midi Remote Randomly Disconnects

Hi,

Cubase’s Midi Remote connections randomly drops and stops working after “X” amount of time. According to the Midi Remote Manager “Status”, the actual connection/midi port is still available and strangely showing it’s connected. However, no midi messages are being read/sent by Cubase from the visual LED feedback, and well, nothing works.

These are not USB ports. I’m using a touchscreen through Open Stage Control. Messages are being sent through the ports according to loopMIDI. Cubase is just not receiving or sending anything, even when still connected.

I’ve tried using the reset in Studio > Midi Remote > Reset. As well, just refreshing the Midi Remote Scripts. The only thing that seems to reconnect the midi remotes (even though they are connected according to Midi Remote Manager “Status”), is to simply restart Cubase.

Is there a different way I can try to re-establish a connection with Cubase that I haven’t thought of? Or, is just simply restarting Cubase the only way? As well, any other thoughts on what could be causing this hiccup?

Cheers,
DMDComposer

Hi,

What happens, if you try to reload the script(s), please?

Hi Martin,

It reloads, logs that the scripts are loading. I can even put console messages in the script, save, and then refresh/reload scripts in Cubase to make sure it is loading the script. No errors whatsoever, but the problem still exists until I restart Cubase.

Hi,

Could the device switch to some kind of Sleep Mode by any chance?

Hi Martin,

Unless Cubase itself is putting asleep, I know for sure that OSC is not putting it to sleep. OSC debugging shows messages being sent out on the specific ports that Midi Remote is expecting. As well, loopMIDI is showing data being sent through the port.

Finally, to further test its something with Midi Remote and perhaps not even Cubase. I created a blank midi channel, and set the input to the port to the same that is being used by the Midi Remote. The MIDI channel shows incoming data, and the LED visual feedback on the midi channel lights up. However, on the Midi Remote, still does nothing and shows nothing in its visual LED meter until I restart Cubase.

Is there something in the API script I can write to test if it disconnects or sleeps?

Hi,

Unfortunately I’m not aware of something like this.

Have yo already tried other USB port, please?

Hi Martin,

Ahh no worries, maybe something will come out like that in a future update for the Midi Remote API.

There is no other USB port to try, it’s not a USB port I’m using. They’re virtual midi ports created with loopMIDI. In the sense of trying a different virtual port. Yes, I just tried that, and to no avail, the same problem.

Exact same issue with my M-Audio Keystation Pro 88. Connection is gone even though all the mappings are there in the MIDI Remote tab. Reloading scripts or trying everything on the “studio Setup” screen doesn’t solve the problem. The keyboard works for VST instruments, it just has no connection with the MIDI Remote Setup even though in there it shows as “connected”.

Weird and soooooo enervating.

1 Like

Hi,

Are you on Mac or Windows, please?

Windows 10