Midi Remote Randomly Disconnects

Yes, I do see this as well occasionally. It’s pretty interesting since it seems that somehow Cubase denies the incoming MIDI (no MIDI In activity at all for this port). Upon refreshing the script, or loading another project, 99% of the time, things get back to normal, while there have been cases I needed to restart Cubase.

Quick update on this,

It seems that this issue has been solved on my side. I left Nuendo running for 5 days now and my controller didn’t lose connection.

It seems to coincide with the fact that i switched to Nuendo 13. Though I can’t be sure since i’m constantly tweaking a lot of things.

I didn’t see anything related tp this in the latest release notes. So can anyone confirm that the issue has been fixed or is it somethingelse that I did?

Thanks

Thomas

Same thing here midi disconnecting randomly on win 11 up to date

Hi,

This is supposed to be fixed in the latest Cubase 13.0.40, which was released.

Thank you Martin!

Hi Martin,

I wanted to let you know that the problems still persists on my side.

Thomas

also for me the latest updated to 13.0.40 did not solve the issue

here in this thread i found a workaround though, so everybody who has the same issue, can have a look and check if the workaround helps here

Cubase’s Midi Remote connections randomly drops and stops working after “X” amount of time.

This issue was also reported from different users several times in the thread
PreSonus FaderPort 2 (2018) midi remote script.

In most cases, the issue could ONLY be fixed by restarting Cubase, but sometimes, a disable/enable or a reload of the script was also sufficient.

Since this issue occurs more or less often without any recognizable logic and cannot be reproduced in a targeted manner, this issue is probably simply accepted at the moment without Steinberg being informed. Affected users simply restart Cubase and live with the expectation that Steinbarg will solve this issue at some point.

However, it seems to be a fundamental problem with MIDI Remote that is not dependent on any specific hardware.

Good luck to Steinberg in correcting this issue, as I assume that it will be very difficult and time-consuming to find the cause.

Best regards
CKB

1 Like

Hi Martin,

after the reports that the problem ‘MIDI Remote Randomly Disconnects’ still exists even after the update to Cubase 13.0.40, it would be good if a fix were now given top priority.

Perhaps we can help Steinberg by having users affected by the error try out different setting variants, e.g. by simply switching off various system components?

Best regards
CKB
(I don’t have this problem myself, as my system is heavily DAW-optimized.)

Hi,

That would be great! But unfortunately, there is no clue, which components to try to switch.

The only one, I can think of, is to disable hibernating/sleeping/switching off/auto-sleep of the USB busses.

I’m glad to hear this. :wink:

1 Like

Disconnect happening several times a session here with my X-Touch. There’s no pattern to it.

@The_Elf
please try this:
create a new miditrack and map the input to your remote control device.

this little trick helped me to keep all my midi remote controls in proper connection.
somehow this midi track ensures the connection stays valid.

Cubase 13.0.40 did not solve the issue for me neither, as soon as i remove those midi track, my midi remote controls will become disfunctional as soon as i add or remove any midi device.
full thread on my issue:

i´m keeping my fingers crossed that the small workaround will also work well for you!

3 Likes

Same disconnect problem with my Arturia Keylab 88 mk2. Despite this, MIDI remote is a wonderful feature and I’m looking forward to future enhancements. Workflow is clunky, but I’m getting used to it. Might be tough for a new user however.

@exoslime Thanks for that. I’ll give it a try.

@exoslime I think it may be working. My X-Touch remained connected yesterday. Will try it again today.

1 Like

that would be nice, i´m keeping the fingers crossed it stays like that in a working condition :slight_smile:

@exoslime All today my X-Touch has remained connected. Thank you so much for your idea.

Now Steinberg need to look into this and see what is happening - and make a proper fix.

1 Like

awesome, i´m so happy that it worked for you as well

and yes, hopefully Steinberg is able to provide a proper fix

Very good. I think also that with the workaround Steinberg is able to find and fix the bug by comparing whats happening inside Cubase with / without the workaround.

I have had two problems since updating to 13.0.40. random disconnections and the device (FaderPort) not connecting on first startup of Cubase after restarting the computer.
Steinberg suggested disable…
In Studio > Studio Setup > MIDI Port Setup, uncheck the ‘Use Directmusic Device’ checkbox

and both problems have gone…until now.