MIDI reverse latency?!

Been using Cubase 6 for years and in the last year I’ve noticed all my MIDI parts have this weird reverse latency. I can record a part on my keyboard completely in time, but when I play it back, all of the notes are ahead of the beat by a fraction (but a very noticeable fraction) of a beat. I can copy and move them all since it seems to happen consistently across all notes, but that’s super cumbersome and not precise to what I played anyway.

I have not changed any settings with the MIDI source or keyboard so I can’t figure out how this started happening, nor do I see a way to change settings in Cubase. The latency numbers listed with the driver have also not changed in years. The MIDI device setup looks to be in order.

Help! I can’t really record any keyboard parts until this is solved. At least not efficiently.

Hi,

Is this your case?

Oh wow, that’s a great resource. Thanks @Martin.Jirsak
I went through a few of those steps though and still no change…

So I’m really stuck here. I’ve trouble-shot through everything I can find in the manual (including every mention of “latency”) and every component of the issue and it’s none of these:

-USB cable
-MIDI controller
-buffer size
-offset samples adjustment
-system timestamp adjustment
-MIDI preferences
-quantize
-snap to

What’s weird is that nothing major has changed with my system since it started doing this, and the files from 6mo ago with MIDI work and play fine. Please help! I am at a standstill with recording my new album til I fix this.

Hi,

What MIDI Driver type do you use, please? Could you attach a screenshot from the Studio > Studio Setup > MIDI Port Setup, please?

Could you try in the Cubase Safe Start Mode [Disable preferences], please?

Using DirectMusic and Windows MIDI inputs, doesn’t matter which - issue remains. Using DirectMusic Project MIDI output.

Tried in Safe Mode, no difference.

So apparently this is a longstanding issue all the way through at least Cubase 9:

I haven’t seen any correspondence from Steinberg about fixing this on several threads detailing many people having this issue. Which leads me to thinking I need to manually adjust all my MIDI notes unless i can afford upgrading to the current Cubase. Which is fucking tragic.

Hi,

Try to remove the DirectMusic MIDI In Ports. Does it work? If not, try to remove the Windows MIDI Ports. Does it work now?

Btw, with this setup, I expect you always record 2 MIDI Notes instead of 1, because it has been recorded from 2 MIDI ports (types).