Midi timing problem

Hi all,
I am on Cubase 9.5 Pro, Windows 7 x64 using Keystation 61 USB as mother keys controller. No outboard gear all in the the box. Using Behringer Xenyx 1204 USB as my mixer/audio device. Everything works well however when recording a midi part for example a small solo sax or guitar or something else from one of my plugins, (by the way no latency issues) so I record the 4 bar part then play it back and it is slightly out and in, just kind wavers about (only slightly ) but enough to hear it’s not as I played it, a little in front of the beat in places. So I play it again, slowing down my playing a bit, then play it back and it is still very very slightly in front in sections. It’s making me think that I play it like that but I don’t !
The Auto Quantize is OFF and there is no other Quantize (that I know of) which is working in the background.
This is so crazy.
I have checked and unchecked the ‘System Timestamp’ but it’s the same.
Can’t think of anything else that would effect my midi like that.
Anyone experienced this before? If so and you found the culprit I would surely appreciate your advise on getting this to behave itself and play back exactly what I recorded.

Thanks in advance.

i just re-install with cubase 9.5 on mac pro , have the same issue . would love to hear any solution to this matter , thanks

hmm, obviously we must be the only 2 people on the planet who experience this…

“ASIO Latency Compensation”?

Recording>MIDI Recording Specifics>Recording MIDI

If you perform a live recording on a VST instrument, you usually compensate the latency of the audio card by playing earlier.
In consequence, the timestamps are recorded too early.
If you activate > ASIO Latency Compensation > on the track list, all recorded events are moved by the current latency setting.

Preferences>Record>Record - MIDI>ASIO Latency Compensation Active by Default

MIDI Track Controls
Instrument Track Controls
Sampler Track Controls

The solution for this problem is the following :
1- Go to Transport->Midi Cycle Record Mode -> uncheck (Auto quantize in Record)
2- Play again
3- It’s done

Also having the same issue. Been having this problem since Cubase 3!! I can’t believe they haven’t fixed this yet. Ugh.

Figured this out FINALLY! None of the above suggestions worked, but what DID work was:

Studio -> Studio Setup -> VST Audio System
Then set ASIO Guard Level to “Low”

Cleared the issue as well as an annoyingly high latency level despite a super small buffer size on my audio interface.

1 Like

I’ve been having this issue for years. On Cubase 8 atm.

Does Steinberg really not care that their DAW can’t record midi notes correctly?

Every single other DAW I own can do this without any problems. It is seriously baffling that they’ve allowed this to continue for so long. I’ve tried every fix in this thread, and every fix in every other thread, and no matter what I do all midi notes get inserted EARLY. Sometimes it’s almost a full 16th note early!!

I’ve already purchased Live 10, and will likely stop using Cubase altogether over the next year if they really can’t be arsed to make this work properly.


I’m on Nuendo 10 so not sure this will apply, but I had the same issue with MIDI notes being shifted noticeably forward after recording.
The fix for me was found in studio/studio setup/MIDI Port Setup. I checked the box marked "Use System Timestamp for “Direct Music” Inputs and for me, this solved the problem.

Same issue. My fix was having only one device active in MIDI port setup. The one using DirectMusic. Make the others inactive. Also, place check mark on Use Device ‘DirectMusic’ and Use System Timestamp for ‘DirectMusic’. Hope it helps, good luck!

I also started having Midi Timing Issues when I updated from Cubase Pro 9.5 to Cubase 10 and still with Cubase 10.5. Windows 10, latest updates, MOTU MTP AV USB Interface with their latest driver. Midi simply chokes and notes do not sound and then they resumes. No matter if it is a Midi track with notes on it or simply playing with Monitoring On and Cubase stopped. Never had this happen in Cubase before. Very, very annoying.

In my experiences Developping VST efx ,
They dont use exact timing info about MIDI event within AudioBuffer.(=delta frame info)
All delta info is Zero , using Cubase as host !
(so maybe MIDI events like playing keyboard are push forward as Ha33y experienced)

But I checked StudioOne , delta frame info is propery stored !

then, I got great respect for presonus good job !

It is so strange , origin of VST didnt use their defined specification .
I heard that from Cubase SX , they didnt use delta frame info.

Is this a documented issue with 10.5? I am a new user and I am primarily wanting to use Cubase to record MIDI from external devices or my playing, and to sequence external MIDI devices.

Please use a proper audio interface - anything other than Realtek should work. Then select interface that in studio settings - vst audio system - Asio driver.

Been having the same problem: MIDI notes recording earlier than when performed. It’s a big problem and seems to just get crappier as time moves along. From I can gather, it’s a WINDOWS clock issue. The longer the PC stays on, the more the timing issue will get worse.

Steinbergs suggested the following fix:

"The first thing I want you to do is reset the program preferences back to a default setting to make sure that isn’t causing the issue here:

You can manually reset your application data by opening your File Explorer: C:\Users\Username\AppData\Roaming\Steinberg then move the folders that say Cubase 9.5 or any earlier version of Cubase you see to the desktop.

*If you don’t see the AppData folder, you must select View > Options > Change folder and search options. Select the View tab and, in Advanced settings, select Show hidden files, folders, and drives and OK.

Restart the computer and then launch Cubase again. Be advised the load time will take longer as it will be rescanning everything just as it did the first time you opened the program."

What’s interesting, is that this fix seems to work but it only lasts for a short time before the MIDI notes start slipping ahead of the actually performance. I can actually see the notes planting early as I play.

I wish someone (MS or Steinberg) would fix this issue.

I’ve been having this same problem with Cubase 11. Never had this problem with Cubase before. None of the solutions in this thread help me. As a working professional I feel pretty silly having to manually correct all of my performances in the midi editor. Total workflow killer.

1 Like

Well I am now also on Cubase 11 Pro and my original problem STILL EXISTS!! this is crazy…several versions on (from my original 9.5) with so much advancement and yet this is still an issue. I have to manually fix every note that I play. Honestly my playing is not that bad, I used to be a drummer years ago and my timing is pretty good, however when hearing it back in cubase, it is off. When I quantize, it shifts the notes even further away and i have to fix most of them by hand. Big time waster.

Have you tried Constrain Delay Compensation ?

PDC makes a tiny improvement, but the results are still way off. So, it’s not a work around at all.

mmmhh – I just don’t seem to have that problem – maybe there are some differences in our configurations?

There must be some latency related stuff going on.

Here are my Preferences settings that might be relevant? Or at least worth experimenting with?