Midi timing problem

Yes, I agree. It’s really troubling.
I’ve heard various explanations as to why it’s happening and work-a-rounds suggested that never really work.
The common explanation is that it’s a Windows issue. But this has been going on so long that you would think Steinberg would have figured out how to make the MIDI timing friendly with windows. Since the midi always plants early by the same amount, it seems logical that they would have compensated for this by now. Or, at the very least, put a switch in the program that allows you to easily compensate for the issue without nudging after every take.
Maddening.

This is exactly my experience with 10.5
it’s getting to the point where I am wondering if I should go back (cubase 5, honestly cubase 8 is as bad as 10.) or move on. It’s unacceptable that in this day, my only issue is with midi timing. Sadly…it’s the thing I require most from the application.

This is my problem too. It is so frustrating.
Real time midi keyboard playing is sluggish and chopped, lagging, midi playback is random and inaccurate, all over the place…early, late…
I have never been a fan of quantizing, mostly just selecting a few notes …maybe on the first beat etc. To lock together via quantizing. But now…in cubase 10.5 (going from 5), every note needs adjusting.
I am spending hours in a week moving notes around, something I never had to do before.

had this problem with some third party vst’s in CB 11.20 …ur solution helped! thanks

Hi,

Do you know this article, please?

I am having this issue since upgrading to 12 (all updates). Still working on it. MIDI recording earlier than performed.

Hi,

Have you read the article I mentioned above, please?

1 Like

@Martin.Jirsak yes, finally. And it was very informative. The problem is solved, sort of. When I changed the MIDI port setup to “System Timestamp” I got a closer approximation to accurate event placement. I have two MIDI input devices (Alesis Q88 and Nektar Panorama P1) and both are Windows compatible USB MIDI. I will stick with this setting for a while to see what happens. FYI I am on Windows 10 22H2 with a Focusrite Scarlett 2i2 3rd Gen interface. The other options - DirectMusic and WinRTMidi, with or without system timestamping, did not work as well. Very odd that I did not notice a problem until Cubase 12.

Since I noticed that my MIDI was displaying almost exactly a 32nd note before it was supposed to I tried adding a bar of 1/32 at the beginning of my project then immediately adding a 4/4. This seemed to work but I ended up being uncomfortable with it.

Thank you for your patience.

Hi,

You can also try to switch to the WinRT drivers.

As you said on the first post recorded notes become earlier on playback, it could be coming from the ASIO Latency Compensation function.
When you play live while recording, you are hearing tracks with a latency comes from ASIO buffer, then on playback, the notes will be shifted earlier by that amount, cubase records the timing which notes arrived to the engine not when it came out from monitors.
So try to switch these off, if you haven’t tried it yet.

ASIO Latency Compensation Active by Default

This determines the initial state of the ASIO Latency Compensation button in the track list for MIDI or instrument tracks.

If you record live on a VST instrument, you usually compensate the latency of your audio card by playing too early. In consequence, the timestamps are recorded too early. By activating this option, all recorded events are moved by the current latency, and playback sounds like during the recording situation.

1 Like