Midi track looping issue

I created a midi track with a 2 bar of drums playing in a loop.
When i hit the play button, it plays the loop twice and then goes into a 1 loop of silence and then comes ON. Sometimes i noticed am not at all hearing anything, then i will hear at random loop.

1 Like

… have you installed the latest version 1.1.10? We improved the MIDI engine for looping.

/Michael.

Yes installed the latest version. I was testing with the 1.1.10.629 version.

  • Created a MIDI track with Groove Agent SE
  • Created a custom drum beat and made copies of it and placed on on bar 6 - 7.
  • Put a marker on 6 - 7 bar and Pressed the cycle button to loop the midi part created in 6-7 bar.
  • The last part (Part 1) is selected
  • Hit Play button.
  • The drum loop cycles twice and on the 3rd cycle no sound coming from the midi drums, but the loop is playing on…
  • On 4th cycle onwards I started to hear sound at the middle of the loop.
  • This sound hearing and then no sound hearing issue is happening randomly…

Tried to recreate your project as close as possible, but the loop plays just fine.
How did you create the MIDI events? Also let us know about your system OS and Interface, thanks.

Sorry, you already said that you created it with GA SE, missed that. Also got confused because you posted similar issue in another thread.

I used Window 10 Pro OS. I use Scarlet 8i6 Focusrite interface.
On the screen shot on this tread, I manually created the drum loop with the piano roll. I didn’t drag and drop a pattern from Grove Agent SE.

I use the same audio interface with my Cubase 10 Pro on the same PC and I don’t have issue so far with the sound card.

As said, I tried to reproduce from your picture as similar as possible, incl. Part triggers. The loop plays just fine forever on 2 systems here.
As a last resort, you might send a project (use the new “Archive” function, otherwise we don’t get the MIDI data). But I honestly doubt that that will reveal your problem, unless you also have plugins etc in the mixer.
Does the CPU display show overload? What is your buffer size (latency) setting? And is the behaviour always exactly the same? Any hint that helps to reproduce, thanks!

I tried to zip the project and its almost 10mb. Is there a way i can send that file to you?
I tried attaching it here and here it only accepts max 4MB.

But then you have loads of other stuff in your project.
Could you not reduce it to the one Song/Part with the MIDI, check if the problem persists? What happens if you save the project, delete all Parts except the one in question, is the problem still there? Then you should have a tiny project :slight_smile:

Archive.zip (878.6 KB)
I used the Archive function and its only 879kb.
I just checked the Archive also the issue exists in that too.

I don’t have a plugin on the drum track. But I had 3 plug on the “Track 1” track which is muted.
I tried disabling the plugs on “Track 1” and still the issue presist.
CPU don’t show overloaded.
Right now i was using my internal PC’s sound card, so am not sure how to check the buffer size.
(When using cubase projects I use my external sound card which i set from 512mb to 1024mb buffer size, depends upon load)

It looks like I can reproduce your problem now, will report, stay tuned and thanks again!

That is relieving to know…
Also am seeing lot of crashing happening and application exiting…
May be i will put this as another thread…

crashes are the very least we accept, so please send us crash reports (documents/Steinberg/Crash Reports, starting with “VST LIve”), thanks.

Yes it does and it helped a lot finding the problem, will be fixed with the next version. Thank you so much for helping. The problem only reveals itself with certain tempi, such as 70 in your case.

I hope you were able to replicate the issue in “Drag a instrument pattern from groove agent to midi track messing up the drum loop - #5 by tmat” thread also.

VST Live Version 1.1.10 2022.11.7 23.25.22.328.zip (454.2 KB)
VST Live Version 1.1.10 2022.11.7 23.30.54.201.zip (282.7 KB)

Todays crash report

@tmat, it has crashed inside your KORG M1 Plug-In. Do you have any contacts to KORG? Can you please contact them to see why it has crashed? Meanwhile we are diving to your other crash log.

Thank you,
Michael.

… that one is fixed too. It happened with the MIDI Inputs color selector in the HUB (only for Windows). At the moment you need to select a color when the selector is visible. If not and you move on (Open Other, New Project, Cancel), it will end up in a crash or deal loop. Next Update.

Sorry,
Michael.