More weird trouble with changing "Duration"

Hi All

From a larger score I just extracted this violin part. I am trying to rewrite it in eighths and not sixteenths. So I’ve got insert mode on, and I’ve here just tried to do the first bar. As you see, it does make eighth note triples, but for some weird reason it makes the first eighth of the triplet a DOTTED eighth. This is driving me nuts. I’ve tried everything. I suspect something is weird with the file so I have attached it, also with screenshots.

I want to do the entire part eventually, copy it and paste it back into my score. I know there are some issues with Duration changes but this seems like a bug.

thank you as always

[ Ignore this post; I misunderstood the intention. ]

I understand this as using the “double note duration” feature from the Write menu–> Edit duration and ensuring Insert is on. When doing this I get much the same result (it will depend a bit on beaming options). This does in fact seem to be a confirmed bug — see this thread Error doubling note duration of tuplets/triplets with suggested workarounds