mp3 saving issue

Hello,

It seems there is an issue since last version.
I make a render in mp3 320 format -> ok
I make modification on the file and do : File/Save -> wavelab ask mp3 parameters -> I clic OK -> an asterisk is already after name of file (the file is not saved) and when I leave wavelab - ask again mp3 parameters because the file has not been saved.

Indeed

I have noticed the same behavior with rendered mp3 and .wav files. I think I can explain why, generally.

If I highlight part of a montage and render the selected audio to mp3 I get a new mp3 audio file on my hard drive, and in a new tab in my project. All good.

BUT… if I make any change to the newly-rendered .mp3 file and then save the file, WL saves the file but doesn’t seem to realize that it has been saved. The rendered mp3 file continues to show an asterix * on the tab next to the file name. No matter how many times I use CTRL-S to bring up a save dialog and then save the file, the asterix remains.

WL is saving the modified file. I can prove this as follows: go through the CTRL-S process once to save the modified mp3 file, and then close it without saving. The changes are saved.

Nevertheless, when I actually close the mp3 file, I am always prompted to save it again, even if my last action was to save it. Same result if I close the entire project.

From time to time, if I close and then re-open my rendered mp3 file, WL generates a message like this:

C:\Users\[name]\AppData\Local\Steinberg\WaveLab Pro 10.0\cache\ace97b447f1e9712b6a855ed69e7ca8a\sample.mp3-956f19a8688ea90339df9d101224413b
This file could not be accessed. It is already in use by this application or another.

In other words, Windows seems to be telling WL that the file is still in use.

I have seen this Windows v. WL file lock problem in another context: After closing files, Windows cannot move or delete them because, Explorer says, “the file is open in Wavelab Pro 10.0.” This can last for hours. I have to close Wavelab to release the file lock.

Sometimes, even WL tells me this! If I render a montage to .wav, close .wav file, and re-render the montage keeping the same destination file name, WL occasionally tells me that I cannot access the file because it is in use by “another process or program”, or that I have to choose a different name because I cannot use the name of a file that’s already open in Wavelab 10.0!

Seems to me that the trouble here is between WL and Windows, releasing file locks when creating temporary files while rendering.

Hope this is helpful.

This has been an ongoing problem for a while. FWIW

I believe you.

Here’s an example:

I realized that I hadn’t unchecked “Bypass Master Section” when I rendered, so I closed the newly-rendered file, called mmf1998-10-17.tracked+eq.wav, and tried to re-render it. But it’s still open in Wavelab, apparently.

Another variation: I have an open filed called mmf1996-10-11.tracked.wav and I am using Process > Auto Split to break it up by markers into separate files in a subfolder underneath the folder containing this .wav file I just named. The subfolder is, naturally, called mmf1996-10-11.tracked because that’s what Wavelab names it.

Because I’ve already does this once, that subfolder already exists. Normally, Wavelab simply writes to the folder, over-writing any files with the same name if needed. Not this time. Wavelab creates the folder, but then stops before splitting any files into it with the following error message.

If I specify a different folder, like “dummy.folder” then it works OK. The problem seems to be only when the folder name is based on the name of the file being split.

I just upgraded (from WL Elements 10.0.50) to WL Elements 10.0.60 (build 174), but the issue of not being able to save a file with a simple Ctrl+S , without being asked again to save the file when quitting WaveLab, still persists. It may not be a major issue, but is rather annoying and, sorry to say, looks like Steinberg isn’t paying much attention to WL Elements, which is a pity.

Also, can anyone indicate how to set saving defaults? See separate entry at How to Set Saving Defaults in WaveLab Elements 10. Creating presets only seems to work when Saving As, but IMO it should also work for a regular Save.

Regards.

Greetings Babaorum,
Has your issue ever been solved? If so, I would appreciate knowing how you managed. I’m having the same or a very similar problem, and none of the proposed solutions (e.g., updating driver) seem to work.
Thanks in advance for some feedback.
Luc

1 Like