MR816 and Win10 - six days of frustration and counting...

Hey all;

I had everything working just fine on a Windows 7 machine. I got a new computer (refurbished) and got everything installed just fine. The device manager shows no cautions/errors, etc.

I am using the same Texas Instruments chipped firewire card and using the “1394 OHCI Compliant Host Controller (Legacy)” driver.

After much fiddling the other day (very similar to what I will outline below, except I also experimented with using alternate FW ports on both the MR816 itself and on the FW card - which I did not try yet today, as everything worked yesterday…), I got everything working. I opened a project and did some mixing. No further problems.

I generally leave my computer on and let it go to sleep, but I turn off the MR816.

When I turned on the MR816, Cubase could not load the MR816 ASIO driver.

In short, what I notice is that the driver fails to initialize, but upon installing and re-installing (using various methods) the drivers, the one that never appears in the device manager is the Steinberg MR816 WDM driver. Once I got this to appear the other day, everything worked fine. (even though it is only the ASIO one that I ever use in Cubase)

System - Windows 10 - 64-bit
Dual-core 3.0Ghz with 6GB RAM


Here are the steps I followed and the results:

turned off and restarted unit - failed to initialize
noticed that wdm driver was dropped in device manager
uninstalled and reinstalled driver - failed to initialize
turned off unit
uninstalled extension; tools; driver (by running setup.exe in each of the individual folders from the install folder)
disabled AVG antivirus
ran setup.exe in root folder
installed MR Editor; MR extension
went to device manager - saw Steinberg FW Bus
turned on MR816 - steinberg MR816 series added
went to task bar and clicked Yamaha Steinberg FW driver

  • control panel greyed out
  • MR Editor - no device found
    re-start computer and MR816
    error: Steinberg FW Driver - Failed to initialize

Turned off MR816
went to control panel
uninstalled MR Editor and MR Extension and Steinberg FW Driver
reinstalled from setup.exe in root folder
device manager - shows Steinberg FW Bus
turned on MR816
shows Steinberg MR816 Series (but not WDM driver)

  • control panel greyed out and MR Editor = “no device found”

Shut off computer

  • BIOS - PCI devices
  • all items either IRQ 5 or IRQ 10
  • changed firewire card to IRQ11, which automatically changed a few other USB controllers to 11 along with it

Restart
Steinberg FW Driver - Failed to Initialize

Disabled AVG
Went to Settings/System/Apps and Features
Uninstalled MR Editor; MR Extension; Steinberg FW Driver
turned off MR816
ran setup.exe and installed everything again
device manager - shows Steinberg FW Bus
turn on MR816
shows Steinberg MR816 Series (still no WDM drivers)
went to task bar and clicked Yamaha Steinberg FW driver

  • control panel greyed out
  • MR Editor - no device found
    went to device manager - view / resources by connection
    firewire card is on IRQ 20 along with three instances of Intel® ICH10 Family USB Enhanced Host Controller
    turned off MR816
    Steinberg MR816 series disappeared
    turned MR816 back on
    Steinberg MR816 series reappeared

turned off MR816
did factory reset

device manager still shows Steinberg MR816 Series and Steinberg FW bus

restart computer - Steinberg FW Driver - failed to initialize

  • device manager still shows Steinberg MR816 series and Steinberg FW Bus, but no WDM driver

What I still have not tried is taking out the FW card and trying it in a different PCI slot.

Any thoughts?

Thanks!
Chris

Note: I disabled AVG in the above steps because yesterday, it kept blocking setup.exe as a virus upon installing the drivers.

Chris

Well, I seem to have it solved. /shrug/

I did so many things, though, that it is hard to tell what worked.

After a few more shut-downs and restarts and uninstalls and reinstalls of the drivers, I did do some other things:

-tried PCI slot #2 (in this slot, it wouldn’t even load either of the other two drivers it did before) and PCI slot #3

  • can of air and cleaned out FW ports and plug and PCI slots
  • re-installed firewire legacy drivers (necessitated by putting FW card into new PCI slot - Windows automatically installed the “newer but less reliable” driver)
  • ran setup.exe as administrator (didn’t work on PCI slot #2)

And now that the WDM driver has installed, I can open the control panel and open the tools for MR and get sound out of Cubase.

I’m reporting this here to give hope for others who may experience this problem.

It would be helpful if someone weighed in as to what might be going on though.

Thanks!
Chris

Alright. This is ridiculous.

Got back today. Did some work in Cubase no problem a few hours ago.

Came back later this evening. Turned on MR816 and the WDM driver is gone and the driver fails to initialize.

Again.

I haven’t done anything except walk away from it.

Chris

Hmmm… I discovered in the device manager under “view” - show hidden devices. The WDM driver does, indeed, show up there.

Under properties, under the “events” tab, it says:

9:17 pm - Device Install Requested - Device YFWBUS\AUDIOSTREAM44&ADAPTER_01\6&2d708c26&3&Y001 requires further installation.
9:17 pm - Driver service added (YFWAUDIO) - Driver Management has concluded the process to add Service YFWAUDIO for Device Instance ID YFWBUS\AUDIOSTREAM44&ADAPTER_01\6&2D708C26&3&Y001 with the following status: 0.
9:18 pm - Device installed (yfwdev.inf) - Driver Management concluded the process to install driver yfwvdev.inf_amd64_0e8eb5b8f095efd0\yfwvdev.inf for Device Instance ID YFWBUS\AUDIOSTREAM44&ADAPTER_01\6&2D708C26&3&Y001 with the following status: 0x0.

Under the general tab, under Device Status, it says - Currently, this hardware device is not connected to the computer. (Code 45). To fix this problem, reconnect this hardware device to the computer.

Under “driver”:
Driver Provider: Yamaha Corporation
Driver Date: 12/14/2015
Driver Version: 1.5.1.1
Digital Signer: Yamaha Corporation

Under Administrative events, I see a few entries similar to the following: (all system warnings)
The DSM service was delayed by 33 seconds for a driver query/download/install on device ‘V1394\YFWBUS\25B200000’
The DSM service was delayed by 56 seconds for a driver query/download/install on device ‘1394\YAMAHA&MR816_SERIES\00A0DE000000C3C1’
The DSM service was delayed by 22 seconds for a driver query/download/install on device ‘V1394\YFWBUS\25B200000’
The DSM service was delayed by 25 seconds for a driver query/download/install on device ‘V1394\YFWBUS\25B200000’
The DSM service was delayed by 30 seconds for a driver query/download/install on device ‘V1394\YFWBUS\25B200000’
The DSM service was delayed by 65 seconds for a driver query/download/install on device ‘1394\YAMAHA&MR816_SERIES\C1C3000000DEA000’

…etc…

CT

Tried disconnecting any/all USB devices and disabling them in the device manager:

  • printer
  • wifi network adapter
  • webcam

Exception: My keyboard/mouse connect via a wireless usb device. This stayed connected out of necessity. I’ve been using it for years.

Restarted computer and MR816. Double-checked device manager to ensure those other usb devices still disconnected / delisted.

Still fails to initialize.

WDM driver still shows up in “show hidden devices” under the device manager with the same notations itemized above.

Chris

I should also add that, under the previous system, I did upgrade the firmware to version 1.1.0.

I have checked (when it actually worked) that the firmware is still showing as 1.1.0 - as it should be.

Chris

Reluctantly calling this tentatively solved…

I uninstalled AVG antivirus. I had forgotten I had also installed something called AVG Zen which… I can’t even remember what it does. It extends protection to all of your devices or something. /shrug/ I uninstalled it too.

I also uninstalled the MR Editor, Steinberg FW Utility, etc., shut down, reinstalled all the Steinberg Driver stuff (run as administrator), shut down again and re-started.

Drivers are loading up fine, playing both web content and within Cubase.

Of course… I have no antivirus now. :-/

I’m considering reinstalling AVG without the Zen thing… but dreading the possibility of spending a heap more time screwing around with this whole thing.

I’m also recognizing that this may, once again, be temporary and will find myself back to the drawing board again, only without an antivirus.

Not sure what to do.

Chris

OH, COME ON!!

Got up this morning, got on my computer, and the driver is gone again. Re-started. “Failed to Initialize.”

GRRRRRRRR!!!

Chris

OK. I can tentatively say that the hardware itself is not the problem.

I removed the FW card and put it back into the old computer, plugged in the MR816 and (after a false start where I put the FW card into the wrong PCI slot) on the second try, it came right up. Just like it always did.

I only say that this is tentative based on the fact that I had it working on the new computer at least three times, after which it stopped working.

I’m now wondering if it has something to do with Windows Power Management settings, but… not feeling like that is it. I’ve poked around in there and there are options for USB devices, but not for FW devices.

??

/sigh/

Chris

Well, tried to reset windows 10 but that didn’t work. Not that it failed to get my drivers to load, but it just failed to do… anything. It didn’t run. Even when attempted in “advanced startup options.”

Rolled back to Win7. Reinstalled driver (run as administrator), restarted the machine, fired up MR816… and it worked first try.

Crossing my fingers that re-installing Win10 will yield similar success.

Chris

Installed Win10. Changed firewire drivers to legacy version. Installed Tools for MR.

Failed to initialize.

Screw you, Windows 10. Back to Win7.

CT

Aaaaaand… now the same thing is happening in Win7.

The only thing I have installed is the Tools for MR, driver, etc. and the wifi adapter driver.

I haven’t even installed Chrome, Cubase, etc.

My webcam and printer are not connected or installed.

W. T. F.

Chris

So, I’m on Win7 now and have uninstalled and reinstalled the drivers… again.

In order to rule out driver conflicts, I have also disabled “SoundMAX Integrated Digital HD Audio” under the device manager.

In the device manager, the Steinberg FW bus shows up, and under properties, says it is working fine.

The MR816 series shows up too. Under properties, it says “no drivers are installed for this device.” Although, this doesn’t sound right… under “driver file details” it says C:\Windows\system32\drivers\ksthunk.sys
When I click on “update driver” and browse for the driver on my computer, I go to C:\Program Files (x86)\Yamaha\FWDriver\Drivers (include subfolders is checked), I get the message “Windows has determined the driver software for your device is up to date. - Steinberg MR816 Series.”

The WDM driver does not show up in the device manager, even when I click on View > Show Hidden Devices.

Chris

Why are you installing the firewire legacy driver?

It’s for old firewire devices with no support for 64 bit OS, try it without!
I used the legacy driver when focusrite told me to do so for old focusrite soundcards and the liquid mix, the mr816 has run with me without legacy drivers, it did his job but with some crackling and drop outs in minimal latency mode, my problem was that my motherboard has a VIA chipset, so I sold it.

https://www.steinberg.net/en/support/knowledgebase_new/show_details/kb_show/mr816-resolving-audio-performance-issues.html

https://www.steinberg.net/forums/viewtopic.php?f=209&t=91278&p=510355&hilit=Legacy+fw+driver+windows+10#p510355

CT

Is the via chipset a problem with Cubase, firewire, or the mr816x?

Chris

The VIA chipset was/is a problem on many fw devices. Many manufacturers advise to use the TI chipset.
I know the Microsoft article about legacy firewire, it’s mainly a work-a-round for old I-Link devices like videocams and photo devices.

In my opinion it isn’t needed by relative new hardware and can cause extra problems.

For the record, I’m totally done with FW, had many devices and all gave problems from time to time.

Ah, OK. You’re talking about chipset on the fw card itself. Yes, my card has the TI chipset.

I thought you meant motherboard chipsets.

Chris