Multi-track drum editing...

I am in desperate need of some serious drum editing help from anyone who’s really good at multi-track drum quantizing. I also need ideas of a place to post mp3 files as examples to show what’s going on. I have watched every YouTube video on this, read and re-read the manual time and time again, watched the quick start videos, and played with every setting and variable the quantize panel has, and I just can’t make it work and I’m pulling my hair out over it.

Please, somebody help!!

Feel free to contact me here or my email is I could really use the help.



I’ll go for a complete guess as there is zero info to go on here:

Are the drums recorded to a click track?
If not have you created a tempo map to follow them before starting the Multi Track edit?

If as is likely, that is not your issue then describe what you ARE doing & where you hit a problem. Try be detailed in your description or you can guarantee you will miss out the bit you are getting wrong!

There are million places to post mp3 files but tbh an audio example may not help much. What about a screencap video of it going wrong? (Licecap will do it for free if you’re PC)

Hi Grim,
Sorry, I was seeing if anyone would offer to help before typing a big description and have no offers to help.
Jam2nite and Rob - thanks to you guys for replying via email. I’ll post the problem here in one place so all can see it.

OK - here’s what I’m starting with. It doesn’t help much that you can’t record or export the click as part of the mix - that seems like a no-brainer feature to have, but you can tell these tracks are out of time - the drummer is up and down all over the place just in this simple pattern.

Were these recorded to a click? Yes and no. I am a drummer myself, but not doing the drumming on this - I’m doing the recording and mixing. Their drummer has never recorded before and was new to all this and he just couldn’t follow a click to save his life. So, we came up with the idea to have ME play with the bass player and the guitarist to a click, then mute my drums and instead of leading the band, he would follow the bass and guitar which were done with a click, hopefully helping him stay in time. Obviously, it didn’t work.

So, here’s where we start - the kit parts are very simple because there’s supposed to be a lot of hand percussion on top of it.

Here’s the raw un Q’ed tracks:
IntroUnQed.mp3 (533 KB)
Here’s a screenshot of the same thing
As you can see, I’ve split just this intro section, bounced selection, tracks are in a folder, group editing is turned on and the tracks are selected.

And then I find there’s a 3 attachment limit on the posts…eh…brick walls everywhere you turn…continued on next post…

So, next I go set hitpoints for kick, hat and LOH (no snare on this track)…

Bring up the quantize panel, set kick to 5 stars, hat to 4, LOH to 3 and slice…
(Zoomed into the fill near the end)
Quantize to 1/16th notes:
Then finally crossfaded:

This is what I get on playback:
IntroQed1.mp3 (533 KB)
Here’s what it looks like:
What in the world am i doing wrong? This seems such a simple pattern that I can’t believe I’m having SO much trouble with it. No matter what variations I make to the Quantize settings - changing the priorities and levels, trying a higher quantize value (have gone up to 64th notes, try the ‘tick’ settings, shortened crossfades, etc…NOTHING makes this simple pattern play in time with ITSELF let alone with a click.

What am I doing wrong? It works so perfectly in the tutorial videos - in fact, the don’t even bother chunking it into sections, they just select all the drum tracks and magically they all just line up. Why can’t I make that happen here?

ANY help is appreciated… :slight_smile:


The drums appear to be played way ahead of the click (not too uncommon). I would advise that you move all the drum tracks back in time a bit BEFORE you try to quantize them. Try to line them up so that you are splitting the difference between the latest and earliest hits versus the grid. I almost always use 1/16 note quantize, but if the drummer plays triplets etc. you will have to do those sections separately with different settings. Also, if the drummer is not that good you still may have a few hits that will quantize incorrectly if it is played really early or really late. I usually perform a “Move to Origin” (I made a key command of “Shift-O” for this) for these to get them back to where they originally were before the were incorrectly quantized and manually place them.

The good news is that the feature does work really well once you get the hang of it. SB did a good job on this one…

Fish, thanks for the reply…if I understand you correctly, you’re thinking the problem is because the drums are ahead of the click? Wouldn’t your suggestion of moving back in time make them even MORE ahead of the click? Or am I misunderstanding you?

The hits will of course go to the closest 16th when you quantise which may actually be further away from the correct beat if the timing is more than a 32nd out. If you can move all tracks closer to the correct beat as fishtank suggests you can use the quantise.

But if the timing is very variable your only option may be to slice & then manually move a section at a time to be roughly on the beat before quantising.

The demo videos will all feature material that is already pretty close…so easy to quantise.
If you have a poor drummer it just isn’t a simple job to correct…you can end up spending hours manually moving everything around.

In my experience, if a drummer is incapable of playing to a click then probably best to track him & the band together without one & make a tempo map afterwards to help editing or to add midi stuff. The tempo will vary but the timing will hopefully be better.

There are different (preset) algorithm settings in the audio editor. One being drums. Are you sure that’s set? Because it could be the detection is set for vocals etc.

Unless there’s a lot of loud cymbal wash spilling everywhere the drum peaks should be fairly easily detectable by the system.

Those videos look nice and easy but they know the settings inside out but I don’t think all of the details are in all of them. Probably depending on what the editor thinks looks good.

Not read the whole thread so apologies if I missed a mention of this already.

They were set to the default elastique Pro - Time…I changed them all to standard drums, deselected then re-selected edit hit points on each drum track and quantized again…made no difference.

Hey Mike. It’s Rob here … did you chek if all the hitpoints were properly detected (or placed)? you can manualy adjust hitpoints if some are not right. if they’re all ok I guess the drummer is too off sometimes and the quantize it to a later point. what you can do in that case is cut just those parts where the quantize is wrong (before quantizing) and then quantize then you can try to quantize just those parts with a lower value like 1/4 and if that doesn’t hep, you can alwaise time stretch those hits to make them on time (with the moving applies time stretch too andmake sure you use elastic pro algoritm when time stretching). If this still doesn’t fix it, Batch export those drum files to mp3 and send them to me with the tempo of the song and I’ll try something here.

Sorry for the typo … it’s late :wink:

Couple of things.

One, you can use the threshold to set the sensitivity of the beat detection.
Then you can edit the hit detection to make sure all the correct beats for that track are selected.
once sliced and quantised, any wrongly quantised bits can be undone by selecting the parts that are wrong (highlight) and undo quantise (from the quantise panel) then use slip edit over the wrongly quantised parts to move them towards the correct quantise points, then re-quantise (selected)
Probably no point in hit detection on the overheads.

Then once all parts are playing correctly, close gaps and crossfade.
If any of the close gaps/crossfade points cause trouble they can also be selectively undone and made to play the game.

Please forgive me if I have missed the point …but having downloaded your mp3 - my process was this:

  1. determined ‘correct’ tempo ~ 84.5bpm
  2. set project to same tempo
  3. manually warp hitpoints to grid

The challenge is that the timing is really off on sections, so one has to time stretch to these hits to align them to the grid. I assume that this is a problem on the individual tracks as well and that time-stretching to grid would be required as well…

Hope it helps…

Thanks for all the tips, guys…I seem to be finally getting it to work most of the time - the biggest tip was moving the tracks closer to the click than they were and then it quantizes better. That should be in the manual, lol…
Still, can someone explain what’s happening when you quantize, crossfade and then like the attack of just one or so kick notes gets cut off?

Manually grab the warp tab slightly before the attack … if you’ve used the auto funtion, individual tabs can be deleted or moved - check out ‘warp’ for Cubase on Youtube

Manually grab the warp tab slightly before the attack … if you’ve used the auto funtion, individual tabs can be deleted or moved - check out ‘warp’ for Cubase on Youtube

Manually grab the warp tab slightly before the attack … if you’ve used the auto funtion, individual tabs can be deleted or moved - check out ‘warp’ for Cubase on Youtube

I think he gets the point now :laughing: