Multiple audio outputs on the same ASIO driver.

Hi, whenever I use Cubase 8 (artist) it causes to “crash/disrupt” other software that is playing sounds. For example:

When I am listening to a song on Youtube and switch to Cubase the song stops and when I go back in this case Youtube cannot play the song anymore and it forces me to do a refresh. (This happends with everyting like soundcloud, mp3’s on my desktop etc…)

Now, I know there is a option in cubase that allows me to play sound from other software but it requires me to completely minmize Cubase and I can only listen to it whenever I am not using Cubase.

Is it possible to play both sound from any software and Cubase at the same time, I have seen it work in Fruity Loops 12 so I assume it could be done in Cubase aswell?

So I’ve been doing some research for myself and found this, which should solve my problem:

https://www.steinberg.net/forums/viewtopic.php?f=34&t=48

Problem with the client above is that it does not support 64-bit Cubase. Is there some similair software that allows me to do the same as the Multi-Client but that works with a 64-bit Cubase?

I have installed cubase as 32 bits aswell just to test out if the multi server works but also in 32-bits the “ASIO Multi Server” says no clients found on either ASIO4ALLv2 or Generic Low Latency ASIO Driver.

What could be the problem?

Another update here, I had to change the ASIO4ALL in cubase to ASIO Client (generated by the multi server) to let it detect Cubase. Now, I can play sound from my browser and work in Cubase without the browser to crash and stop playing any sound, but even though Cubase is producing sound I cannot hear that sound (no output). The audio outputs are connected. If anyone reads this before I have fixed my problem and knows what I should do next please respond.

Ok I got it working, I totally ditched the ASIO multi server and followed this explaination that I found on another forum:

I’ve solved this issue for those who want to use ASIO4ALL on Windows 7/Vista.

A program called Virtual Audio Cables (> http://software.muzychenko.net/eng/vac.htm> ) enables you to route audio to your main sound device, and since it uses a virtual WDM driver, it doesn’t cause the same problem. Here is how to do it:


Buy Virtual Audio Cables (or you can find it on the internet somewhere if you search, although I don’t condone piracy)
Install it
Go to Control Panel -> Sounds, click on the Recording tab, right click Line 1 and go to Properties. Click on the Listen tab, check “Listen to this device”, select your main audio device under “Playback through this device:” and click OK for both screens. You’re done.
Now configure ASIO4ALL: enable the output for “Virtual Audio Cable” only and check “Force WDM Driver To 16 Bit” (I find that not doing this introduces extra latency), and disable the output for your main audio device


Now you can use your sound fully while using ASIO4ALL on Windows 7/Vista, and if you want to record the output of ASIO4ALL, you can do so using the Line 1 recording device. Note that we didn’t set the Line 1 playback device as default, so anything else you play will still go through your main audio device and won’t be recorded. If you want to record additional sounds, make sure it’s playing through the Line 1 playback device as well.

Hope this helped!